手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助把三个指标合并不重叠

[通达信]
设置
1915 3 梁小全 Lv.5 发表于 · 2020-2-8 21:57 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
将下面三公式合并但不要 重叠     如图

VAR1:=EMA(CLOSE,2)-EMA(CLOSE,89);
VAR2:=EMA(VAR1,30);
VAR3:=2*(VAR1-VAR2)*10;
VAR4:=POW(VAR3,3)*0.1+POW(VAR3,2);
VAR5:=IF(VAR3>0.015,VAR4,0)/45;
拉升资金:VAR5,COLORRED;
VAR6:=EMA(CLOSE,2)-EMA(CLOSE,150);
VAR7:=EMA(VAR6,100);
VAR8:=2*(VAR6-VAR7);
VAR9:=POW(VAR8,3)*0.1+POW(VAR8,1);
主力资金:IF(VAR8>0.1,VAR9,0)*5;
GZ:=拉升资金+主力资金;
关注:GZ>0 AND REF(GZ,1)=0,NODRAW;
STICKLINE(关注>0,10,0,1,0),COLORMAGENTA;





XA_1:=VOL*CLOSE*100;
XA_2:=SUM(XA_1,1)/(SUM(VOL,1)*100);
XA_3:=5;
XA_4:=EMA(XA_2,XA_3);
主力资金:(XA_2-XA_4)*100/XA_2,NODRAW,COLOR00EEFF;
资金趋势:SUM(主力资金,4),NODRAW,COLORRED;
DRAWBAND(资金趋势,RGB(180,0,0),0,RGB(0,180,80));
STICKLINE(主力资金>0,0,主力资金,2,0),COLOR00EEFF;
STICKLINE(主力资金<0,主力资金,0,2,0),COLORCYAN;


JJ:=(HIGH+LOW+CLOSE)/3;

QJ0:=AMOUNT/IF(HIGH=LOW,4,HIGH-LOW);

买1:=QJ0*(MIN(OPEN,CLOSE)-LOW);

买2:=QJ0*(JJ-MIN(CLOSE,OPEN));

卖1:=QJ0*(MAX(CLOSE,OPEN)-JJ);

卖2:=QJ0*(HIGH-MAX(OPEN,CLOSE));

DT:=((买1+买2)-(卖1+卖2))/10000;

主力持仓:SUM(DT,66),COLORWHITE,LINETHICK1;

STICKLINE(DT>0,主力持仓,主力持仓+DT,1,0),COLOR0000FF; STICKLINE(DT<0,主力持仓+DT,主力持仓,1,0),COLOR00FF00;

附件

指标.JPG
休闲者68
Lv.6
发表于 2020-2-9 17:34 复制 查看全部楼层
梁小全 发表于 2020-2-9 12:49
红线与黄线向上移一点不要被第一公式盖住

红线与黄线上下是由赋值决定的,改赋值就失去原指标的思路了。
梁小全
Lv.5
发表于 2020-2-9 12:49 复制 查看全部楼层
休闲者68 发表于 2020-2-9 12:21
{只能叠加两个,三个都叠加指标压缩的没法看}
VAR1:=EMA(CLOSE,2)-EMA(CLOSE,89);
VAR2:=EMA(VAR1,30);

红线与黄线向上移一点不要被第一公式盖住
休闲者68
Lv.6
发表于 2020-2-9 12:21 复制 查看全部楼层
{只能叠加两个,三个都叠加指标压缩的没法看}
VAR1:=EMA(CLOSE,2)-EMA(CLOSE,89);
VAR2:=EMA(VAR1,30);
VAR3:=2*(VAR1-VAR2)*10;
VAR4:=POW(VAR3,3)*0.1+POW(VAR3,2);
VAR5:=IF(VAR3>0.015,VAR4,0)/45;
拉升资金:VAR5,COLORRED;
VAR6:=EMA(CLOSE,2)-EMA(CLOSE,150);
VAR7:=EMA(VAR6,100);
VAR8:=2*(VAR6-VAR7);
VAR9:=POW(VAR8,3)*0.1+POW(VAR8,1);
资金:IF(VAR8>0.1,VAR9,0)*5;
GZ:=拉升资金+资金;
关注:GZ>0 AND REF(GZ,1)=0,NODRAW;
STICKLINE(关注>0,10,0,1,0),COLORMAGENTA;

XA_1:=VOL*CLOSE*100;
XA_2:=SUM(XA_1,1)/(SUM(VOL,1)*100);
XA_3:=5;
XA_4:=EMA(XA_2,XA_3);
主力资金:(XA_2-XA_4)*100/XA_2,NODRAW,COLOR00EEFF;
资金趋势:SUM(主力资金,4),NODRAW,COLORRED;
DRAWBAND(资金趋势,RGB(180,0,0),0,RGB(0,180,80));
STICKLINE(主力资金>0,0,主力资金,2,0),COLOR00EEFF;
STICKLINE(主力资金<0,主力资金,0,2,0),COLORCYAN;
查看全部打赏
  • 梁小全+10理想币 +1共享币 : 愿有明月,驱散黑暗,带来光明;
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表