手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助改编成选股公式

[通达信]
设置
1905 2 我在理想18 Lv.4 发表于 · 2020-2-9 10:09 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请老师,就指标出现洋红柱时编选股公式(如下图),谢谢老师!
DIF:EMA(CLOSE,9)-EMA(CLOSE,150),NODRAW;
DEA:EMA(DIF,12),NODRAW;
MACD:2*(DIF-DEA),COLORSTICK;
DIK:4*DIF-3*DEA,COLORYELLOW;
DED:=EMA(DIK,1),COLORGREEN;
IF(C>DED,DED,DRAWNULL),COLORRED,LINETHICK3;
IF(DED<=REF(DED,1),DED,DRAWNULL),COLORGREEN,LINETHICK3;
启动点:=MACD<0 AND MACD>REF(MACD ,1) AND REF(MACD ,1)<REF(MACD ,2)
AND REF(MACD ,2)<REF(MACD ,3)
AND REF(MACD ,3)<REF(MACD ,4){ AND DYNAINFO(17)>2.5,NODRAW,COLORWHITE};
STICKLINE(启动点,3,MACD,2,0),COLORMAGENTA ;
{分界线:0,COLORFF00FF;}
{DRAWICON(启动点,20,11);}
STICKLINE(MACD>REF(MACD,1) AND MACD>0,0,MACD,1.8,0),COLOR000055;
STICKLINE(MACD>REF(MACD,1) AND MACD>0,0,MACD,1.1,0),COLOR000099;
STICKLINE(MACD>REF(MACD,1) AND MACD>0,0,MACD,0.6,0),COLOR0000BB;
STICKLINE(MACD<=REF(MACD,1) AND MACD>0,0,MACD,1.8,0),COLOR40FF00;
STICKLINE(MACD<=REF(MACD,1) AND MACD>0,0,MACD,1.1,0),COLOR40FF00;
STICKLINE(MACD<=REF(MACD,1) AND MACD>0,0,MACD,0.6,0),COLOR40FF00;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,1.8,0),COLOR000055;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,1.1,0),COLOR000099;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,0.6,0),COLOR0000BB;
STICKLINE(MACD<=REF(MACD,1) AND MACD<0,0,MACD,1.8,0),COLOR40FF00;
STICKLINE(MACD<=REF(MACD,1) AND MACD<0,0,MACD,1.1,0),COLOR40FF00;
STICKLINE(MACD<=REF(MACD,1) AND MACD<0,0,MACD,0.6,0),COLOR40FF00;

附件

tdxjietu1.JPG
我在理想18
Lv.4
发表于 2020-2-9 10:47 复制 查看全部楼层
许昌舍得 发表于 2020-2-9 10:36
DIF:=EMA(CLOSE,9)-EMA(CLOSE,150);
DEA:=EMA(DIF,12);
MACD:=2*(DIF-DEA);

谢谢许昌舍得老师!论坛因您而精彩!
许昌舍得
Lv.6
发表于 2020-2-9 10:36 复制 查看全部楼层
DIF:=EMA(CLOSE,9)-EMA(CLOSE,150);
DEA:=EMA(DIF,12);
MACD:=2*(DIF-DEA);
DIK:=4*DIF-3*DEA,COLORYELLOW;
DED:=EMA(DIK,1),COLORGREEN;

启动点:=MACD<0 AND MACD>REF(MACD ,1) AND REF(MACD ,1)<REF(MACD ,2)
AND REF(MACD ,2)<REF(MACD ,3)
AND REF(MACD ,3)<REF(MACD ,4){ AND DYNAINFO(17)>2.5,NODRAW,COLORWHITE};
XG:启动点;
查看全部打赏
  • 我在理想18+20理想币 +2共享币 : 很给力,理想因你而精彩;
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表