手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙拼接两个指标

[通达信]
设置
1800 1 一位道友 Lv.2 发表于 · 2020-2-9 10:10 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
老师一下是我的两个监测资金的指标,请老师帮忙拼接一下,要求是在一个指标上面同时显示这个两个指标的共同效果,我自己拼接了一下,测试是可以通过。但是效果就不行了,需要里面进行更改,还得麻烦各位老师!!万分感谢!!

第一个;

K1:=IF(CLOSE>=REF(CLOSE,1),HIGH-OPEN+CLOSE-LOW+CLOSE-REF(CLOSE,1),HIGH-OPEN+CLOSE-LOW);
K2:=IF(CLOSE<=REF(CLOSE,1),OPEN-LOW+HIGH-CLOSE+REF(CLOSE,1)-CLOSE,OPEN-LOW+HIGH-CLOSE);
DT:=VOL*K1/(K1+K2);
KT:=VOL-DT;
买量:=SUM(DT,3);
卖量:=SUM(KT,3);
DX:=EMA(买量-卖量,5)*VOL/CAPITAL*100;
STICKLINE(DX>0,0,DX,2,0),COLOR000088;
STICKLINE(DX>0,0,DX,2,0),COLOR0000AA;
STICKLINE(DX>0,0,DX,2,0),COLOR0000CC;
STICKLINE(DX>0,0,DX,2,0),COLOR0000EE;
STICKLINE(DX<0,0,DX,2,0),COLOR008800;
STICKLINE(DX<0,0,DX,2,0),COLOR00AA00;
STICKLINE(DX<0,0,DX,2,0),COLOR00CC00;
STICKLINE(DX<0,0,DX,2,0),COLOR00EE00;
YX:=BARSSINCE(DX)+1;
QM:=BARSLAST(DX<=0);
主力强买:IF(QM<0,YX,QM),COLOR00FFFF;
QM卖:=BARSLAST(DX>=0);
主力强卖:IF(QM卖<0,YX,QM卖),COLOR00FF00;
力度:(主力强买-主力强卖),COLORRED;

第二个;

VAR1:=EMA(HHV(HIGH,500),21);
VAR2:=EMA(HHV(HIGH,250),21);
VAR3:=EMA(HHV(HIGH,90),21);
VAR4:=EMA(LLV(LOW,500),21);
VAR5:=EMA(LLV(LOW,250),21);
VAR6:=EMA(LLV(LOW,90),21);
VAR7:=EMA((VAR4*0.96+VAR5*0.96+VAR6*0.96+VAR1*0.558+VAR2*0.558+VAR3*0.558)/6,21);
VAR8:=EMA((VAR4*1.25+VAR5*1.23+VAR6*1.2+VAR1*0.55+VAR2*0.55+VAR3*0.65)/6,21);
VAR9:=EMA((VAR4*1.3+VAR5*1.3+VAR6*1.3+VAR1*0.68+VAR2*0.68+VAR3*0.68)/6,21);
VARA:=EMA((VAR7*3+VAR8*2+VAR9)/6*1.738,21);
VARB:=REF(LOW,1);
VARC:=SMA(ABS(LOW-VARB),3,1)/SMA(MAX(LOW-VARB,0),3,1)*100;
VARD:=EMA(IF(CLOSE*1.35<=VARA,VARC*10,VARC/10),3);
VARE:=LLV(LOW,30);
VARF:=HHV(VARD,30);
VAR10:=IF(MA(CLOSE,58),1,0);
资金入场: EMA(IF(LOW<=VARE,(VARD+VARF*2)/2,0),3)/618*VAR10;
资金入场2: IF(资金入场>0,资金入场,0),STICK,LINETHICK2, COLOR0000FF;
今量: 资金入场;
A1:IF(资金入场>0,今量*1.2,0),STICK,LINETHICK5, COLOR0000FF;
A2:IF(资金入场>0,今量*0.8,0),STICK,LINETHICK5, COLOR0066FF;
A3:IF(资金入场>0,今量*0.6,0),STICK,LINETHICK5, COLOR0099FF;
A4:IF(资金入场>0,今量*0.4,0) ,STICK,LINETHICK5,COLOR00CCFF;
A5:IF(资金入场>0,今量*0.2,0) ,STICK,LINETHICK5,COLOR00FFFF;

相关股票

注册111
Lv.6
发表于 2020-2-9 13:53 复制 查看全部楼层
K1:=IF(CLOSE>=REF(CLOSE,1),HIGH-OPEN+CLOSE-LOW+CLOSE-REF(CLOSE,1),HIGH-OPEN+CLOSE-LOW);
K2:=IF(CLOSE<=REF(CLOSE,1),OPEN-LOW+HIGH-CLOSE+REF(CLOSE,1)-CLOSE,OPEN-LOW+HIGH-CLOSE);
DT:=VOL*K1/(K1+K2);
KT:=VOL-DT;
买量:=SUM(DT,3);
卖量:=SUM(KT,3);
DX:=EMA(买量-卖量,5)*VOL/CAPITAL*100;
STICKLINE(DX>0,0,DX,2,0),COLOR000088;
STICKLINE(DX>0,0,DX,2,0),COLOR0000AA;
STICKLINE(DX>0,0,DX,2,0),COLOR0000CC;
STICKLINE(DX>0,0,DX,2,0),COLOR0000EE;
STICKLINE(DX<0,0,DX,2,0),COLOR008800;
STICKLINE(DX<0,0,DX,2,0),COLOR00AA00;
STICKLINE(DX<0,0,DX,2,0),COLOR00CC00;
STICKLINE(DX<0,0,DX,2,0),COLOR00EE00;
YX:=BARSSINCE(DX)+1;
QM:=BARSLAST(DX<=0);
主力强买:IF(QM<0,YX,QM),COLOR00FFFF;
QM卖:=BARSLAST(DX>=0);
主力强卖:IF(QM卖<0,YX,QM卖),COLOR00FF00;
力度:(主力强买-主力强卖),COLORRED;

VAR1:=EMA(HHV(HIGH,500),21);
VAR2:=EMA(HHV(HIGH,250),21);
VAR3:=EMA(HHV(HIGH,90),21);
VAR4:=EMA(LLV(LOW,500),21);
VAR5:=EMA(LLV(LOW,250),21);
VAR6:=EMA(LLV(LOW,90),21);
VAR7:=EMA((VAR4*0.96+VAR5*0.96+VAR6*0.96+VAR1*0.558+VAR2*0.558+VAR3*0.558)/6,21);
VAR8:=EMA((VAR4*1.25+VAR5*1.23+VAR6*1.2+VAR1*0.55+VAR2*0.55+VAR3*0.65)/6,21);
VAR9:=EMA((VAR4*1.3+VAR5*1.3+VAR6*1.3+VAR1*0.68+VAR2*0.68+VAR3*0.68)/6,21);
VARA:=EMA((VAR7*3+VAR8*2+VAR9)/6*1.738,21);
VARB:=REF(LOW,1);
VARC:=SMA(ABS(LOW-VARB),3,1)/SMA(MAX(LOW-VARB,0),3,1)*100;
VARD:=EMA(IF(CLOSE*1.35<=VARA,VARC*10,VARC/10),3);
VARE:=LLV(LOW,30);
VARF:=HHV(VARD,30);
VAR10:=IF(MA(CLOSE,58),1,0);
资金入场:( EMA(IF(LOW<=VARE,(VARD+VARF*2)/2,0),3)/618*VAR10)+DX;
资金入场2: IF(资金入场>0,资金入场+DX,0),STICK,LINETHICK2, COLOR0000FF;
今量: 资金入场+DX;
A1:IF(资金入场>0,今量*1.2,0),STICK,LINETHICK5, COLOR0000FF;
A2:IF(资金入场>0,今量*0.8,0),STICK,LINETHICK5, COLOR0066FF;
A3:IF(资金入场>0,今量*0.6,0),STICK,LINETHICK5, COLOR0099FF;
A4:IF(资金入场>0,今量*0.4,0) ,STICK,LINETHICK5,COLOR00CCFF;
A5:IF(资金入场>0,今量*0.2,0) ,STICK,LINETHICK5,COLOR00FFFF;

附件

捕获.PNG
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表