手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助合并一下这两个公式

[通达信]
设置
1862 0 一位道友 Lv.2 发表于 · 2020-2-9 14:06 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
第一个;

K1:=IF(CLOSE>=REF(CLOSE,1),HIGH-OPEN+CLOSE-LOW+CLOSE-REF(CLOSE,1),HIGH-OPEN+CLOSE-LOW);
K2:=IF(CLOSE<=REF(CLOSE,1),OPEN-LOW+HIGH-CLOSE+REF(CLOSE,1)-CLOSE,OPEN-LOW+HIGH-CLOSE);
DT:=VOL*K1/(K1+K2);
KT:=VOL-DT;
买量:=SUM(DT,3);
卖量:=SUM(KT,3);
DX:=EMA(买量-卖量,5)*VOL/CAPITAL*100;
STICKLINE(DX>0,0,DX,2,0),COLOR000088;
STICKLINE(DX>0,0,DX,2,0),COLOR0000AA;
STICKLINE(DX>0,0,DX,2,0),COLOR0000CC;
STICKLINE(DX>0,0,DX,2,0),COLOR0000EE;
STICKLINE(DX<0,0,DX,2,0),COLOR008800;
STICKLINE(DX<0,0,DX,2,0),COLOR00AA00;
STICKLINE(DX<0,0,DX,2,0),COLOR00CC00;
STICKLINE(DX<0,0,DX,2,0),COLOR00EE00;
YX:=BARSSINCE(DX)+1;
QM:=BARSLAST(DX<=0);
主力强买:IF(QM<0,YX,QM),COLOR00FFFF;
QM卖:=BARSLAST(DX>=0);
主力强卖:IF(QM卖<0,YX,QM卖),COLOR00FF00;
力度:(主力强买-主力强卖),COLORRED;


第二个;
VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
OBV:SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);
MAOBV:MA(OBV,M);

相关股票

您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表