手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助把这个通达信的公式改成飞狐

[飞 狐]
设置
2386 4 走远001 Lv.1 发表于 · 2020-2-10 00:14 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
STICKLINE(C>0,-20,5,4,0),COLORBLACK;
F1:=ZIG(3,15);
F2:=IF((F1> REF(F1,1)),100,80);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
MA势:=SMA(MAX(C-REF(C,1),0),8,1)/SMA(ABS(C-REF(C,1)),8,1)*100;
势:EMA(MA势,5),COLORLIRED,DOTLINE;
IF(势<=45,势,DRAWNULL),COLORGREEN,DOTLINE;
趋势:=3*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1)-2*
SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1),3,1);
ZZ:=趋势>REF(趋势,1);
K1:=DVOL/1000000;
K2:=DCLOSE;
V1:=EMA(K1,5);
V2:=EMA(K2,5);
价异动:=K2>REF(V2,1)*1.06;
量异动:=K1>REF(V1,1)*1.6&&ZZ;
停牌:=DYNAINFO(17)>0;
M1:=SUM(价异动,2)>0 AND 停牌;
M2:=SUM(量异动,2)>0 AND REF(趋势,1)<89;
共鸣:(F2=100 AND C>REF(C,1) AND FILTER(M1 AND M2,3))*60,COLORRED;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
低2:=IF(CURRBARSCOUNT<=60, CONST(IF(ISLASTBAR=1,LLV(L, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL);
TX:=BARSLAST(C>REF(C,1)*1.095 AND C=H);
T2L:=BARSLAST(C<REF(C,1)*1.095 AND C>REF(C,1)*1.08);
T3L:=BARSLAST(C<REF(C,1)*1.08 AND C>REF(C,1)*1.07);
T4L:=BARSLAST(C<REF(C,1)*1.07 AND C>REF(C,1)*1.06);
T5L:=BARSLAST(C<REF(C,1)*1.06 AND C>REF(C,1)*1.05);
TJ1X:=COUNT(TX=0,100)=0;
TJ2:=COUNT(T2L=0,100)=0;
TJ3:=COUNT(T3L=0,100)=0;
TJ4:=COUNT(T4L=0,100)=0;
TJ5:=COUNT(T5L=0,100)=0;
TJA:=C>REF(C,1)*1.05;
AA:=REF(TX,1)>100 AND REF(T2L,1)>100 AND REF(T3L,1)>100 AND REF(T4L,1)>100 AND REF(T5L,1)>80 AND TJA;
HHM:=HHV(MACD.MACD*100,200);
LLM:=LLV(MACD.MACD*100,200);
M5:=MA(C,5);M10:=MA(C,10);M20:=MA(C,20);M60:=MA(C,60);
D3:=MIN(MIN(M5,M10),M20)>M60;
XGT:=BARSLAST(AA AND HHM<60 AND LLM>-55);
D6:=BARSSINCEN(MIN(MIN(M5,M10),M20)>M60,XGT+1);
XGX:=CROSS((XGT=0 AND D3) OR D6=0,0.5);
TJX:=COUNT(XGX,30)=2 AND XGX;
SR11:=REF(HIGH,10)=HHV(HIGH,2*10+1);
SR21:=FILTER(SR11,10);
SR31:=BACKSET(SR21,10+1);
HDH:=FILTER(SR31,10);
前高G:=REF(H,BARSLAST(HDH));
倍量G:=VOL/REF(VOL,1)>=1.9;
突破前高G:=CROSS(C,前高G);
YG:= 倍量G AND 突破前高G;
SJG:=BARSLAST(YG);
H300:=HHVBARS(DIF,300);
AL:=BOLL.UB;
TQ:=BARSLAST(CROSS(AL>=REF(AL,1),0.5));
E25:=EXPMA(C,25);
Z,:=EVERY(RANGE(C/REF(C,1),0.97,1.05),TQ+1);
Z,F:=(HHV(H,TQ+1)-LLV(L,TQ+1))/LLV(L,TQ+1)*100;
TJQ:=EVERY(MAX(C,O)/AL<1.02 ,TQ+1);
XL:=(ATAN((E25/REF(E25,TQ)-1)*100)*180/3.1415926);
TJ1Q:=CROSS(DIF>=REF(DIF,H300),0.5) AND Z,F<17 AND Z, AND TJQ;
起程:=TJ1Q AND XL>75;
A1F:=REF(C,1);
A3F:=(DCLOSE-A1F)/A1F*100;
AA1F:=(A3F-REF(A3F,1));
选股1:=CROSS(AA1F,9.8);
A11F:=REF(V,1);
A13F:=DVOL/A11F;
AA3F:=(A13F-REF(A13F,1));
选股2:=CROSS(AA3F,500);
潜伏:=选股1 AND 选股2;
爆发点:=(DCLOSE-REF(C,1))/REF(C,1)*100;
XB:=CROSS(爆发点,20);
TJ1L:=REF(CROSS(MA(C,5),C),1) AND CROSS(C,MA(C,5));
TJ2L:=REF(CROSS(MA(C,10),C),1) AND CROSS(C,MA(C,10));
TJ3L:=REF(CROSS(MA(C,20),C),1) AND CROSS(C,MA(C,20));
TJ4L:=TJ1L OR TJ2L OR TJ3L;
TJ5L:=REF(C,2)/REF(C,1)>=1.045 AND REF(C,1)<REF(O,1) AND C/REF(C,1)>1.09 AND C=H AND TJ4L;
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
中线:=EMA(X,13);
KKA:=EMA(C,5);
KKB:=EMA(KKA,8);
KKC:=EMA(KKB,13);
长线1:=EMA(KKC,50);
KAAA3:=REF(C,1)<REF(中线,1) AND C>中线;
KBBB3:=C/REF(C,1)>1+0.01*9;
KCCC3:=中线/长线1<1+0.01*20;
大牛:=KAAA3 AND KBBB3 AND KCCC3 AND TJ5L;
VARAA:=LLV(LOW,5);
VARBA:=HHV(HIGH,5);
确:=EMA((CLOSE-VARAA)/(VARBA-VARAA)*100,4);
MA500:=MA(CLOSE,500);
MA250:=MA(CLOSE,250);
MA120:=MA(CLOSE,120);
MA30:=MA(CLOSE,33);
MA60:=MA(CLOSE,55);
涨停收盘:=(C-REF(C,1))*100/REF(C,1)>=4 AND H-C<0.02;
HD30:=FILTER(BACKSET(FILTER(REF(H,30)=HHV(H,2*30+1),30),30+1),30);
LD30:=FILTER(BACKSET(FILTER(REF(H,30)=LLV(H,2*30+1),30),30+1),30);
AX30:=REF(H,BARSLAST(HD30));
T300:=BARSLAST(HD30)<BARSLAST(LD30) AND NOT(HD30);
顶30:=IF(T300,AX30,AX30);
JZ:=(CROSS(C,顶30) AND DIF>=-0.21 AND DEA<=0.37 AND MA30>MA60 AND (CROSS(C,MA30)OR CROSS(C,MA120)OR CROSS(C,MA250)OR CROSS(C,MA500) OR LOW< MA30)) AND MA30- MA60<0.7 AND 涨停收盘 AND ABS((顶30-MA30)/顶30*100)<10;
信号:IF(确>REF(确,1) AND DIF>DEA AND (JZ OR 大牛 OR XB OR 潜伏 OR 起程 OR CURRBARSCOUNT=CONST(SJG)+2 OR TJX OR (CCI<=100 AND L<=低2)),100,0),STICK,COLORFF00FF,LINETHICK2;
卖警:IF(PEAKBARS(3,15,1)=1,80,100),COLORGREEN;
泥淖:IF((F1> REF(F1,1)),100,80),COLORFF9900;
Q_1:=C-REF(C,1);
Q_2:=100*EMA(EMA(Q_1,6),6)/EMA(EMA(ABS(Q_1),6),6);
Q_3:=CROSS(EMA(C,19),EMA(C,7));
Q_4:=CROSS(EMA(C,7),EMA(C,19));
Z1:=L=LLV(L,BARSLAST(Q_3)+1);
Z2:=LLV(L,BARSLAST(Q_3)+1);
Z3:=H=HHV(H,BARSLAST(Q_4)+1);
Z4:=HHV(H,BARSLAST(Q_4)+1);
上0:=DRAWLINE(Z1,Z2,Z3,Z4,0);
Y1:=H=HHV(H,BARSLAST(Q_4)+1);
Y2:=HHV(H,BARSLAST(Q_4)+1);
Y3:=L=LLV(L,BARSLAST(Q_3)+1);
Y4:=LLV(L,BARSLAST(Q_3)+1);
下0:=DRAWLINE(Y1,Y2,Y3,Y4,0);
TJ:=IF(上0<REF(上0,1) AND 下0=上0,1,0);
未来空柱:=IF(REF(TJ,1)=0 AND TJ>=1,100,0);
红区:卖警=泥淖,NODRAW,COLORRED;
绿区:卖警>泥淖,NODRAW,COLORGREEN;
STICKLINE(卖警>泥淖,卖警,泥淖,0.8,1),COLORGREEN;
STICKLINE(卖警=泥淖,卖警,泥淖*0.9,0.8,1),COLORRED;

附件

QQ图片20200210000659.png
注册111
Lv.6
发表于 2020-2-10 16:49 复制 查看全部楼层
走远001 发表于 2020-2-10 15:17
感谢注册111的帮助!!!
但是很可惜用kt交易师编译,公式没有通过。
能否帮助修改下?能正常使用,谢 ...

重新再来一次
STICKLINE(C>0,-20,5,4,0),COLORBLACK;
F1:=ZIG(3,15);
F2:=IF((F1> REF(F1,1)),100,80);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
MA势:=SMA(MAX(C-REF(C,1),0),8,1)/SMA(ABS(C-REF(C,1)),8,1)*100;
势:EMA(MA势,5),COLORLIGHTRED,LINEDOT;
IF(势<=45,势,INVALID),COLORGREEN,LINEDOT;
趋势:=3*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1)-2*
SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1),3,1);
ZZ:=趋势>REF(趋势,1);
K1:=vol/1000000;
K2:=CLOSE;
V1:=EMA(K1,5);
V2:=EMA(K2,5);
价异动:=K2>REF(V2,1)*1.06;
量异动:=K1>REF(V1,1)*1.6&&ZZ;
停牌:=DYNAINFO(17)>0;
M1:=SUM(价异动,2)>0 AND 停牌;
M2:=SUM(量异动,2)>0 AND REF(趋势,1)<89;
共鸣:(F2=100 AND C>REF(C,1) AND FILTER(M1 AND M2,3))*60,COLORRED;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
低2:=IF(DATACOUNT-BARPOS+1<=60,(IF(ISLASTBAR=1,LLV(L, BARSLAST(DATACOUNT-BARPOS+1=60)),1))[DATACOUNT],INVALID);
TX:=BARSLAST(C>REF(C,1)*1.095 AND C=H);
T2L:=BARSLAST(C<REF(C,1)*1.095 AND C>REF(C,1)*1.08);
T3L:=BARSLAST(C<REF(C,1)*1.08 AND C>REF(C,1)*1.07);
T4L:=BARSLAST(C<REF(C,1)*1.07 AND C>REF(C,1)*1.06);
T5L:=BARSLAST(C<REF(C,1)*1.06 AND C>REF(C,1)*1.05);
TJ1X:=COUNT(TX=0,100)=0;
TJ2:=COUNT(T2L=0,100)=0;
TJ3:=COUNT(T3L=0,100)=0;
TJ4:=COUNT(T4L=0,100)=0;
TJ5:=COUNT(T5L=0,100)=0;
TJA:=C>REF(C,1)*1.05;
AA:=REF(TX,1)>100 AND REF(T2L,1)>100 AND REF(T3L,1)>100 AND REF(T4L,1)>100 AND REF(T5L,1)>80 AND TJA;
HHM:=HHV("MACD.MACD"*100,200);
LLM:=LLV("MACD.MACD"*100,200);
M5:=MA(C,5);M10:=MA(C,10);M20:=MA(C,20);M60:=MA(C,60);
D3:=MIN(MIN(M5,M10),M20)>M60;
XGT:=BARSLAST(AA AND HHM<60 AND LLM>-55);
D6:=BARSLAST(MIN(MIN(M5,M10),M20)>M60,XGT+1);
XGX:=CROSS((XGT=0 AND D3) OR D6=0,0.5);
TJX:=COUNT(XGX,30)=2 AND XGX;
SR11:=REF(HIGH,10)=HHV(HIGH,2*10+1);
SR21:=FILTER(SR11,10);
SR31:=BACKSET(SR21,10+1);
HDH:=FILTER(SR31,10);
前高G:=REF(H,BARSLAST(HDH));
倍量G:=VOL/REF(VOL,1)>=1.9;
突破前高G:=CROSS(C,前高G);
YG:= 倍量G AND 突破前高G;
SJG:=BARSLAST(YG);
H300:=HHVBARS(DIF,300);
AL:="BOLL.UPPER";
TQ:=BARSLAST(CROSS(AL>=REF(AL,1),0.5));
E25:=EMA(C,25);
Z:=EVERY(RANGE(C/REF(C,1),0.97,1.05),TQ+1);
Z_F:=(HHV(H,TQ+1)-LLV(L,TQ+1))/LLV(L,TQ+1)*100;
TJQ:=EVERY(MAX(C,O)/AL<1.02 ,TQ+1);
XL:=(ATAN((E25/REF(E25,TQ)-1)*100)*180/3.1415926);
TJ1Q:=CROSS(DIF>=REF(DIF,H300),0.5) AND Z_F<17 AND Z AND TJQ;
起程:=TJ1Q AND XL>75;
A1F:=REF(C,1);
A3F:=(CLOSE-A1F)/A1F*100;
AA1F:=(A3F-REF(A3F,1));
选股1:=CROSS(AA1F,9.8);
A11F:=REF(V,1);
A13F:=vol/A11F;
AA3F:=(A13F-REF(A13F,1));
选股2:=CROSS(AA3F,500);
潜伏:=选股1 AND 选股2;
爆发点:=(CLOSE-REF(C,1))/REF(C,1)*100;
XB:=CROSS(爆发点,20);
TJ1L:=REF(CROSS(MA(C,5),C),1) AND CROSS(C,MA(C,5));
TJ2L:=REF(CROSS(MA(C,10),C),1) AND CROSS(C,MA(C,10));
TJ3L:=REF(CROSS(MA(C,20),C),1) AND CROSS(C,MA(C,20));
TJ4L:=TJ1L OR TJ2L OR TJ3L;
TJ5L:=REF(C,2)/REF(C,1)>=1.045 AND REF(C,1)<REF(O,1) AND C/REF(C,1)>1.09 AND C=H AND TJ4L;
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
中线:=EMA(X,13);
KKA:=EMA(C,5);
KKB:=EMA(KKA,8);
KKC:=EMA(KKB,13);
长线1:=EMA(KKC,50);
KAAA3:=REF(C,1)<REF(中线,1) AND C>中线;
KBBB3:=C/REF(C,1)>1+0.01*9;
KCCC3:=中线/长线1<1+0.01*20;
大牛:=KAAA3 AND KBBB3 AND KCCC3 AND TJ5L;
VARAA:=LLV(LOW,5);
VARBA:=HHV(HIGH,5);
确:=EMA((CLOSE-VARAA)/(VARBA-VARAA)*100,4);
MA500:=MA(CLOSE,500);
MA250:=MA(CLOSE,250);
MA120:=MA(CLOSE,120);
MA30:=MA(CLOSE,33);
MA60:=MA(CLOSE,55);
涨停收盘:=(C-REF(C,1))*100/REF(C,1)>=4 AND H-C<0.02;
HD30:=FILTER(BACKSET(FILTER(REF(H,30)=HHV(H,2*30+1),30),30+1),30);
LD30:=FILTER(BACKSET(FILTER(REF(H,30)=LLV(H,2*30+1),30),30+1),30);
AX30:=REF(H,BARSLAST(HD30));
T300:=BARSLAST(HD30)<BARSLAST(LD30) AND NOT(HD30);
顶30:=IF(T300,AX30,AX30);
JZ:=(CROSS(C,顶30) AND DIF>=-0.21 AND DEA<=0.37 AND MA30>MA60 AND (CROSS(C,MA30)OR CROSS(C,MA120)OR CROSS(C,MA250)OR CROSS(C,MA500) OR LOW< MA30)) AND MA30- MA60<0.7 AND 涨停收盘 AND ABS((顶30-MA30)/顶30*100)<10;
TYP := (HIGH + LOW + CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
信号:IF(确>REF(确,1) AND DIF>DEA AND (JZ OR 大牛 OR XB OR 潜伏 OR 起程 OR DATACOUNT-BARPOS+1=(SJG)[DATACOUNT]+2 OR TJX OR (CCI<=100 AND L<=低2)),100,0),STICK,COLORFF00FF,LINETHICK2;
卖警:IF(PEAKBARS(3,15,1)=1,80,100),COLORGREEN;
泥淖:IF((F1> REF(F1,1)),100,80),COLORFF9900;
Q_1:=C-REF(C,1);
Q_2:=100*EMA(EMA(Q_1,6),6)/EMA(EMA(ABS(Q_1),6),6);
Q_3:=CROSS(EMA(C,19),EMA(C,7));
Q_4:=CROSS(EMA(C,7),EMA(C,19));
Z1:=L=LLV(L,BARSLAST(Q_3)+1);
Z2:=LLV(L,BARSLAST(Q_3)+1);
Z3:=H=HHV(H,BARSLAST(Q_4)+1);
Z4:=HHV(H,BARSLAST(Q_4)+1);
上0:=LINEVALUE(Z1,Z2,Z3,Z4,0,0);
Y1:=H=HHV(H,BARSLAST(Q_4)+1);
Y2:=HHV(H,BARSLAST(Q_4)+1);
Y3:=L=LLV(L,BARSLAST(Q_3)+1);
Y4:=LLV(L,BARSLAST(Q_3)+1);
下0:=LINEVALUE(Y1,Y2,Y3,Y4,0,0);
TJ:=IF(上0<REF(上0,1) AND 下0=上0,1,0);
未来空柱:=IF(REF(TJ,1)=0 AND TJ>=1,100,0);
红区:卖警=泥淖,NODRAW,COLORRED;
绿区:卖警>泥淖,NODRAW,COLORGREEN;
STICKLINE(卖警>泥淖,卖警,泥淖,0.8,1),COLORGREEN;
STICKLINE(卖警=泥淖,卖警,泥淖*0.9,0.8,1),COLORRED;

附件

捕获.PNG
注册111
Lv.6
发表于 2020-2-10 16:22 复制 查看全部楼层
本帖最后由 注册111 于 2020-2-10 16:25 编辑
走远001 发表于 2020-2-10 15:17
感谢注册111的帮助!!!
但是很可惜用kt交易师编译,公式没有通过。
能否帮助修改下?能正常使用,谢 ...


把有dvol,DCLOSE这个改中d去掉。
走远001
Lv.1
发表于 2020-2-10 15:17 复制 查看全部楼层
注册111 发表于 2020-2-10 12:32
kt交易师
STICKLINE(C>0,-20,5,4,0),COLORBLACK;
F1:=ZIG(3,15);

感谢注册111的帮助!!!
但是很可惜用kt交易师编译,公式没有通过。
能否帮助修改下?能正常使用,谢谢!报错如下图:

附件

QQ图片20200210151530.png
注册111
Lv.6
发表于 2020-2-10 12:32 复制 查看全部楼层
本帖最后由 福阿德 于 2020-2-10 15:17 编辑

kt交易师

附件

捕获.JPG

回复.txt [预览]

5.11 KB, 下载次数: 0, 下载积分: 共享币 -5 个

查看全部打赏
  • 走远001+5理想币 : 点赞,知识的价值在于分享,谢谢!
  • 福阿德+8理想币 +7共享币 : 赠人玫瑰,手有余香。
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表