手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助把指标修复一下

[通达信]
设置
2274 1 快乐归来 Lv.2 发表于 · 2020-2-10 22:27 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
OK:=REF(CLOSE,1);

鱼:=SMA(MAX(CLOSE-OK,0),7,1)/SMA(ABS(CLOSE-OK),7,1)*100;

RSI4:=SMA(鱼,7,1);

HH:=BARSLAST(鱼<><>

白绿线:=SMA(鱼,7,1);

深水鱼:=CROSS(鱼,RSI4) AND 白绿线>15 AND HH;

BU:=深水鱼;

BB2:=IF(C>REF((6*H+5*REF(H,1)+4*REF(H,2)+3*REF(H,3)+2*REF(H,4)+1*REF(H,5))/(6+5+4+3+2+1),1),1,IF(C

DD2:=BARSLAST(NOT(BB2=0));

B:=IF(BB2=0,REF(BB2,DD2),BB2);

触发:BU,NODRAW,COLORRED;

止损:C0)) AND COUNT(C0)),BARSLAST(BU>0))=1 AND IF(MA(CLOSE,1)>IF(B=-1,MA(HIGH,6),MA(LOW,6)) ,1,-1)>0,NODRAW, COLORGREEN;

止盈:(H/REF(C,BARSLAST(BU>0))>=1.05 OR C/REF(C,BARSLAST(BU>0))>=1.05) AND COUNT(止损,BARSLAST(BU>0))=0 AND COUNT(CROSS(0,IF(MA(CLOSE,1)>IF(B=-1,MA(HIGH,6),MA(LOW,6)) ,1,-1)),BARSLAST(BU>0))=0,NODRAW, COLORBLUE;

区间:COUNT(BU,BARSLAST(BU)+1)=1 AND COUNT(止损,BARSLAST(BU>0)+1)=0 AND COUNT(CROSS(0,IF(MA(CLOSE,1)>IF(B=-1,MA(HIGH,6),MA(LOW,6)) ,1,-1)), BARSLAST(BU>0)+1)=0,NODRAW,COLOR696960;

结束:(COUNT(BU,BARSLAST(BU)+1)=1 AND COUNT(止损,BARSLAST(BU>0)+1)=0 AND COUNT(CROSS(0,IF(MA(CLOSE,1)>IF(B=-1,MA(HIGH,6),MA(LOW,6)) ,1,-1)), BARSLAST(BU>0)+1)=1 AND CROSS(0,IF(MA(CLOSE,1)>IF(B=-1,MA(HIGH,6),MA(LOW,6)) ,1,-1))) OR 止损,NODRAW, COLORGREEN;

STICKLINE(触发>0,0,1,4,0),COLORRED;

STICKLINE(止盈>0 ,0.3,0.6,4,0) COLORBLUE;

STICKLINE(结束>0,0,1,4,0) COLORGREEN;

TS:=BARSLASTCOUNT(止盈>0);

DRAWTEXT(止盈>0,0.5,VAR2STR(TS,0));

休闲者68
Lv.6
发表于 2020-2-10 22:35 复制 查看全部楼层
OK:=REF(CLOSE,1);
鱼:=SMA(MAX(CLOSE-OK,0),7,1)/SMA(ABS(CLOSE-OK),7,1)*100;
RSI4:=SMA(鱼,7,1);
HH:=BARSLAST(鱼<=15)<5;
白绿线:=SMA(鱼,7,1);
深水鱼:=CROSS(鱼,RSI4) AND 白绿线>15 AND HH;
BU:=深水鱼;
BB2:=IF(C>REF((6*H+5*REF(H,1)+4*REF(H,2)+3*REF(H,3)+2*REF(H,4)+1*REF(H,5))/(6+5+4+3+2+1),1),1,IF(C<REF((6*L+5*REF(L,1)+4*REF(L,2)+3*REF(L,3)+2*REF(L,4)+1*REF(L,5))/(6+5+4+3+2+1),1),-1,0));
DD2:=BARSLAST(NOT(BB2=0));
B:=IF(BB2=0,REF(BB2,DD2),BB2);
触发:BU,NODRAW,COLORRED;
止损:C<REF(O,BARSLAST(BU>0)) AND COUNT(C<REF(O,BARSLAST(BU>0)),BARSLAST(BU>0))=1 AND IF(MA(CLOSE,1)>IF(B=-1,MA(HIGH,6),MA(LOW,6)) ,1,-1)>0,NODRAW, COLORGREEN;
止盈:(H/REF(C,BARSLAST(BU>0))>=1.05 OR C/REF(C,BARSLAST(BU>0))>=1.05) AND COUNT(止损,BARSLAST(BU>0))=0 AND COUNT(CROSS(0,IF(MA(CLOSE,1)>IF(B=-1,MA(HIGH,6),MA(LOW,6)) ,1,-1)),BARSLAST(BU>0))=0,NODRAW, COLORBLUE;
区间:COUNT(BU,BARSLAST(BU)+1)=1 AND COUNT(止损,BARSLAST(BU>0)+1)=0 AND COUNT(CROSS(0,IF(MA(CLOSE,1)>IF(B=-1,MA(HIGH,6),MA(LOW,6)) ,1,-1)), BARSLAST(BU>0)+1)=0,NODRAW,COLOR696960;
结束:(COUNT(BU,BARSLAST(BU)+1)=1 AND COUNT(止损,BARSLAST(BU>0)+1)=0 AND COUNT(CROSS(0,IF(MA(CLOSE,1)>IF(B=-1,MA(HIGH,6),MA(LOW,6)) ,1,-1)), BARSLAST(BU>0)+1)=1 AND CROSS(0,IF(MA(CLOSE,1)>IF(B=-1,MA(HIGH,6),MA(LOW,6)) ,1,-1))) OR 止损,NODRAW, COLORGREEN;
STICKLINE(触发>0,0,1,4,0),COLORRED;
STICKLINE(止盈>0 ,0.3,0.6,4,0) COLORBLUE;
STICKLINE(结束>0,0,1,4,0) COLORGREEN;
TS:=BARSLASTCOUNT(止盈>0);
DRAWTEXT(止盈>0,0.5,VAR2STR(TS,0));
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表