手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助编写个预警公式

[通达信]
设置
1965 2 美丽小阳光 Lv.3 发表于 · 2020-2-11 10:40 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
公式要求:当主图出现”鼠“字,发出预警,感谢。



MA5:MA(C,5),COLORFFFFFF;
MA20:MA(C,20),COLORFF00FF;
MA60:MA(C,60),COLOR00FFFF;
RSV1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
RSV4:=(CLOSE-LLV(LOW,89))/(HHV(HIGH,89)-LLV(LOW,89))*100;
短期B:=SMA(RSV1,3,1);
短期A:=SMA(短期B,3,1);
K4:=SMA(RSV4,8,1);
中期波段:=SMA(K4,3,1);
VV1:=SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1);
VV2:=SMA(VV1,3,1);
VV3:=3*VV1-2*VV2;
趋势:=EMA(VV3,3);
VV4:=(趋势-REF(趋势,1))/REF(趋势,1)*100;
准备资金:=趋势<13;
开始建仓:=趋势<13 AND VV4>13;
VA1:=(CLOSE*2+HIGH+LOW)/4*10;
VA2:=EMA(VA1,13);
VA3:=EMA(VA1,34);
VA4:=VA2-VA3;
VA5:=EMA(VA4,5);
VA6:=2*(VA4-VA5)*5.5;
AAA:=VA6>=0 AND 趋势<13;
主力进场:=FILTER(AAA,5);
转折:=REF(中期波段,1)<REF(中期波段,2) AND 中期波段>REF(中期波段,1);
共振抄底:=EXIST(开始建仓,3) AND EXIST( 主力进场,1) AND 中期波段>REF(中期波段,1);
短线波段:=(EXIST(转折,2) AND 短期B>=短期A) OR (REF(短期B,1)<REF(短期A,1) AND 短期B>=短期A AND 中期波段>REF(中期波段,1));
ZT:=C>REF(C,1)*1.095;
DRAWTEXT(共振抄底,LOW-0.05,'抄底'),COLORRED;
DRAWTEXT(FILTER(短线波段,3),LOW-0.05,'鼠'),COLORYELLOW;
DRAWTEXT(主力进场,LOW-0.05,'庄进'),COLORFF00FF;

美丽小阳光
Lv.3
发表于 2020-2-11 10:48 复制 查看全部楼层
许昌舍得 发表于 2020-2-11 10:42
RSV1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
RSV4:=(CLOSE-LLV(LOW,89))/(HHV(HIGH,89)-LLV( ...

谢谢老师热心帮助。
许昌舍得
Lv.6
发表于 2020-2-11 10:42 复制 查看全部楼层
RSV1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
RSV4:=(CLOSE-LLV(LOW,89))/(HHV(HIGH,89)-LLV(LOW,89))*100;
短期B:=SMA(RSV1,3,1);
短期A:=SMA(短期B,3,1);
K4:=SMA(RSV4,8,1);
中期波段:=SMA(K4,3,1);
VV1:=SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1);
VV2:=SMA(VV1,3,1);
VV3:=3*VV1-2*VV2;
趋势:=EMA(VV3,3);
VV4:=(趋势-REF(趋势,1))/REF(趋势,1)*100;
准备资金:=趋势<13;
开始建仓:=趋势<13 AND VV4>13;
VA1:=(CLOSE*2+HIGH+LOW)/4*10;
VA2:=EMA(VA1,13);
VA3:=EMA(VA1,34);
VA4:=VA2-VA3;
VA5:=EMA(VA4,5);
VA6:=2*(VA4-VA5)*5.5;
AAA:=VA6>=0 AND 趋势<13;
主力进场:=FILTER(AAA,5);
转折:=REF(中期波段,1)<REF(中期波段,2) AND 中期波段>REF(中期波段,1);
共振抄底:=EXIST(开始建仓,3) AND EXIST( 主力进场,1) AND 中期波段>REF(中期波段,1);
短线波段:=(EXIST(转折,2) AND 短期B>=短期A) OR (REF(短期B,1)<REF(短期A,1) AND 短期B>=短期A AND 中期波段>REF(中期波段,1));

鼠:FILTER(短线波段,3);
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表