手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙改写公式指标

[通达信]
设置
2124 9 财团长 Lv.3 发表于 · 2020-2-11 11:48 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
改写为选股公式指标,谢谢

主升浪:IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,90,0),COLOR1010FF,LINETHICK2;
V6:=CLOSE/REF(CLOSE,3)>=1.1;
V7:=BACKSET(V6,4);
涨停初现:IF((V7 AND COUNT(V7,3)=1),40,0),COLORCYAN,STICK,LINETHICK3;
LS:=C/REF(C,1)>1.040 AND C=H AND BETWEEN(FORCAST(V,4),0.2*FORCAST(V,12),2.1
*FORCAST(V,5)),COLORFF6600,LINETHICK1;
买涨停:FILTER(LS,28)*40,COLORFF6600,LINETHICK3 ,STICK;
VAR26:=EMA(CLOSE,2)-EMA(CLOSE,150);
VAR27:=EMA(VAR26 ,100);
VAR28:=2*(VAR26-VAR27);
VAR29:=POW(VAR28,3)*0.1+POW(VAR28,1);
黑马线: IF( VAR28>0.1,VAR29,0)*3, COLOR400080,LINETHICK2;
低买:IF(TROUGHBARS(3,6,1)=0 AND HIGH>LOW+0.04,50,0),COLOR00FFFF,LINETHICK1;

财团长
Lv.3
发表于 2020-2-12 16:43 复制 查看全部楼层
老师回复的真快!谢谢老师。
注册111
Lv.6
发表于 2020-2-12 16:22 复制 查看全部楼层
财团长 发表于 2020-2-12 16:16
你说的对,单独的选股都比较好,放到一起不出票了。
另外,这个问题能不能帮助解决一下
VAR26:=EMA(CLO ...

VAR26:=EMA(CLOSE,2)-EMA(CLOSE,150);
VAR27:=EMA(VAR26 ,100);
VAR28:=2*(VAR26-VAR27);
VAR29:=POW(VAR28,3)*0.1+POW(VAR28,1);
黑马线:=IF( VAR28>0.1,VAR29,0);
REF(黑马线=0,1)&&黑马线>0;
财团长
Lv.3
发表于 2020-2-12 16:16 复制 查看全部楼层
注册111 发表于 2020-2-12 08:34
1。指标有未来。2。最好用股票来说明。

你说的对,单独的选股都比较好,放到一起不出票了。
另外,这个问题能不能帮助解决一下
VAR26:=EMA(CLOSE,2)-EMA(CLOSE,150);
VAR27:=EMA(VAR26 ,100);
VAR28:=2*(VAR26-VAR27);
VAR29:=POW(VAR28,3)*0.1+POW(VAR28,1);
黑马线: =IF( VAR28>0.1,VAR29,0);
REF(黑马线=0,1)&&黑马线>0;

当前公式 : 黑马线 (条件选股公式)  
错误句 :  
黑马线: =IF( VAR28>0.1,VAR29,0)
详细信息 : 某个操作数没有相应的操作符匹配!
错误起始位置 : 139 ; 长度: 2
注册111
Lv.6
发表于 2020-2-12 08:34 复制 查看全部楼层
财团长 发表于 2020-2-11 20:30
能不能成为一个选股指标呢?选出的票与副图不相匹配,咋办?

1。指标有未来。2。最好用股票来说明。
财团长
Lv.3
发表于 2020-2-11 20:30 复制 查看全部楼层
注册111 发表于 2020-2-11 12:07
1
主升浪:IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,90,0);
2

能不能成为一个选股指标呢?选出的票与副图不相匹配,咋办?
财团长
Lv.3
发表于 2020-2-11 20:27 复制 查看全部楼层
休闲者68 发表于 2020-2-11 12:04
低买:IF(TROUGHBARS(3,6,1)=0 AND HIGH>LOW+0.04,50,0);

选出的票与副图不匹配,都是刚上市不久的新股
财团长
Lv.3
发表于 2020-2-11 19:49 复制 查看全部楼层
谢谢二位老师!
注册111
Lv.6
发表于 2020-2-11 12:07 复制 查看全部楼层
本帖最后由 注册111 于 2020-2-11 12:10 编辑

1
主升浪:IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,90,0);
2
LS:=C/REF(C,1)>1.040 AND C=H AND BETWEEN(FORCAST(V,4),0.2*FORCAST(V,12),2.1
*FORCAST(V,5));
买涨停:FILTER(LS,28);
3
VAR26:=EMA(CLOSE,2)-EMA(CLOSE,150);
VAR27:=EMA(VAR26 ,100);
VAR28:=2*(VAR26-VAR27);
VAR29:=POW(VAR28,3)*0.1+POW(VAR28,1);
黑马线: =IF( VAR28>0.1,VAR29,0);
ref(黑马线=0,1)&&黑马线>0;
4
低买:IF(TROUGHBARS(3,6,1)=0 AND HIGH>LOW+0.04,50,0);
休闲者68
Lv.6
发表于 2020-2-11 12:04 复制 查看全部楼层
低买:IF(TROUGHBARS(3,6,1)=0 AND HIGH>LOW+0.04,50,0);
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表