手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙改一下选股公式条件

[通达信]
设置
1813 1 小斌仔王智勃 Lv.2 发表于 · 2020-2-11 16:10 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
需求:选出不带绿色的股票,红绿相间的也不要,只要纯红色!


DRAWGBK(ISLASTBAR, RGB(60,60,60),RGB(0,0,0),0,'0',0);

HE1:=55;

HE2:=21;

HE3:=REF(LOW,1);

HE4:=SMA(ABS(LOW-HE3),3,1)/SMA(MAX(LOW-HE3,0),3,1)*100;

HE5:=EMA(IF(CLOSE*1.3,HE4*10,HE4/10),3);

HE6:=LLV(LOW,30);

HE7:=HHV(HE5,30);

HE8:=IF(MA(CLOSE,58),1,0);

HE9:=EMA(IF(LOW<=HE6,(HE5+HE7*2)/2,0),3)/618*HE8;

HE10:=IF(HE9>100,100,HE9);

主力吸筹:(HE10>(-120),0,HE10,3.0,0),COLOR0000FF;

STICKLINE(HE10>(-120),0,HE10,3.0,0),COLOR000044;

STICKLINE(HE10>(-120),0,HE10,2.4,0),COLOR000066;

STICKLINE(HE10>(-120),0,HE10,1.8,0),COLOR000088;

STICKLINE(HE10>(-120),0,HE10,1.2,0),COLOR0000AA;

STICKLINE(HE10>(-120),0,HE10,0.6,0),COLOR0000CC;

STICKLINE(HE10>(-120),0,HE10,0.1,0),COLOR0000FF;
HE11:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);

HE12:=SMA(ABS(HE11-HIGH),13,1)/SMA(MAX(HE11-HIGH,0),10,1);

HE13:=EMA(HE12,10);

HE14:=HHV(HIGH,30);

HE15:=EMA(IF(HIGH>=HE14,HE13,0),3);

主力出逃:IF(HE15<REF(HE15,1),HE15,0),NODRAW,COLOR00FF00;

STICKLINE(HE15<REF(HE15,1),0,-HE15,3.0,0),COLOR006600;

STICKLINE(HE15<REF(HE15,1),0,-HE15,2.4,0),COLOR008800;

STICKLINE(HE15<REF(HE15,1),0,-HE15,1.8,0),COLOR00AA00;

STICKLINE(HE15<REF(HE15,1),0,-HE15,1.2,0),COLOR00CC00;

STICKLINE(HE15<REF(HE15,1),0,-HE15,0.6,0),COLOR00DD00;

STICKLINE(HE15<REF(HE15,1),0,-HE15,0.1,0),COLOR00FF00;

散户筹码:100*(HHV(HIGH,HE1)-CLOSE)/(HHV(HIGH,HE1)-LLV(LOW,HE1)),COLORYELLOW;

HE16:=(CLOSE-LLV(LOW,HE2))/(HHV(HIGH,HE2)-LLV(LOW,HE2))*100;

HE17:=SMA(HE16,3,1);

HE18:=SMA(HE17,3,1);

HE19:=3*HE17-2*HE18;

主力筹码:EMA(HE19,5),COLORMAGENTA;

附件

111111111111111111111.png
网络漫步1
Lv.5
发表于 2020-2-11 20:14 复制 查看全部楼层

HE11:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
HE12:=SMA(ABS(HE11-HIGH),13,1)/SMA(MAX(HE11-HIGH,0),10,1);
HE13:=EMA(HE12,10);
HE14:=HHV(HIGH,30);
HE15:=EMA(IF(HIGH>=HE14,HE13,0),3);
NOT(HE15<REF(HE15,1));
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表