手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助改写个选股指标

[通达信]
设置
2167 5 阳光早到 Lv.3 发表于 · 2020-2-11 20:14 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请求老师帮助把副图指标改写成一个选股指标,谢谢!
{超级买点}
XA_1:=MA(HHV(HIGH,485),17);
XA_2:=MA(HHV(HIGH,222),17);
XA_3:=MA(HHV(HIGH,96),17);
XA_4:=MA(LLV(LOW,485),17);
XA_5:=MA(LLV(LOW,222),17);
XA_6:=MA(LLV(LOW,96),17);
XA_7:=MA((XA_4*0.96+XA_5*0.96+XA_6*0.96+XA_1*0.558+XA_2*0.558+XA_3*0.558)/6,17);
XA_8:=MA((XA_4*1.25+XA_5*1.23+XA_6*1.2+XA_1*0.55+XA_2*0.55+XA_3*0.65)/6,17);
XA_9:=MA((XA_4*1.3+XA_5*1.3+XA_6*1.3+XA_1*0.68+XA_2*0.68+XA_3*0.68)/6,17);
XA_10:=MA((XA_7*3+XA_8*2+XA_9)/6*1.738,17);
XA_11:=IF(DATE<=1050531,XA_10,XA_10*DAY);
XA_12:=LOW;
XA_13:=REF(LOW,1);
XA_14:=SMA(ABS(XA_12-XA_13),3,1)/SMA(MAX(XA_12-XA_13,0),3,1)*100;
XA_15:=MA(IF(CLOSE*1.35<=XA_11,XA_14*10,XA_14/10),N);
XA_16:=LLV(LOW,30);
XA_17:=HHV(XA_15,30);
XA_18:=1990831;
XA_19:=IF(DATE<=XA_18,MA(IF(LOW<=XA_16,(XA_15+XA_17*2)/2,0),N),100000000);
XA_20:=IF(CLOSE<REF(CLOSE,1),VOL/CAPITAL*10053,0);
XA_21:=ABS(EMA(XA_20,13.3)-18)/WINNER(CLOSE)*IF((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)<(-0.04),1,0);
短线买:IF(XA_19>500 AND XA_19>2500,1,0),COLORYELLOW;
中线买:IF(XA_19>10000 AND XA_19>20000,2,0),COLORMAGENTA,LINETHICK2;
加仓买:IF(XA_19>30000 AND XA_19>30000,3,0),COLORRED,LINETHICK3;

要求是选出短线买、中线买、加仓买同符合的股票
阳光早到
Lv.3
发表于 2020-2-12 09:11 复制 查看全部楼层
许昌舍得老师你好!非常感谢你的帮助,我想做一个能够选出短线买、中线买和 加仓买同时出信号的股票,这可以做到吗?如果可以就请老师再帮助一下做成一个公式指标。谢谢!
耿欣
Lv.2
发表于 2020-2-11 21:43 复制 查看全部楼层
看了老师的公式..........感觉非常好..............优秀.............优秀.............优秀.............
许昌舍得
Lv.6
发表于 2020-2-11 20:34 复制 查看全部楼层

N:=6;
XA_1:=MA(HHV(HIGH,485),17);
XA_2:=MA(HHV(HIGH,222),17);
XA_3:=MA(HHV(HIGH,96),17);
XA_4:=MA(LLV(LOW,485),17);
XA_5:=MA(LLV(LOW,222),17);
XA_6:=MA(LLV(LOW,96),17);
XA_7:=MA((XA_4*0.96+XA_5*0.96+XA_6*0.96+XA_1*0.558+XA_2*0.558+XA_3*0.558)/6,17);
XA_8:=MA((XA_4*1.25+XA_5*1.23+XA_6*1.2+XA_1*0.55+XA_2*0.55+XA_3*0.65)/6,17);
XA_9:=MA((XA_4*1.3+XA_5*1.3+XA_6*1.3+XA_1*0.68+XA_2*0.68+XA_3*0.68)/6,17);
XA_10:=MA((XA_7*3+XA_8*2+XA_9)/6*1.738,17);
XA_11:=IF(DATE<=1050531,XA_10,XA_10*DAY);
XA_12:=LOW;
XA_13:=REF(LOW,1);
XA_14:=SMA(ABS(XA_12-XA_13),3,1)/SMA(MAX(XA_12-XA_13,0),3,1)*100;
XA_15:=MA(IF(CLOSE*1.35<=XA_11,XA_14*10,XA_14/10),N);
XA_16:=LLV(LOW,30);
XA_17:=HHV(XA_15,30);
XA_18:=1990831;
XA_19:=IF(DATE<=XA_18,MA(IF(LOW<=XA_16,(XA_15+XA_17*2)/2,0),N),100000000);
XA_20:=IF(CLOSE<REF(CLOSE,1),VOL/CAPITAL*10053,0);
XA_21:=ABS(EMA(XA_20,13.3)-18)/WINNER(CLOSE)*IF((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)<(-0.04),1,0);





加仓买:XA_19>30000 AND XA_19>30000;
许昌舍得
Lv.6
发表于 2020-2-11 20:34 复制 查看全部楼层

N:=6;
XA_1:=MA(HHV(HIGH,485),17);
XA_2:=MA(HHV(HIGH,222),17);
XA_3:=MA(HHV(HIGH,96),17);
XA_4:=MA(LLV(LOW,485),17);
XA_5:=MA(LLV(LOW,222),17);
XA_6:=MA(LLV(LOW,96),17);
XA_7:=MA((XA_4*0.96+XA_5*0.96+XA_6*0.96+XA_1*0.558+XA_2*0.558+XA_3*0.558)/6,17);
XA_8:=MA((XA_4*1.25+XA_5*1.23+XA_6*1.2+XA_1*0.55+XA_2*0.55+XA_3*0.65)/6,17);
XA_9:=MA((XA_4*1.3+XA_5*1.3+XA_6*1.3+XA_1*0.68+XA_2*0.68+XA_3*0.68)/6,17);
XA_10:=MA((XA_7*3+XA_8*2+XA_9)/6*1.738,17);
XA_11:=IF(DATE<=1050531,XA_10,XA_10*DAY);
XA_12:=LOW;
XA_13:=REF(LOW,1);
XA_14:=SMA(ABS(XA_12-XA_13),3,1)/SMA(MAX(XA_12-XA_13,0),3,1)*100;
XA_15:=MA(IF(CLOSE*1.35<=XA_11,XA_14*10,XA_14/10),N);
XA_16:=LLV(LOW,30);
XA_17:=HHV(XA_15,30);
XA_18:=1990831;
XA_19:=IF(DATE<=XA_18,MA(IF(LOW<=XA_16,(XA_15+XA_17*2)/2,0),N),100000000);
XA_20:=IF(CLOSE<REF(CLOSE,1),VOL/CAPITAL*10053,0);
XA_21:=ABS(EMA(XA_20,13.3)-18)/WINNER(CLOSE)*IF((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)<(-0.04),1,0);



中线买:XA_19>10000 AND XA_19>20000;
许昌舍得
Lv.6
发表于 2020-2-11 20:33 复制 查看全部楼层

N:=6;
XA_1:=MA(HHV(HIGH,485),17);
XA_2:=MA(HHV(HIGH,222),17);
XA_3:=MA(HHV(HIGH,96),17);
XA_4:=MA(LLV(LOW,485),17);
XA_5:=MA(LLV(LOW,222),17);
XA_6:=MA(LLV(LOW,96),17);
XA_7:=MA((XA_4*0.96+XA_5*0.96+XA_6*0.96+XA_1*0.558+XA_2*0.558+XA_3*0.558)/6,17);
XA_8:=MA((XA_4*1.25+XA_5*1.23+XA_6*1.2+XA_1*0.55+XA_2*0.55+XA_3*0.65)/6,17);
XA_9:=MA((XA_4*1.3+XA_5*1.3+XA_6*1.3+XA_1*0.68+XA_2*0.68+XA_3*0.68)/6,17);
XA_10:=MA((XA_7*3+XA_8*2+XA_9)/6*1.738,17);
XA_11:=IF(DATE<=1050531,XA_10,XA_10*DAY);
XA_12:=LOW;
XA_13:=REF(LOW,1);
XA_14:=SMA(ABS(XA_12-XA_13),3,1)/SMA(MAX(XA_12-XA_13,0),3,1)*100;
XA_15:=MA(IF(CLOSE*1.35<=XA_11,XA_14*10,XA_14/10),N);
XA_16:=LLV(LOW,30);
XA_17:=HHV(XA_15,30);
XA_18:=1990831;
XA_19:=IF(DATE<=XA_18,MA(IF(LOW<=XA_16,(XA_15+XA_17*2)/2,0),N),100000000);
XA_20:=IF(CLOSE<REF(CLOSE,1),VOL/CAPITAL*10053,0);
XA_21:=ABS(EMA(XA_20,13.3)-18)/WINNER(CLOSE)*IF((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)<(-0.04),1,0);
短线买:XA_19>500 AND XA_19>2500;
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表