手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙编写个预警公式

[通达信]
设置
1871 4 小卢888 Lv.3 发表于 · 2020-2-12 13:38 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
JJ :=(C*3+H+L+O)/6;SK := EMA(JJ,13) - EMA(JJ,21);
SD := EMA(SK,3);
SP := EMA(SK,10);
A1:=EMA(C,7)-EMA(C,21);
B1:=EMA((0.668*REF
(A1,1)+0.333*A1),1);
B1,COLORSTICK;X1:=V/SUM(V,13);
X2:=DMA(C,X1);
X3:=(C-X2)/X2*40;
L2:=MA(AMOUNT/(100*V),13);
CYS13:= (C-L2)/L2*100;
做多:IF(A1>=B1,A1,B1),LINETHICK2,COLORRED;
做空:IF(B1-A1,B1,A1),COLORGREEN,LINETHICK2;
点火:STICKLINE(CYS13>5 AND DIFF>DEA AND C>=EMA(C,5) AND A1-B1>0,0,-做空,2,0 ),COLORRED;
DRAWICON(点火,点火,9);
DRAWTEXT((点火 AND REF(A1,1)<=REF(B1,1)AND REF(A1,0)>REF(B1,0)),0.38,'点火'),COLORRED;
主力强度:STICKLINE(X3>0 AND 做多>0,做多+0.1,做多,1,0),COLORYELLOW;
C>MA(C,30),COLORFF80FF,LINETHICK2;
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J1:=DIFF;
J2:=DEA;
J3:=K;
J4:=D;
VL:=REF(LOW,1);
VH:=REF(H,1);
VAR1:=SMA(ABS(H-VH),13,1)/SMA(MAX(H-VH,0),13,1)*100;
VAR2:=SMA(ABS(L-VL),13,1)/SMA(MAX(L-VL,0),13,1)*100;
VAR3:=REF(CLOSE,1);
VAR4:=MA(VAR2,13);
VAR5:=LLV(L,34);
VAR6:=SMA(MAX(CLOSE-VAR3,0),6,1)/SMA(ABS(CLOSE-VAR3),6,1)*100;
VAR7:=CROSS(93,VAR6);
VAR8:=EMA(IF(L<=VAR5,VAR4,0),3);
VAR9:=H>LLV(L,0)*7;
VAR10:=(SMA(SMA((((CLOSE - LLV(LOW,54)) / (HHV(HIGH,54) - LLV(LOW,54))) * 100),7,1),5,1));
VAR11:=((SMA(((CLOSE - LLV(LOW,54)) / (HHV(HIGH,54) - LLV(LOW,54)) * 100),7,1)) * 16.18) - (VAR10 * 10.9);
上攻:=FILTER(CROSS(J1,J2) AND VOL>REF(SUM(VOL,5),1),3),COLOR0066FF,LINETHICK2;
WR10:=-100*(HHV(HIGH,10)-CLOSE)/(HHV(HIGH,10)-LLV(LOW,10));
WR45:=-100*(HHV(HIGH,45)-CLOSE)/(HHV(HIGH,45)-LLV(LOW,45));
WR99:=-100*(HHV(HIGH,99)-CLOSE)/(HHV(HIGH,99)-LLV (LOW,99));
顶:= 0;
底1:=-95;


请老师帮忙写个预警公式:紫色线由数值0今天第一次上升到数值1时预警。谢谢!
小卢888
Lv.3
发表于 2020-2-12 14:25 复制 查看全部楼层
许昌舍得 发表于 2020-2-12 14:20
选股:CROSS(C,MA(C,30));

谢谢老师的帮助,祝股票长红!
许昌舍得
Lv.6
发表于 2020-2-12 14:20 复制 查看全部楼层
小卢888 发表于 2020-2-12 14:15
老师您好首先谢谢你的解答!我想要的不是点火,我要的是紫色线由数值0今天第一次上升到数值1时预警,是第 ...

选股:CROSS(C,MA(C,30));
小卢888
Lv.3
发表于 2020-2-12 14:15 复制 查看全部楼层
许昌舍得 发表于 2020-2-12 14:07
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
JJ :=(C*3+H+L+O)/6;SK := EMA(JJ,13) - EMA(J ...

老师您好首先谢谢你的解答!我想要的不是点火,我要的是紫色线由数值0今天第一次上升到数值1时预警,是第一次预警,可否帮忙修改?谢谢!
许昌舍得
Lv.6
发表于 2020-2-12 14:07 复制 查看全部楼层
本帖最后由 福阿德 于 2020-2-12 15:17 编辑

供参考

附件

回复.txt [预览]

430 Bytes, 下载次数: 0, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+8理想币 +7共享币 : 赠人玫瑰,手有余香。
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表