手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙修改一下三顾茅庐指标

[大智慧]
设置
2039 1 无敌雄鹰 Lv.4 发表于 · 2020-2-12 14:49 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
老大777老师的飞狐指标,小弟修改了一下效果不理想。麻烦路过的老师出售效果一下谢谢。
飞狐源码:CB80:ema(((COST(99.3)+COST(70.7))/2+COST(85))/2,13);
CB66:ema(((COST(99)+COST(33))/2+COST(66))/2,13);
CB:EMA((((COST(80.9)+COST(19.1))/2+(COST(61.8)+COST(38.2))/2)/2+COST(50))/2,13);
CB6:EMA(((COST(6)+COST(16))/2+COST(11))/2,13);
MA5:MA(C,5);
//(c-cb6)>0是c在cb6上方  <0 在下方
updown:=if((c-CB6)<0,1,0);
maCB80:=ma(CB80,13);
maCB66:=ma(CB66,13);
maCB:=ma(CB,13);
maCB6:=ma(CB6,13);
ma向上:=if((maCB80>ref(maCB80,5) or maCB66>ref(maCB66,5) or maCB>ref(maCB,5)) or maCB6>ref(maCB6,5),1,0);
主力建仓:if(c>CB6 and sum(updown,220)>20 and (c/hhv(c,700)<0.5 or c/llv(c,700)<1.7) and ma向上,sum(updown,220),0),colorred,linethick0;
partline(主力建仓>0,CB6),colorred,linethick3;
卧龙式盘建仓:if(主力建仓>0 and sum(主力建仓,400)>88,sum(主力建仓,400),0),Color5ADB9A,linethick0;
partline(卧龙式盘建仓>0,CB6*0.91),Color5ADB9A,linethick5;
刘备捞月式建仓:if(主力建仓 and c/hhv(c,700)<0.35,sum(updown,220),0),coloryellow,linethick0;
partline(刘备捞月式建仓>0,CB6*0.95),coloryellow,linethick5;{黄色}
三顾茅庐:if(主力建仓>0 and 卧龙式盘建仓>0 and 刘备捞月式建仓>0,(主力建仓+卧龙式盘建仓+刘备捞月式建仓)/3,0),colorgreen,linethick0;
partline(三顾茅庐>0,CB6*1.15),ColorF8E71F,linethick11;
stickline(三顾茅庐>0,CB6*1.08,CB6*1.33,7,0),ColorF8E71F;{蓝色}
下面是我修改的
CB80:EMA(((COST(99.3)+COST(70.7))/2+COST(85))/2,13);
CB66:EMA(((COST(99)+COST(33))/2+COST(66))/2,13);
CB:EMA((((COST(80.9)+COST(19.1))/2+(COST(61.8)+COST(38.2))/2)/2+COST(50))/2,13);
CB6:EMA(((COST(6)+COST(16))/2+COST(11))/2,13);
{//(C-CB6)>0是C在CB6上方 <0 在下方}
UPDOWN:=IF((C-CB6)<0,1,0);
MACB80:=MA(CB80,13);
MACB66:=MA(CB66,13);
MACB:=MA(CB,13);
MACB6:=MA(CB6,13);
MA向上:=IF((MACB80>REF(MACB80,5) OR MACB66>REF(MACB66,5) OR MACB>REF(MACB,5)) OR MACB6>REF(MACB6,5),1,0);
主力建仓:=IF(C>CB6 AND SUM(UPDOWN,220)>20 AND (C/HHV(C,700)<0.5 OR C/LLV(C,700)<1.7) AND MA向上,SUM(UPDOWN,220),0);
IF(主力建仓>0,CB6,0),COLORRED,LINETHICK3;
卧龙式盘建仓:=IF(主力建仓>0 AND SUM(主力建仓,400)>88,SUM(主力建仓,400),0);
IF(卧龙式盘建仓>0,CB6*0.91,0),COLOR5ADB9A,LINETHICK5;{黄绿色}
刘备捞月式建仓:=IF(主力建仓 AND C/HHV(C,700)<0.35,SUM(UPDOWN,220),0);
IF(刘备捞月式建仓>0,CB6*0.95,0),COLORYELLOW,LINETHICK5;{黄色}
三顾茅庐:=IF(主力建仓>0 AND 卧龙式盘建仓>0 AND 刘备捞月式建仓>0,(主力建仓+卧龙式盘建仓+刘备捞月式建仓)/3,0);
STICKLINE(三顾茅庐>0,CB6*1.08,CB6*1.33,7,0),COLORF8E71F;
partline(三顾茅庐>0,CB6*1.15),ColorF8E71F,linethick5;
stickline(三顾茅庐>0,CB6*1.08,CB6*1.33,7,0),ColorF8E71F;

附件

三顾茅庐.png
三顾茅庐2.png
1.png
2.png
注册111
Lv.6
发表于 2020-2-12 15:26 复制 查看全部楼层
CB80:EMA(((COST(99.3)+COST(70.7))/2+COST(85))/2,13);
CB66:EMA(((COST(99)+COST(33))/2+COST(66))/2,13);
CB:EMA((((COST(80.9)+COST(19.1))/2+(COST(61.8)+COST(38.2))/2)/2+COST(50))/2,13);
CB6:EMA(((COST(6)+COST(16))/2+COST(11))/2,13);
{//(C-CB6)>0是C在CB6上方 <0 在下方}
UPDOWN:=IF((C-CB6)<0,1,0);
MACB80:=MA(CB80,13);
MACB66:=MA(CB66,13);
MACB:=MA(CB,13);
MACB6:=MA(CB6,13);
MA向上:=IF((MACB80>REF(MACB80,5) OR MACB66>REF(MACB66,5) OR MACB>REF(MACB,5)) OR MACB6>REF(MACB6,5),1,0);
主力建仓:=IF(C>CB6 AND SUM(UPDOWN,220)>20 AND (C/HHV(C,700)<0.5 OR C/LLV(C,700)<1.7) AND MA向上,SUM(UPDOWN,220),0);
PARTLINE(CB6,主力建仓>0),COLORRED,LINETHICK3;
卧龙式盘建仓:=IF(主力建仓>0 AND SUM(主力建仓,400)>88,SUM(主力建仓,400),0);
PARTLINE(CB6*0.91,卧龙式盘建仓>0),COLOR5ADB9A,LINETHICK5;{黄绿色}
刘备捞月式建仓:=IF(主力建仓 AND C/HHV(C,700)<0.35,SUM(UPDOWN,220),0);
PARTLINE(CB6*0.95,刘备捞月式建仓>0),COLORYELLOW,LINETHICK5;{黄色}
三顾茅庐:=IF(主力建仓>0 AND 卧龙式盘建仓>0 AND 刘备捞月式建仓>0,(主力建仓+卧龙式盘建仓+刘备捞月式建仓)/3,0);
STICKLINE(三顾茅庐>0,CB6*1.08,CB6*1.33,7,0),COLORF8E71F;
{partline(三顾茅庐>0,CB6*1.15),ColorF8E71F,linethick5;}
stickline(三顾茅庐>0,CB6*1.08,CB6*1.33,7,0),ColorF8E71F;
查看全部打赏
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表