手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助编写三个上穿的源码

[通达信]
设置
1948 7 水滴石穿 Lv.2 发表于 · 2020-2-13 11:15 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
1、股价上穿60日均线后至少15个交易日以上,(最好能圈定在15日--30日),15日箱体振幅在30%以内,出现5日线上穿10日线为选股信号
2、股价上穿60日均线后至少15个交易日以上,(最好能圈定在15日--30日),15日箱体振幅在30%以内,出现当日股价涨幅大于3%,量比大于3,成交量是昨日成交量
   的1.5倍以上,换手是5%,股价最高价突破箱体最高价为选股信号
3、股价上穿60日均线后至少15个交易日以上,(最好能圈定在15日--30日),15日箱体振幅在30%以内,出现一阳穿三线的K线,换手大于5%为选股信号。

还有一个:三者结合一起的话能不能再做成主图指标?
水滴石穿
Lv.2
发表于 2020-2-14 13:42 复制 查看全部楼层
@许昌舍得 非常感谢老师,您太棒了
许昌舍得
Lv.6
发表于 2020-2-14 13:04 复制 查看全部楼层

T:=BARSLAST(CROSS(C,MA(C,60)));
XH3:REF(T>=15 AND HHV(H,T)/LLV(L,T)<1.3,1) AND CROSS(C,MA(C,5)) AND CROSS(C,MA(C,10)) AND CROSS(C,MA(C,20)) AND HSL.HSL>5;
许昌舍得
Lv.6
发表于 2020-2-14 13:02 复制 查看全部楼层

T:=BARSLAST(CROSS(C,MA(C,60)));
XH2:REF(T>=15 AND HHV(H,T)/LLV(L,T)<1.3,1) AND ((C/REF(C,1)-1)*100>3 AND DYNAINFO(17)>3 AND V>REF(V,1)*1.5 AND HSL.HSL>5);
许昌舍得
Lv.6
发表于 2020-2-14 13:02 复制 查看全部楼层
水滴石穿 发表于 2020-2-14 12:40
@许昌舍得 老师最终这个能不能改成选股指标?

还有我说的1、2、3想做成3个选股指标,麻烦您啦/th ...

T:=BARSLAST(CROSS(C,MA(C,60)));
XH:REF(T>=15 AND HHV(H,T)/LLV(L,T)<1.3,1) AND CROSS(MA(C,5),MA(C,10)) AND EVERY(C>MA(C,60) ,T);
水滴石穿
Lv.2
发表于 2020-2-14 12:40 复制 查看全部楼层
@许昌舍得 老师最终这个能不能改成选股指标?

还有我说的1、2、3想做成3个选股指标,麻烦您啦
许昌舍得
Lv.6
发表于 2020-2-14 11:16 复制 查看全部楼层
本帖最后由 许昌舍得 于 2020-2-14 11:26 编辑

MA1:MA(CLOSE,5);
MA2:MA(CLOSE,10);
MA3:MA(CLOSE,20);
MA4:MA(CLOSE,60);

T:=BARSLAST(CROSS(C,MA(C,60)));
XH:REF(T>=15 AND HHV(H,T)/LLV(L,T)<1.3,1) AND (CROSS(MA(C,5),MA(C,10)) AND EVERY(C>MA(C,60) ,T)
OR ((C/REF(C,1)-1)*100>3 AND DYNAINFO(17)>3 AND V>REF(V,1)*1.5 AND HSL.HSL>5)
OR (CROSS(C,MA(C,5)) AND CROSS(C,MA(C,10)) AND CROSS(C,MA(C,20)) AND HSL.HSL>5));

DRAWICON(XH,MA(C,60)*1.1,34);

附件

tdxjietu3.JPG
tdxjietu5.JPG
水滴石穿
Lv.2
发表于 2020-2-14 10:44 复制 查看全部楼层
顶一下,@休闲者68老师,@注册111 老师,@许昌舍得 老师
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表