手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助做个趋势线变红的选股(XG=1,只在趋势线变红时出现)公式

[通达信]
设置
2148 6 景逸863 Lv.4 发表于 · 2020-2-13 14:38 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
麻烦老师做个趋势线变红的选股(XG=1,只在趋势线变红时出现)公式,谢谢!

AA:=(CLOSE-LLV(LOW,43))/(HHV(HIGH,43)-LLV(LOW,43))*100;
能量:SMA(AA,32,8),NODRAW;
STICKLINE(能量>80,0,能量,2,0),COLORRED;
STICKLINE(能量>80,0,80,2,0),COLORMAGENTA;
STICKLINE(能量<80,0,能量,2,0),COLORMAGENTA;
STICKLINE(能量<20,0,能量,2,0),COLOR008B00;
STICKLINE(能量>20,0,20,2,0),COLOR008B00;
STICKLINE(能量>20 AND 能量<50,20,能量,2,0),COLORYELLOW;
STICKLINE(能量>50,20,50,2,0),COLORYELLOW;
BB:=IF(能量>REF(能量,1),能量-能量*1/100,能量+能量*1/100);
趋势线:SMA(BB,19,6),COLORRED,LINETHICK3;
差值:能量-趋势线,NODRAW;
IF(差值>0,趋势线,DRAWNULL),COLORRED,LINETHICK3;
IF(差值<0,趋势线,DRAWNULL),COLORGREEN,LINETHICK3;

安全区:20,COLOR008B00,LINETHICK3;
中线:50,COLORYELLOW,LINETHICK3;
危险区:80,COLORMAGENTA,LINETHICK3;

{M:=13;N:=30;
A01:=(C+O+L+H)/4;
A02:=(WINNER((A01 * 1.04)) * 100.000);
A03:=(WINNER((A01 * 0.96)) * 100.000);
A04:A03,NODRAW;
A08:A02-A03,NODRAW;
A06:( 100.000 - A02),NODRAW;
STICKLINE( 1.000,0,A04, 2,0),COLORRED;
STICKLINE( 1.000, 100.000,A02, 2,0), COLOR008B00;
STICKLINE( 1.000,A04,(100-A06), 2,0),COLORYELLOW;
A0A:=(((((HHV(A04, 15.000) - A03) / A03) * 100.000) > N) AND (HHV(A04, 15.000) > 50.000));
STICKLINE(A0A,(0 - 2.000), 2.000, 4,0),COLORYELLOW;
STICKLINE(NOT(A0A),(0 - 2.000), 2.000, 4,0),COLORMAGENTA;
获利:MA(A03,M),COLORRED,LINETHICK3;
浮动: (MA(A02,M) - MA(A03,M)),COLORYELLOW,LINETHICK3;
套牢: (100.000 - MA(A02,M)),COLOR008B00 LINETHICK3;};

景逸863
Lv.4
发表于 2020-2-16 15:22 复制 查看全部楼层
谢谢刘勤福老师,祝股市长虹!
刘勤福
Lv.3
发表于 2020-2-14 22:38 复制 查看全部楼层
启动:IF( 能量>趋势线 AND REF(能量,1)<趋势线 AND 能量<20,80,50),COLORYELLOW;
景逸863
Lv.4
发表于 2020-2-13 15:43 复制 查看全部楼层
再次谢谢许昌老师,这回成了,老师辛苦了,祝老师身体健康,万事如意!
许昌舍得
Lv.6
发表于 2020-2-13 15:36 复制 查看全部楼层
本帖最后由 福阿德 于 2020-2-13 21:18 编辑
景逸863 发表于 2020-2-13 15:30
谢谢许昌老师,麻烦老师再改一下,这个源码只是一条线,老师辛苦了!


附件

回复.txt [预览]

235 Bytes, 下载次数: 2, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+8理想币 +7共享币 : 赠人玫瑰,手有余香。
景逸863
Lv.4
发表于 2020-2-13 15:30 复制 查看全部楼层
谢谢许昌老师,麻烦老师再改一下,这个源码只是一条线,老师辛苦了!
许昌舍得
Lv.6
发表于 2020-2-13 15:09 复制 查看全部楼层
AA:=(CLOSE-LLV(LOW,43))/(HHV(HIGH,43)-LLV(LOW,43))*100;
能量:=SMA(AA,32,8);


BB:=IF(能量>REF(能量,1),能量-能量*1/100,能量+能量*1/100);
趋势线:SMA(BB,19,6);
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表