手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

黄金线主图求选股器

设置
3105 7 鹰眼023 Lv.3 发表于 · 2020-2-13 15:17 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
本帖最后由 鹰眼023 于 2020-2-13 17:49 编辑

    黄金线主图指标经常用到,无论是日线还是周线、分钟线,都可以很好的寻找其【未来趋势】,主要是日线和周K线,在判断趋势上比较有力,尤其是周K线,在相对底部出现黄K,一般未来至少1—2周都是位于黄K线上,呈多头趋势,但是需要对比几个附图指标作出判断,当然成交量也是一方面,个股的大趋势也是一个方面;就是没有选股指标,每天基本都是手动选股,比较烦,在此向论坛里面的各位大神请求,写一个关于本指标用于选股的公式,选股要求比较简单:K线出现黄色的股票(当日),可以用到所有周期,如果不行也需要日线和周线周期。

下面是指标的源代码:

  MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
牛线:(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16
*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11
*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+5
*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210,COLORRED;
马线:MA(牛线,6),COLORGREEN;
MAA5:MA(C,5),COLORFF00FF,LINETHICK2;


A3:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
A4:=SMA(A3,3,1);
A5:=SMA(A4,3,1);
A6:=3*A4-2*A5;
A7:=C-REF(C,1);
A8:=100*EMA(EMA(A7,6),6)/EMA(EMA(ABS(A7),6),6);
买:=LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND CROSS(A8,MA(A8,2));
DRAWTEXT(FILTER(买=1,5),LOW-0.05,'↖买进'),COLORYELLOW;
STICKLINE(买,OPEN,CLOSE,2,0),COLORYELLOW;



LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
日:=150;昨前:=3;
高1:=REF(HHV(H,日),昨前);
低1:=REF(LLV(L,日),昨前);
H1:=高1-(高1-低1)*0.191;
H2:=高1-(高1-低1)*0.382;
H3:=高1-(高1-低1)*0.5;
H4:=高1-(高1-低1)*0.618;
H5:=高1-(高1-低1)*0.809;
顶:REFDATE(高1,DATE),COLORRED;
一:REFDATE(H1,DATE),COLORYELLOW;
二:REFDATE(H2,DATE),COLORMAGENTA;
三:REFDATE(H3,DATE),COLORWHITE;
四:REFDATE(H4,DATE),COLORGREEN;
五:REFDATE(H5,DATE),COLORYELLOW;
低:REFDATE(低1,DATE),COLORRED;

下面上传几幅截图,都是随机选取的股票:

005大盘-周线.png

周K线图01
004美利云-周线.png

日K线图01
003美利云-日线.png

周K线02
002格林美(周线).png

日K线02
001格林美.png

有写说明已经在图片里面有写到

鹰眼023
Lv.3
发表于 2020-2-15 13:14 复制 查看全部楼层
风清云淡68 发表于 2020-2-13 19:49
能把修改后的源码奉献一下吗?谢谢!

利用附图指标选股就行。
风清云淡68
Lv.2
发表于 2020-2-13 19:49 复制 查看全部楼层
鹰眼023 发表于 2020-2-13 18:53
谢谢,刚才试用了几次才成功,开始选股数据错误,一只都没饿选出,刚才修改后全部选出了,几年了一直没好 ...

能把修改后的源码奉献一下吗?谢谢!
鹰眼023
Lv.3
发表于 2020-2-13 18:53 复制 查看全部楼层
佛山dog 发表于 2020-2-13 18:01
就是用上面的指标,新建一个条件选股公式,在条件选股就可以了。

谢谢,刚才试用了几次才成功,开始选股数据错误,一只都没饿选出,刚才修改后全部选出了,几年了一直没好的办法。谢谢
佛山dog
Lv.3
发表于 2020-2-13 18:01 复制 查看全部楼层
本帖最后由 佛山dog 于 2020-2-13 18:05 编辑
鹰眼023 发表于 2020-2-13 17:48
谢谢你的指点和公式,指标提示比较准确,但是我需要的是选股器


就是用上面的指标,新建一个条件选股公式,在条件选股就可以了。

附件

2020-02-13_180442.png
鹰眼023
Lv.3
发表于 2020-2-13 17:48 复制 查看全部楼层
佛山dog 发表于 2020-2-13 16:34
看看这个是不是你想要的。新建一个副图指标.

A3:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;

谢谢你的指点和公式,指标提示比较准确,但是我需要的是选股器
佛山dog
Lv.3
发表于 2020-2-13 16:34 复制 查看全部楼层
看看这个是不是你想要的。新建一个副图指标.

A3:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
A4:=SMA(A3,3,1);
A5:=SMA(A4,3,1);
A6:=3*A4-2*A5;
A7:=C-REF(C,1);
A8:=100*EMA(EMA(A7,6),6)/EMA(EMA(ABS(A7),6),6);
买:LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND CROSS(A8,MA(A8,2));
查看全部打赏
  • 鹰眼023+10理想币 : 点赞,知识的价值在于分享,谢谢!
田子晖
Lv.5
发表于 2020-2-13 16:01 复制 查看全部楼层
感谢分享!!!!!
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表