手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙编写个选股公式

[通达信]
设置
1950 4 小麦郎 Lv.4 发表于 · 2020-2-13 15:18 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请老师编写一个选股公式:(趋势同时下穿“牛熊及平滑”)。谢谢!!!

HH:=HHV(H,9);
LL:=LLV(L,9);
FG:=(HH-LL)/100;
RSV:=(C-LL)/(HH-LL)*100;
K1:=SMA(RSV,3,1);
DA:=SMA(K1,3,1);
J1:=3*K1-2*DA;
K:K1*FG+LL,NODRAW;
D:DA*FG+LL,NODRAW;
J:=J1*FG+LL;
DRAWBAND(K,RGB(250,0,0),D,RGB(0,180,0));
ZIF:=EMA(C,12)-EMA(C,26);
ZEA:=EMA(ZIF,9);
ZBC:=2.5*(ZIF-ZEA);
ZJS:=1.2*ZIF-0.2*ZEA;
ZXH:=(ZJS*13*27-27*11*EMA(C,12)+13*25*EMA(C,26))/28,COLORWHITE;
ZPH:=(ZIF*13*27-27*11*EMA(C,12)+13*25*EMA(C,26))/28,COLORYELLOW;
ZQS:=(ZEA*13*27-27*11*EMA(C,12)+13*25*EMA(C,26))/28,COLORCYAN;
ZNX:=(ZXH+ZQS)/2,COLORMAGENTA;
ZJD:=ATAN((ZPH-REF(ZPH,1))/REF(ZPH,1)*100)*180/3.14159;
导向:ZXH,COLORFFFFFF;
平滑:ZPH,COLOR00FFFF;
牛熊:ZNX,COLORFF00FF;
趋势:ZQS,COLORFFFF00;

附件

0000003.jpg
小麦郎
Lv.4
发表于 2020-2-13 15:43 复制 查看全部楼层
感谢“休闲者68”老师!谢谢!!!
小麦郎
Lv.4
发表于 2020-2-13 15:36 复制 查看全部楼层
感谢“许昌舍得”老师!谢谢!!!
休闲者68
Lv.6
发表于 2020-2-13 15:30 复制 查看全部楼层
本帖最后由 福阿德 于 2020-2-13 21:13 编辑

供参考

附件

回复.txt [预览]

348 Bytes, 下载次数: 0, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+8理想币 +7共享币 : 赠人玫瑰,手有余香。
许昌舍得
Lv.6
发表于 2020-2-13 15:29 复制 查看全部楼层
本帖最后由 福阿德 于 2020-2-13 21:12 编辑

供参考

附件

回复.txt [预览]

539 Bytes, 下载次数: 2, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+8理想币 +7共享币 : 赠人玫瑰,手有余香。
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表