手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙做个选股公式

[通达信]
设置
2051 5 轶凡王 Lv.2 发表于 · 2020-2-13 15:48 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请老师帮忙根据幅图公式中:黄色线(金牛)、蓝色线(金牛2)、红色线(金钻趋势)三根线向上,并且当日K线股价相对黄色线(金牛)还有距离20%【(金牛—当日股价)÷当日股价】    以上的差距时做个选股预警公式。
DRAWGBK(C>O,RGB(60,0,0),RGB(0,0,0),1,2,1);
DRAWTEXT_FIX(1,0.88,5,0,''),COLORBLUE;
Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLORRED;
金牛:(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1+XMA(XMA

(H,25),25),DOTLINE,COLORYELLOW;
金钻趋势:XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))

*1,LINETHICK2,COLORRED;
金牛2:EMA(金钻趋势,25)COLORCYAN,LINETHICK2;
DRAWBAND(金钻趋势,RGB(55,0,0),金牛2,RGB(0,91,0));
DRAWKLINE(H,O,L,C);
STICKLINE(金钻趋势>LOW AND 金钻趋势<HIGH,金钻趋势,MIN(MIN

(OPEN,CLOSE),金钻趋势),2,0),COLORYELLOW;
STICKLINE(金钻趋势>MIN(C,O) AND 金钻趋势<MAX(C,O),金钻趋势,MIN

(OPEN,CLOSE),2,0),COLORYELLOW;
STICKLINE(金钻趋势>HIGH,OPEN,CLOSE,2,0),COLORYELLOW;
STICKLINE(金钻趋势>HIGH,HIGH,LOW,0,0),COLORYELLOW;
VAR23:=100*XMA(XMA((C-REF(C,1)),6),6)/XMA(XMA(ABS((C-REF

(C,1))),6),6);
回调买:=LLV(VAR23,2)=LLV(VAR23,7) AND COUNT(VAR23<0,2) AND

CROSS(VAR23,MA(VAR23,2));
XG:=金钻趋势>HIGH AND 回调买 AND L<=金钻趋势;
DRAWTEXT(XG,L,'▲买入'),COLORRED;
JJ:=(HIGH+LOW+CLOSE)/3;
QJ0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
QJ1:=IF(CAPITAL=0,QJ0*(JJ-MIN(CLOSE,OPEN)),QJ0*IF(HIGH=LOW,1,

(MIN(OPEN,CLOSE)-LOW)));
QJ2:=IF(CAPITAL=0,QJ0*(MIN(OPEN,CLOSE)-LOW),QJ0*IF(HIGH=LOW,1,

(JJ-MIN(CLOSE,OPEN))));
QJ3:=IF(CAPITAL=0,QJ0*(HIGH-MAX(OPEN,CLOSE)),QJ0*IF(HIGH=LOW,1,

(HIGH-MAX(OPEN,CLOSE))));
QJ4:=IF(CAPITAL=0,QJ0*(MAX(CLOSE,OPEN)-JJ),QJ0*IF(HIGH=LOW,1,

(MAX(CLOSE,OPEN)-JJ)));
DDX:=((QJ1+QJ2)-(QJ3+QJ4))/IF

(CAPITAL=0,10000,10000),COLOR00AAAA,LINETHICK;
V2:=SMA(IF(C>=REF(C,1),DDX,-DDX/100),2,1);
V5:=SMA(V2*120/FROMOPEN*5,2,1);
V10:=SMA(V5,5,1);
V20:=SMA(V10,5,1);
DY:=CURRBARSCOUNT=1 AND C<REF(C,1);
DY2:=REF(V2,1)-DY;
XG2:=C>O AND DY2<0.02 AND MA(C,5)>MA(C,60) AND C/REF(C,1)>=1.02

AND H<金牛;
{DRAWTEXT(XG2,L,'▲抓牛'),COLORYELLOW;}
DRAWTEXT(XG2 AND L<金钻趋势,L,'金钻起涨'),COLORMAGENTA;
MA1:MA(C,3);
注册111
Lv.6
发表于 2020-2-14 09:14 复制 查看全部楼层
理想tldx 发表于 2020-2-14 09:12
请教。这里的xma会产生漂移吗?

有未来,会的。
理想tldx
Lv.4
发表于 2020-2-14 09:12 复制 查看全部楼层

请教。这里的xma会产生漂移吗?
注册111
Lv.6
发表于 2020-2-13 18:04 复制 查看全部楼层
本帖最后由 福阿德 于 2020-2-13 21:10 编辑
轶凡王 发表于 2020-2-13 17:19
公式入不了。

还有能把大于20%的公式单独分开来吗?!谢谢!!!


可以了。

附件

回复.txt [预览]

289 Bytes, 下载次数: 4, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+8理想币 +7共享币 : 赠人玫瑰,手有余香。
  • 轶凡王+10理想币 +2共享币 : 很给力,理想因你而精彩;
轶凡王
Lv.2
发表于 2020-2-13 17:19 复制 查看全部楼层
本帖最后由 轶凡王 于 2020-2-13 17:24 编辑
注册111 发表于 2020-2-13 17:00
金牛:=(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1+XMA(XMA
(H,25),25);
金钻趋势:XMA(XMA(L,25),25)-(XM ...








公式入不了。

还有能把大于20%的公式单独分开来吗?!谢谢!!!

附件

截图未命名.jpg
注册111
Lv.6
发表于 2020-2-13 17:00 复制 查看全部楼层

金牛:=(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1+XMA(XMA
(H,25),25);
金钻趋势:XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))
*1;
金牛2:EMA(金钻趋势,25);
金牛>REF(金牛,1)&&金钻趋势>REF(金钻趋势,1)&&金牛2>REF(金牛2,1)&&(金牛-C)/C*100>20;
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表