手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙选股公式加一个条件

[通达信]
设置
2170 2 一位道友 Lv.2 发表于 · 2020-2-13 18:51 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
老师帮忙在这个公式上面增加一个条件;要求当天阴线跌幅小于百分之2。  谢谢!!


MA20:=MA(CLOSE,20);
MA60:=MA(CLOSE,60);
{20线和60线趋势向上}
VAR1:=MA20>REF(MA20,1);

VAR2:=MA60>REF(MA60,1);

{KDJ死叉,这个和买字的一样; KDJ的J要在50以下};
N:=9;M1:=3;M2:=3;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,M1,1);
D:=SMA(K,M2,1);
J:=3*K-2*D;
VAR3:=CROSS(D,K);

VAR4:=J<50;

{收盘阳线,当天涨幅不超百分之四,当天上影线不超百分之2.5,阴线无所谓}
VAR5:=C>OPEN; {收盘阳线}{阴线无所谓}
VAR6:=(C-REF(C,1))/REF(C,1)*100<4;

VAR7:=(H-MAX(C,OPEN))/MAX(C,OPEN)*100<2.5;

{最少调整三天以上 且不破60线}
VAR8:=C<REF(C,1) AND REF(C,1)<REF(C,2) AND REF(C,2)<REF(C,3);

VAR9:=C>MA60 AND LOW/MA60<1.1;{不破60线,贴近60线距离10个百分点}

{成交量是10日内最小量,或是持续缩量到极致。   提示;K线涨幅和量能参数可以自己调节}
VAR10:=VOL=LLV(V,10);

{今日成交量小于5日均量线的50%}
VAR11:=V<MA(V,5)*0.50;



{OBV的黄色线趋势向上}
VAR12:=1;

VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
OBV2:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);
MAOBV:=MA(OBV2,30);
VAR13:=MAOBV>REF(MAOBV,1);

XG:VAR1 AND VAR2 AND VAR3 AND VAR4 AND VAR6 AND VAR7 AND VAR8 AND VAR9 AND VAR10 AND

VAR12 AND VAR13;
一位道友
Lv.2
发表于 2020-2-13 19:07 复制 查看全部楼层
感谢!!!
许昌舍得
Lv.6
发表于 2020-2-13 18:53 复制 查看全部楼层
本帖最后由 福阿德 于 2020-2-13 20:55 编辑

供参考

附件

回复.txt [预览]

1.28 KB, 下载次数: 0, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+8理想币 +7共享币 : 赠人玫瑰,手有余香。
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表