手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助根据下面公式改成选股公式

[大智慧]
设置
2550 6 郭富生 Lv.4 发表于 · 2020-2-14 03:45 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
跳空缺口幅度:=(O/REF(C,1)-1)*100<=9.856;                                                                                                               
首次涨停:=count(c/ref(c,1)>1.09865,10);                                                                                                            
涨幅限制:=(C-REF(C,5))/REF(C,5)*100<=36;                                                                                                           
当日有交易:=DYNAINFO(8)>0;                                                                                                                        
涨停基因:="涨停脉源.涨停基因评分#day">=45;                                                                                                         
当日均额比:="均额最大.竞价均额比#tick">=1.5;                                                                                                      
五十万增仓:=if("50W大单.集合竞价增仓5">=0 or "50W大单.集合竞价增仓6">=0.45,1,0);                                                                  
竞价动能:="竞价量比.竞价动能强势">=250;                                                                                                            
竞价高量:="竞价高量.竞价实际换手">=0.4;                                                                                                            
九二四提升率:=if("竞价涨幅.九二四提升率">=0 or "竞价涨幅.九二四提升率">=0.45,1,0);     
先谢谢各位老师
飘雪秋天
Lv.2
发表于 2020-2-15 23:36 复制 查看全部楼层
你这是大智慧的,搞不了,不好意思!
郭富生
Lv.4
发表于 2020-2-15 23:24 复制 查看全部楼层

老师麻烦你再帮帮忙改成选股公式,公式在下面,上面是条件要求
郭富生
Lv.4
发表于 2020-2-15 01:12 复制 查看全部楼层
请老师帮忙做个选股公式。先谢谢了
郭富生
Lv.4
发表于 2020-2-14 18:57 复制 查看全部楼层

var1:=ref(v,BARSLAST(v=hhv(v,0)));
TT:=ref(var1,BARSLAST(TIME<=092800));
竞价最高量:if(TT,var1,0);
竞价实际换手:竞价最高量/FINANCE2(37);
郭富生
Lv.4
发表于 2020-2-14 18:54 复制 查看全部楼层
本帖最后由 郭富生 于 2020-2-14 19:31 编辑


全部公式1;当日最低:llv(sum(vol,0)*240/dynainfo(38)/barscount(c),0);
当日最高:hhv(sum(vol,0)*240/dynainfo(38)/barscount(c),0);
当日均量比:ma(sum(vol,0)*240/dynainfo(38)/barscount(c),0);

当日竞价均量比:REF(ma(sum(vol,0)*240/dynainfo(38)/barscount(c),0),BARSLAST(TIME>092500 AND TIME<=093100)),LINETHICK0;      
当日竞价量比:REF(ma(sum(vol,0)*240/dynainfo(38)/barscount(c),0),BARSLAST(TIME>092500 AND TIME<=092900)),LINETHICK0;

竞价量:sum(if(time<92610 ,vol,0),0),PRECIS0;                    
竞价:DYNAINFO(4),PRECIS2;                                       
竞价额:竞价量*竞价/100,PRECIS0;                                 
T:=TIME>=091500 AND TIME<=093120;
开盘成交量:SUM(IF(T,VOL,0),0);                  
                        
竞价量占比:竞价量/capital*100;      
开盘量占比:开盘成交量/capital*100;                                 
                        

开盘竞价涨幅:(O-REF(C,1))/REF(C,1)*100;
竞价强势排序:开盘竞价涨幅*竞价量占比*当日竞价量比*10000;

kf:(DYNAINFO(4)/DYNAINFO(3)-1)*100,PRECIS2;
竞价量比:=SUM(V*(time<92600),0)/DYNAINFO(38)*240;
ltp:=if(CAPITAL<100000,100000,CAPITAL);
竞价换手率:=SUM(V*(time<92600),0)/ltp*10000;
竞价动能:kf*竞价换手率,PRECIS1;
竞价动能强势:竞价动能*竞价量比/10,PRECIS1;
2;CJBS:IF(TICKCOUNT=0,SELFDATA('BS'),TICKCOUNT),volstick;
每笔均额:AMOUNT/CJBS,COLORblack;
MA5:=MA(每笔均额,5);
MA13:=MA(每笔均额,13);
MA50:=MA(每笔均额,50);
MA250:=MA(每笔均额,250) ;
均额比:MA5/REF(MA5,5);
当日均额比:每笔均额/REF(MA5,5);
均额比十异动:count(当日均额比>1.04,10);
均额比二十异动:count(当日均额比>1.04,20);
均额比三十异动:count(当日均额比>1.04,30);
三日均额比:ma(均额比,3);
五日均额比:ma(均额比,5);
十日均额比:ma(均额比,10);
二十日均额比:ma(均额比,20);
3ZF:=C/REF(C,1)>=1.03;                                          
ZT:=C/REF(C,1)>1.0985;                                          
ZTS:=COUNT(ZT,120);                                             
SS20:=BARSCOUNT(C)>=20;                                         
AA:=ZF AND SS20;                                                
                                                               
BB:=IF(AA AND ZTS>=20,85,                                       
IF(AA AND RANGE(ZTS,17,20),80,                                 
IF(AA AND RANGE(ZTS,14,18),75,                                 
IF(AA AND RANGE(ZTS,11,15),70,                                 
IF(AA AND RANGE(ZTS,10,13),65,                                 
IF(AA AND RANGE(ZTS,8,11),60,                                   
IF(AA AND RANGE(ZTS,6,9),55,                                    
IF(AA AND RANGE(ZTS,3,7),50,                                    
IF(AA AND RANGE(ZTS,1,4),45,                                    
IF(AA AND RANGE(ZTS,0,2),35,0))))))))));                       
                                                               
XG:=bb>=45 AND COUNT(ZT,60)>=1 AND DYNAINFO(8)>0;               
                                                               
基因选股:IF(CURRENTTIME>092400 AND CURRENTTIME<=110000,XG,0);
4;Var1:=AMOUNT/VOL/100;
Var2:=REF(ASKPRICE(1),1);
Var3:=REF(BIDPRICE(1),1);
Var4:=(Var2-Var3)*0.35;
Var5:=IF(Var1>=Var2-Var4,VOL,IF(Var1<Var2-Var4 AND Var1>Var3+Var4,BUYVOL,0));
Var6:=IF(Var1<=Var3+Var4,VOL,IF(Var1<Var2-Var4 AND Var1>Var3+Var4,SELLVOL,0));
买一:=if(BARSTATUS=1 and DYNAINFO(4)>=DYNAINFO(3),vol,if(c=DYNAINFO(55),0,if(c=DYNAINFO(54),vol,var5)));
卖一:=if(BARSTATUS=1 and DYNAINFO(4)<DYNAINFO(3),vol,if(c=DYNAINFO(54),0,if(c=DYNAINFO(55),vol,var6)));
主动买单:=if(买一>0 and AMOUNT>=500000 ,买一,0);
主动卖单:=if(卖一>0 and AMOUNT>=500000 ,卖一,0);
主动买单一:=if(买一>0 and AMOUNT<200000 ,买一,0);
主动卖单一:=if(卖一>0 and AMOUNT<200000 ,卖一,0);
大买量:sum(主动买单,0);
大卖量:sum(主动卖单,0);
小买量:sum(主动买单一,0);
小卖量:sum(主动卖单一,0);
总量:大买量+大卖量+小买量+小卖量,linethick0;
买卖差:大买量-大卖量;
买差比:(买卖差/总量)*100;
实际流通盘:SELFDATA('实际流通盘');

买差比二:买卖差/capital*100;
主动买单二:=if(买一>0 and AMOUNT>=500000 ,买一,0);
主动卖单二:=if(卖一>0 and AMOUNT>=500000 ,卖一,0);
五十万买卖差:主动买单二-主动卖单二;
五十万净量:sum(五十万买卖差,0);
总量一:sum(vol,0);
大资金比:五十万净量/总量一*100;
五十万增仓率:买卖差/capital*100;

{9点30分}
ZL9D:REF(五十万增仓率,BARSLAST(TIME>=091500 AND TIME<=093000));
集合竞价增仓:REF(五十万增仓率,BARSLAST(TIME<=093300)),linethick0;
集合竞价增仓1:REF(五十万增仓率,BARSLAST(TIME>091500 AND TIME<=093100))>0.28,linethick0;
集合竞价增仓2:REF(五十万增仓率,BARSLAST(TIME>091500 AND TIME<=103100)),linethick0;
集合竞价增仓4:REF(五十万增仓率,BARSLAST(TIME>091500 AND TIME<=093100)),linethick0;
{10点}
ZL10D:REF(五十万增仓率,BARSLAST(TIME<=100000));

{10点半}
ZL10DB:=REF(五十万增仓率,BARSLAST(TIME>100000 AND TIME<=103000));

{11点}
ZL11D:=REF(五十万增仓率,BARSLAST(TIME>103000 AND TIME<=110000));

{11点半}
ZL11DB:=REF(五十万增仓率,BARSLAST(TIME>110000 AND TIME<=113000));

{13点半}
ZL13DB:=REF(五十万增仓率,BARSLAST(TIME>130000 AND TIME<=133000));

{14点}
ZL14D:=REF(五十万增仓率,BARSLAST(TIME>133000 AND TIME<=140000));

{14点半}
ZL14DB:=REF(五十万增仓率,BARSLAST(TIME>140000 AND TIME<=143000));

{15点}
ZL15D:=REF(五十万增仓率,BARSLAST(TIME>143000 AND TIME<=150000));

5;竞价低点:=ref(LLV(L,BARSSINCE(TIME>=92000)+1),barslast(time<92440));
九二四价格:=REF(c,BARSSINCE(TIME0>=33880)),LINETHICK0,PRECIS2,colorwhite;
九二四距低点:ref((九二四价格-竞价低点)/竞价低点*100,barslast(time<092600));
6;最后封板量:REF(v,(LAST(C = (DYNAINFO(54)))) - 1),PRECIS0;
最大量:HHV(v,0),POINTDOT,COLOR999999,PRECIS0;
7;第一股东:=PFFIN(4002 , 0);
第二股东:=PFFIN(4012 , 0);
第三股东:=PFFIN(4022 , 0);
第四股东:=PFFIN(4032 , 0);
第五股东:=PFFIN(4042 , 0);
第六股东:=PFFIN(4052 , 0);
第七股东:=PFFIN(4062 , 0);
第八股东:=PFFIN(4072 , 0);
第九股东:=PFFIN(4082 , 0);
第十股东:=PFFIN(4092 , 0);
cap:=pffin(3002,0);

{cap:CAPITAL*100,linethick0;}
n1:=5;
第一流通股:=if(第一股东/cap*100>n1,第一股东,0);
第二流通股:=if(第二股东/cap*100>n1,第二股东,0);
第三流通股:=if(第三股东/cap*100>n1,第三股东,0);
第四流通股:=if(第四股东/cap*100>n1,第四股东,0);
第五流通股:=if(第五股东/cap*100>n1,第五股东,0);
第六流通股:=if(第六股东/cap*100>n1,第六股东,0);
第七流通股:=if(第七股东/cap*100>n1,第七股东,0);
第八流通股:=if(第八股东/cap*100>n1,第八股东,0);
第九流通股:=if(第九股东/cap*100>n1,第九股东,0);
第十流通股:=if(第十股东/cap*100>n1,第十股东,0);

真实流通1:=(cap-第一流通股-第二流通股-第三流通股-第四流通股-第五流通股-第六流通股-第七流通股-第八流通股-第九流通股-第十流通股)/100000000;
流通盘:cap/100000000,linethick0;
真实流通:if(真实流通1>0,真实流通1,流通盘);

飘雪秋天
Lv.2
发表于 2020-2-14 08:39 复制 查看全部楼层
语句不全。。。!
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表