手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙编写个选股公式

[通达信]
设置
2171 5 财财财发 Lv.3 发表于 · 2020-2-14 16:34 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请老师编写一个5,10,120 K线金叉的选股公式,谢谢!!!
财财财发
Lv.3
发表于 2020-2-15 16:34 复制 查看全部楼层
操盘A线:EMA(EMA(EMA(EMA(CLOSE,2),2),2),2),COLORFFFFFF;
操盘B线:EMA(REF(操盘A线,1),2),COLOR00FFFF;
趋势:EMA(EMA(EMA(EMA(EMA(CLOSE,60),2),2),2),2),LINETHICK2,COLORRED;
A3:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
{理想股票论坛 WWW.70822.COM}
A4:=SMA(A3,3,1);
A5:=SMA(A4,3,1);
A6:=3*A4-2*A5;
A7:=C-REF(C,1);
A8:=100*EMA(EMA(A7,6),6)/EMA(EMA(ABS(A7),6),6);
买:=LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND CROSS(A8,MA(A8,2));
警惕:STICKLINE(买,OPEN,CLOSE,2.7,0),COLORYELLOW;
涨停:STICKLINE(CLOSE/REF(C,1)>=1.09,O,C,2.7,0),COLORFF00FF;
Z1:=STRCAT(DYBLOCK,' ');
Z2:=STRCAT(Z1,HYBLOCK);
Z3:=STRCAT(Z2,' ');
Z4:=STRCAT(Z3,GNBLOCK);
Z5:=STRCAT(Z4,' ');
Z6:=STRCAT(Z5,FGBLOCK);
DRAWTEXT_FIX(ISLASTBAR,0.01,0.012,0,STRCAT(Z6,ZHBLOCK)),COLORYELLOW;
DRAWTEXT_FIX(1,0,0.075,0,STRCAT('【自定板块】:',ZDBLOCK)),COLORRED;


请老师就用这个公式修改吧,谢谢!!!
财财财发
Lv.3
发表于 2020-2-15 16:25 复制 查看全部楼层
谢谢老师!!!再修改一下,要求金叉处在k线上升角度最好有30度左右。
注册111
Lv.6
发表于 2020-2-15 08:33 复制 查看全部楼层
本帖最后由 注册111 于 2020-2-15 08:34 编辑
财财财发 发表于 2020-2-14 19:34
五日跟十日金叉同时靠近120现。


M5:=MA(C,5);
M10:=MA(C,10);
M120:=MA(C,120);
CROSS(M5,M10)&&BETWEEN(M5/M120,1,1.05)&&M5>M120;
财财财发
Lv.3
发表于 2020-2-14 19:34 复制 查看全部楼层
五日跟十日金叉同时靠近120现。
张彪77
Lv.3
发表于 2020-2-14 16:55 复制 查看全部楼层
怎么金叉写清楚。五日线金叉十日还是怎样
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表