手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助把公式改成大智慧版本的

[大智慧]
设置
1620 1 永不回撤 Lv.2 发表于 · 2020-2-14 20:04 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
附源码,源码为通达信版本的,希望老师能帮改成大智慧能用的


DRAWGBK(O>C,RGB(10,10,10),RGB(0,50,40),0,'01',0);
成交额:=V*C/100,NODRAW;
A2:=SUM((IF(((成交额/8>20) AND (CLOSE>(REF(CLOSE,1)))),成交额,0)),0);
A3:=SUM((IF(((成交额/8>20) AND (CLOSE<(REF(CLOSE,1)))),成交额,0)),0);
A4:=SUM((IF(((成交额/8<20) AND (CLOSE>(REF(CLOSE,1)))),成交额,0)),0);
A5:=SUM((IF(((成交额/8<20) AND (CLOSE<(REF(CLOSE,1)))),成交额,0)),0);
A6:=((A2+A3)+A4)+A5;
A7:=IF((ISLASTBAR),((100*A2)/A6),0);
A8:=IF((ISLASTBAR),((100*A3)/A6),0);
A9:=IF((ISLASTBAR),((100*A4)/A6),0);
A10:=IF((ISLASTBAR),((100*A5)/A6),0);
机构买:(A2),COLORRED,LINETHICK2;
机构卖:(A3),COLORGREEN,LINETHICK1;
机构进出:=机构买-机构卖,NODRAW;
散户买:(A4),COLORLIMAGENTA;
散户卖:(A5),COLORBLUE;
散户进出:=散户买-散户卖,,COLORWHITE,NODRAW;
强势:((100*A2)/A6>50);
STICKLINE(强势,机构买*1.02,机构买*1.1,0.1,0),COLORYELLOW;
拉升:((100*A2)/A6-(100*A3)/A6)>18 AND (100*A2)/A6-(100*A5)/A6>18;
STICKLINE(拉升,机构买*1.1,机构买*1.2,0.1,0),COLORRED;
DRAWTEXT(ISLASTBAR=1,机构买*0.95,''),LINETHICK1,COLORRED;
DRAWTEXT(ISLASTBAR=1,机构卖*0.95,''),LINETHICK1,COLORFFFF55;
Q:=BETWEEN(C/(SUM(AMOUNT,BARSCOUNT(C))/SUM(VOL*100,BARSCOUNT(C))),1.05,0.95);
Q2:=IF(Q=0,MA(C,BARSCOUNT(C)),(SUM(AMOUNT,BARSCOUNT(C))/SUM(VOL*100,BARSCOUNT(C))));
DRAWICON(CROSS((C/Q2),1.03),机构买,0);
XG:C/Q2;
DD1:=1;
AAA1:=STRCAT(STRCAT('机构买入',CON2STR((100*A2)/A6,0)),'%');
AAA2:=STRCAT(STRCAT('机构卖出',CON2STR((100*A3)/A6,0)),'%');
AAA0:=STRCAT(STRCAT('机构总买入',CON2STR((100*(A2-A3))/A6,0)),'%');
AAA3:=STRCAT(STRCAT('散户买入',CON2STR((100*A4)/A6,0)),'%');
AAA4:=STRCAT(STRCAT('散户卖出',CON2STR((100*A5)/A6,0)),'%');
AAA5:=STRCAT(STRCAT('散户总买入',CON2STR((100*(A4-A5))/A6,0)),'%');
{DRAWTEXT_FIX(DD1=1,0.001,0.05,0,AAA1),COLORRED;
DRAWTEXT_FIX(DD1=1,0.001,0.15,0,AAA2),COLORGREEN;
DRAWTEXT_FIX(DD1=1,0.001,0.25,0,AAA3),COLORLIMAGENTA;
DRAWTEXT_FIX(DD1=1,0.001,0.35,0,AAA4),COLORBLUE;
DRAWTEXT_FIX(DD1=1,0.001,0.45,0,AAA0),COLORRED;
DRAWTEXT_FIX(DD1=1,0.001,0.55,0,AAA5)COLORGREEN;}
主力净买额:=(机构进出+散户进出)/成交额,NODRAW;
AAA6:=STRCAT(STRCAT('主力净买额',CON2STR(主力净买额,0)),'%');
DRAWTEXT_FIX(DD1=1,0.14,0.15,0,AAA6),COLORWHITE;
资金流入:A2+A4,COLORRED,NODRAW;
资金流出:A3+A5,NODRAW;
资金:=资金流入-资金流出,NODRAW;
资金差:资金流入-资金流出,NODRAW;
WW:=资金>0;
QQ:=资金<0;
STICKLINE(资金 AND WW,资金,0,0.0005,0),COLORLIRED;
STICKLINE(资金 AND QQ,资金,0,0.0005,0),COLORCYAN;
本主题由 任务系统 于 2020-2-14 20:11 审核通过

相关股票

注册111
Lv.6
发表于 2020-2-15 08:16 复制 查看全部楼层
DRAWGBK(O>C);
成交额:=V*C/100;
A2:=SUM((IF(((成交额/8>20) AND (CLOSE>(REF(CLOSE,1)))),成交额,0)),0);
A3:=SUM((IF(((成交额/8>20) AND (CLOSE<(REF(CLOSE,1)))),成交额,0)),0);
A4:=SUM((IF(((成交额/8<20) AND (CLOSE>(REF(CLOSE,1)))),成交额,0)),0);
A5:=SUM((IF(((成交额/8<20) AND (CLOSE<(REF(CLOSE,1)))),成交额,0)),0);
A6:=((A2+A3)+A4)+A5;
A7:=IF((DISPSTATUS=2),((100*A2)/A6),0);
A8:=IF((DISPSTATUS=2),((100*A3)/A6),0);
A9:=IF((DISPSTATUS=2),((100*A4)/A6),0);
A10:=IF((DISPSTATUS=2),((100*A5)/A6),0);
机构买:(A2),COLORRED,LINETHICK2;
机构卖:(A3),COLORGREEN,LINETHICK1;
机构进出:=机构买-机构卖;
散户买:(A4),COLORBLUE;
散户卖:(A5),COLORBLUE;
散户进出:=散户买-散户卖;
强势:((100*A2)/A6>50);
STICKLINE(强势,机构买*1.02,机构买*1.1,0.1,0),COLORYELLOW;
拉升:((100*A2)/A6-(100*A3)/A6)>18 AND (100*A2)/A6-(100*A5)/A6>18;
STICKLINE(拉升,机构买*1.1,机构买*1.2,0.1,0),COLORRED;
DRAWTEXT(DISPSTATUS=2,机构买*0.95,''),LINETHICK1,COLORRED;
DRAWTEXT(DISPSTATUS=2,机构卖*0.95,''),LINETHICK1,COLORFFFF55;
Q:=BETWEEN(C/(SUM(AMOUNT,BARSCOUNT(C))/SUM(VOL*100,BARSCOUNT(C))),1.05,0.95);
Q2:=IF(Q=0,MA(C,BARSCOUNT(C)),(SUM(AMOUNT,BARSCOUNT(C))/SUM(VOL*100,BARSCOUNT(C))));
DRAWICON(CROSS((C/Q2),1.03),机构买,0);
XG:C/Q2;
DD1:=1;
AAA1:='机构买入'+NUMTOSTRN((100*A2)/A6,0)+'%';
AAA2:='机构卖出'+NUMTOSTRN((100*A3)/A6,0)+'%';
AAA0:='机构总买入'+NUMTOSTRN((100*(A2-A3))/A6,0)+'%';
AAA3:='散户买入'+NUMTOSTRN((100*A4)/A6,0)+'%';
AAA4:='散户卖出'+NUMTOSTRN((100*A5)/A6,0)+'%';
AAA5:='散户总买入'+NUMTOSTRN((100*(A4-A5))/A6,0)+'%';
{DRAWTEXT_FIX(DD1=1,0.001,0.05,0,AAA1),COLORRED;
DRAWTEXT_FIX(DD1=1,0.001,0.15,0,AAA2),COLORGREEN;
DRAWTEXT_FIX(DD1=1,0.001,0.25,0,AAA3),COLORLIMAGENTA;
DRAWTEXT_FIX(DD1=1,0.001,0.35,0,AAA4),COLORBLUE;
DRAWTEXT_FIX(DD1=1,0.001,0.45,0,AAA0),COLORRED;
DRAWTEXT_FIX(DD1=1,0.001,0.55,0,AAA5)COLORGREEN;}
主力净买额:=(机构进出+散户进出)/成交额;
AAA6:='主力净买额'+NUMTOSTRN(主力净买额,0)+'%';
DRAWTEXTABS(0,0,AAA6),COLORWHITE;
资金流入:A2+A4,COLORRED,LINETHICK0;
资金流出:A3+A5,LINETHICK0;
资金:=资金流入-资金流出;
资金差:资金流入-资金流出,LINETHICK0;
WW:=资金>0;
QQ:=资金<0;
STICKLINE(资金 AND WW,资金,0,0.0005,0);
STICKLINE(资金 AND QQ,资金,0,0.0005,0),COLORCYAN;
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表