手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助编写个选股和预警指标

[通达信]
设置
2209 1 你好9368 Lv.2 发表于 · 2020-2-14 20:39 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
麻烦老师帮写一个       分时图 幅图出现 + 号 的 选股 和预警 指标



MA25:EMA(CLOSE,25);
FJ:EMA(CLOSE,905);
STICKLINE((MA25 >FJ),MA25,FJ,1,0),COLOR0000FF;
STICKLINE((MA25 >FJ)AND MA25<REF(MA25,1),MA25,FJ,1,0),COLORYELLOW;
STICKLINE((MA25 >FJ)AND FJ<REF(FJ,1),MA25,FJ,1,0),COLORCYAN;
STICKLINE((MA25 <FJ),MA25,FJ,1,0),COLOR00FF00;
STICKLINE((MA25 <FJ)AND MA25>REF(MA25,1),MA25,FJ,1,0),COLORCYAN;
STICKLINE((MA25 <FJ)AND FJ>REF(FJ,1),MA25,FJ,1,0),COLORLIRED;
DRAWICON(CROSS(MA25,FJ),FJ,23);
TT:=BARSCOUNT(C)+1;
ZZ:=SUM(AMOUNT,TT)/SUM(VOL*100,TT);
ZZ1:=BETWEEN(C/ZZ,1.05,0.95);
均线:IF(ZZ1=0,MA(C,TT),ZZ),COLOR00FFFF,LINETHICK1;
{IF(均线>REF(均线,1),均线,DRAWNULL),COLORRED;}
上均:均线+MA(ABS(C-均线),TT)*1.7,COLOR00FF00;
下均:均线-MA(ABS(C-均线),TT)*1.7,COLORFF6600;
时长:=IF(HOUR>=13 AND HOUR<15 ,1,0);
涨幅:=(CLOSE/DYNAINFO(3))>=1.03;
跌幅:=(CLOSE/DYNAINFO(3))<=0.97;
涨跌幅:=涨幅 OR 跌幅;
YY:=SMA(VOL,30,1);
放量:=(YY-LLV(LLV(YY,1),30))/(HHV(HHV(YY,1),30)-LLV(LLV(YY,1),30))>0;
横盘:=((HHV(CLOSE,TT)-LLV(CLOSE,TT))/CLOSE)<=0.05;
横涨:=涨跌幅=0 AND 横盘 AND 时长 AND 放量 AND CROSS(C,上均) AND DYNAINFO(22)<DYNAINFO(23);
横跌:=涨跌幅=0 AND 横盘 AND 时长 AND 放量 AND CROSS(下均,C) ;
PP:=FILTER(横涨,80);
UU:=FILTER(横跌,50);
DRAWTEXT(PP,上均,'★上突'),COLORFF00FF;
DRAWTEXT(UU,下均,'★下破'),COLOR00FFFF;
STICKLINE(PP,CONST(HHV(H,0)),CONST(LLV(L,0)),0,0),COLORWHITE;
STICKLINE(UU,CONST(HHV(H,0)),CONST(LLV(L,0)),0,0),COLOR00FF00;
{STICKLINE(PP,上均,下均,0,0),COLORWHITE;}
{STICKLINE(UU,上均,上均,0,0),COLOR00FF00;};
休闲者68
Lv.6
发表于 2020-2-14 21:16 复制 查看全部楼层
MA25:=EMA(CLOSE,25);
FJ:=EMA(CLOSE,905);
XG:CROSS(MA25,FJ);
查看全部打赏
  • 你好9368+10理想币 +2共享币 : 谢谢老师
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表