手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙修改一个选股公式

[通达信]
设置
2297 7 多情杀手刘 Lv.2 发表于 · 2020-2-14 22:06 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
VAR26:=EMA(CLOSE,2)-EMA(CLOSE,150);
VAR27:=EMA(VAR26 ,100);
VAR28:=2*(VAR26-VAR27);
VAR29:=POW(VAR28,3)*0.1+POW(VAR28,1);
黑马线:=IF(VAR28>0.1,VAR29,0)*3;
黑马角度:=ATAN((黑马线/REF(黑马线,1)-1)*100)*180/3.1416;

选股:黑马角度>30 AND 黑马角度<70;这个选股可以选出黑马线,但我是想改动一下把选出的黑马线是上翘的角度上翘15~50度的上翘形态。

附件

IMG_20200214_220124.JPG
许昌舍得
Lv.6
发表于 2020-2-15 11:19 复制 查看全部楼层
多情杀手刘 发表于 2020-2-15 11:15
不知道什么原因,还是过不了。

发一个 导出的指标试试

附件

黑马角度.tn6

6.41 KB, 下载次数: 0, 下载积分: 共享币 -5 个

多情杀手刘
Lv.2
发表于 2020-2-15 11:15 复制 查看全部楼层
许昌舍得 发表于 2020-2-15 08:47
测试通过 没有问题

不知道什么原因,还是过不了。

附件

mmexport1581736433560.jpg
许昌舍得
Lv.6
发表于 2020-2-15 08:47 复制 查看全部楼层
测试通过 没有问题

附件

QQ图片20200215084631.png
多情杀手刘
Lv.2
发表于 2020-2-15 08:39 复制 查看全部楼层
许昌舍得 发表于 2020-2-14 22:14
P1:=15;
P2:=50;


老师帮忙看看怎么回事?通不过。

附件

mmexport1581691238995.jpg
多情杀手刘
Lv.2
发表于 2020-2-14 22:43 复制 查看全部楼层
休闲者68 发表于 2020-2-14 22:14
VAR26:=EMA(CLOSE,2)-EMA(CLOSE,150);
VAR27:=EMA(VAR26 ,100);
VAR28:=2*(VAR26-VAR27);

也是通不过。

附件

mmexport1581691238995.jpg
许昌舍得
Lv.6
发表于 2020-2-14 22:14 复制 查看全部楼层
P1:=15;
P2:=50;

VAR26:=EMA(CLOSE,2)-EMA(CLOSE,150);
VAR27:=EMA(VAR26 ,100);
VAR28:=2*(VAR26-VAR27);
VAR29:=POW(VAR28,3)*0.1+POW(VAR28,1);
黑马线:=IF(VAR28>0.1,VAR29,0)*3;
黑马角度:=ATAN((黑马线/REF(黑马线,1)-1)*100)*180/3.1416;

XG:BETWEEN(黑马角度,P1,P2);
休闲者68
Lv.6
发表于 2020-2-14 22:14 复制 查看全部楼层
VAR26:=EMA(CLOSE,2)-EMA(CLOSE,150);
VAR27:=EMA(VAR26 ,100);
VAR28:=2*(VAR26-VAR27);
VAR29:=POW(VAR28,3)*0.1+POW(VAR28,1);
黑马线:=IF(VAR28>0.1,VAR29,0)*3;
黑马角度:=ATAN((黑马线/REF(黑马线,1)-1)*100)*180/3.1416;

选股:BETWEEN(黑马角度,15,50);
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表