手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助做个预警指标

[通达信]
设置
2460 2 老飞贼 Lv.3 发表于 · 2020-2-15 10:47 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
麻烦老师帮做个预警指标,要求当出现红三角时预警。谢谢!

本指标为副图
AA:=(O+H+L+C)/4;
BB:=MA(AA,3);
CC:=SUM(IF(AA>REF(AA,1),AA*VOL,0),4)/SUM(IF(AA<REF(AA,1),AA*VOL,0),4);
DD:=REF(100-(100/(1+CC)),1);
A1:=HHV(AA,15);
A2:=LLV(AA,15);
A3:=A1-A2;
A4:=EMA((AA-A2)/A3,2)*100;
B1:=HHV(AA,60);
B2:=LLV(AA,60);
B3:=B1-B2;
B4:=EMA((AA-B2)/B3,2)*100;
C1:=HHV(AA,240);
C2:=LLV(AA,240);
C3:=C1-C2;
C4:=EMA((AA-C2)/C3,2)*100;
短期:A4,COLORGREEN;
中期:B4,COLORYELLOW;
长期:C4,COLORFF00FF;
IF(FILTER(中期<REF(中期,1)AND 中期>90 AND BB<REF(BB,1),5),80,100),COLORBLUE,LINETHICK2;
IF(FILTER(中期>REF(中期,1)AND 中期<5 AND C>REF(C,1),5),20,0),COLORRED,LINETHICK2;
STICKLINE(短期>90 AND 中期>70,95,100,1,0),COLORFF00FF;
STICKLINE(短期<5 AND 中期<30,0,5,1,0),COLORFF00FF;
D1:=中期>REF(中期,1)AND 短期>REF(短期,1)AND 长期>REF(长期,1)AND 长期<8 AND 中期<10 AND 短期<15;
D2:=CROSS(短期,中期)AND 中期<8;
D3:=CROSS(短期,长期)AND 长期<8 AND 中期<20;
DRAWICON(FILTER((D1 OR D2 OR D3) AND DD<15 AND C>REF(C,1),5),5,1);
DRAWICON(FILTER((中期<REF(中期,1)AND 短期<REF(短期,1)AND 长期<REF(长期,1)AND 中期>95 AND 短期>85)OR (长期>100 AND 中期>100 AND 短期>100),5),95,2);
警戒区:90,LINETHICK1,COLORWHITE;
生死线:50,LINETHICK1,COLORYELLOW;
安全区:20,COLORFFFF00;

附件

1.png
休闲者68
Lv.6
发表于 2020-2-15 11:05 复制 查看全部楼层
AA:=(O+H+L+C)/4;
B1:=HHV(AA,60);
B2:=LLV(AA,60);
B3:=B1-B2;
B4:=EMA((AA-B2)/B3,2)*100;
中期:=B4;
红三角:FILTER(中期>REF(中期,1)AND 中期<5 AND C>REF(C,1),5);
查看全部打赏
  • 老飞贼+2共享币 : 麻烦老师:选出来的都是2月7日上周五发出信号的呀?
许昌舍得
Lv.6
发表于 2020-2-15 11:04 复制 查看全部楼层
本帖最后由 许昌舍得 于 2020-2-15 11:10 编辑

AA:=(O+H+L+C)/4;
B1:=HHV(AA,60);
B2:=LLV(AA,60);
B3:=B1-B2;
B4:=EMA((AA-B2)/B3,2)*100;


中期:=B4,COLORYELLOW;


XG:FILTER(中期>REF(中期,1)AND 中期<5 AND C>REF(C,1),5);

附件

tdxjietu4.JPG
查看全部打赏
  • 老飞贼+2共享币 : 麻烦老师:选出来的都是2月10日周一发出信号的呀?
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表