手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙编写二个选股公式

[通达信]
设置
2126 3 多情杀手刘 Lv.2 发表于 · 2020-2-15 11:39 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
LC:=REF(CLOSE,1);
RSI1:SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100,COLOR555555;
大买主升浪:IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,90,0),COLOR1010FF,LINETHICK2;
V6:=CLOSE/REF(CLOSE,3)>=1.1;
V7:=BACKSET(V6,4);
涨停初现:IF((V7 AND COUNT(V7,3)=1),40,0),COLORCYAN,STICK,LINETHICK3;
LS:=C/REF(C,1)>1.040 AND C=H AND BETWEEN(FORCAST(V,4),0.2*FORCAST(V,12),2.1
*FORCAST(V,5)),COLORFF6600,LINETHICK1;
买涨停:FILTER(LS,28)*40,COLORFF6600,LINETHICK3 ,STICK;
VAR26:=EMA(CLOSE,2)-EMA(CLOSE,150);
VAR27:=EMA(VAR26 ,100);
VAR28:=2*(VAR26-VAR27);
VAR29:=POW(VAR28,3)*0.1+POW(VAR28,1);
黑马线: IF( VAR28>0.1,VAR29,0)*3, COLOR400080,LINETHICK2;
低买:IF(TROUGHBARS(3,6,1)=0 AND HIGH>LOW+0.04,50,0),COLOR00FFFF,LINETHICK1;
高卖:IF(PEAKBARS(3,6,1)<1.0=1,70,0),COLORGREEN,LINESTICK,LINETHICK1;
最佳买入: ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)
<REF
(ZIG(3,10),2),COLORRED,LINETHICK2;
DRAWTEXT(最佳买入=1,40,'最佳买点'),COLORRED;第一个编写选黑马线上翘30~50角度。第二个编写出现:涨停初现:图中紫色线是黑马线,浅蓝是涨停初现。辛苦老师了!

附件

mmexport1581737917786.jpg
休闲者68
Lv.6
发表于 2020-2-15 12:51 复制 查看全部楼层
多情杀手刘 发表于 2020-2-15 12:45
谢谢了。就是找出的黑马线有的不是上翘的,也有上翘的。

VAR26:=EMA(CLOSE,2)-EMA(CLOSE,150);
VAR27:=EMA(VAR26 ,100);
VAR28:=2*(VAR26-VAR27);
VAR29:=POW(VAR28,3)*0.1+POW(VAR28,1);
黑马线:=IF(VAR28>0.1,VAR29,0)*3;
黑马角度:=ATAN((黑马线/REF(黑马线,1)-1)*100)*180/3.1416;
BETWEEN(黑马角度,30,50) AND 黑马线>REF(黑马线,1);
多情杀手刘
Lv.2
发表于 2020-2-15 12:45 复制 查看全部楼层
休闲者68 发表于 2020-2-15 12:20
VAR26:=EMA(CLOSE,2)-EMA(CLOSE,150);
VAR27:=EMA(VAR26 ,100);
VAR28:=2*(VAR26-VAR27);

谢谢了。就是找出的黑马线有的不是上翘的,也有上翘的。
休闲者68
Lv.6
发表于 2020-2-15 12:20 复制 查看全部楼层
VAR26:=EMA(CLOSE,2)-EMA(CLOSE,150);
VAR27:=EMA(VAR26 ,100);
VAR28:=2*(VAR26-VAR27);
VAR29:=POW(VAR28,3)*0.1+POW(VAR28,1);
黑马线:=IF(VAR28>0.1,VAR29,0)*3;
黑马角度:=ATAN((黑马线/REF(黑马线,1)-1)*100)*180/3.1416;
BETWEEN(黑马角度,30,50);

V6:=CLOSE/REF(CLOSE,3)>=1.1;
V7:=BACKSET(V6,4);
涨停初现:(V7 AND COUNT(V7,3)=1);
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表