手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助将四个指标合并为一个副图指标

[通达信]
设置
2520 6 老飞贼 Lv.3 发表于 · 2020-2-15 12:36 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
麻烦老师帮我将四个指标合并为一个副图指标,因为几个指标会有不少地方有重合,所以,希望用三角的高低和颜色区分开,麻烦老师了,谢谢!谢谢!!


1.买(用红色显示,三角高度为1)
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);

买:=LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2));
XG:FILTER(买=1,5);

2.加(用黄色显示,三角高度为0.75)
A:=(3*C+L+O+H)/6;
VAR4:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/210;
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
CB:=EMA(VAR4,13);


买:=LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2));

加仓:=SMA(EMA((C-REF(C,1))/REF(C,1),5)*100,3,1)*10;
XG:FILTER((CROSS(加仓,0) OR CROSS(CLOSE,CB)) AND 买=1,3);

3.跟(用兰色显示,三角高度为0.5)
MA18:=MA(CLOSE,18);
跟:MA18>=REF(MA18,3) AND CROSS(CLOSE,MA18);

4.买1(用绿色显示,三角高度为0.25)
AA:=(O+H+L+C)/4;
B1:=HHV(AA,60);
B2:=LLV(AA,60);
B3:=B1-B2;
B4:=EMA((AA-B2)/B3,2)*100;


中期:=B4,COLORYELLOW;


XG:FILTER(中期>REF(中期,1)AND 中期<5 AND C>REF(C,1),5);

附件

2.png
沙漠胡杨5
Lv.3
发表于 2020-2-15 18:53 复制 查看全部楼层
两位老师无私奉献令人佩服,公式如果修改一下, 在副图上看到象买一样那样直观就好了
老飞贼
Lv.3
发表于 2020-2-15 13:25 复制 查看全部楼层
注册111 发表于 2020-2-15 12:53
{1.买(用红色显示,三角高度为1)}
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6 ...

谢谢老师!
老飞贼
Lv.3
发表于 2020-2-15 13:24 复制 查看全部楼层
注册111 发表于 2020-2-15 12:53
{1.买(用红色显示,三角高度为1)}
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6 ...

谢谢老师!
老飞贼
Lv.3
发表于 2020-2-15 13:23 复制 查看全部楼层
本帖最后由 老飞贼 于 2020-2-15 13:26 编辑
休闲者68 发表于 2020-2-15 12:48
{1.买(用红色显示,三角高度为1)}
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6 ...


麻烦老师,显示通不过

附件

1581743698.png
注册111
Lv.6
发表于 2020-2-15 12:53 复制 查看全部楼层
{1.买(用红色显示,三角高度为1)}
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
买:=LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2));
XG:FILTER(买=1,5),COLORRED;

{2.加(用黄色显示,三角高度为0.75)}
A:=(3*C+L+O+H)/6;
VAR4:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/210;
CB:=EMA(VAR4,13);
加仓:=SMA(EMA((C-REF(C,1))/REF(C,1),5)*100,3,1)*10;
XG1:FILTER((CROSS(加仓,0) OR CROSS(CLOSE,CB)) AND 买=1,3)*0.75,COLORYELLOW;

{3.跟(用兰色显示,三角高度为0.5)}
MA18:=MA(CLOSE,18);
跟:(MA18>=REF(MA18,3) AND CROSS(CLOSE,MA18))*0.5,COLORBLUE;

{4.买1(用绿色显示,三角高度为0.25)}
AA:=(O+H+L+C)/4;
B1:=HHV(AA,60);
B2:=LLV(AA,60);
B3:=B1-B2;
B4:=EMA((AA-B2)/B3,2)*100;
中期:=B4,COLORYELLOW;
XG2:FILTER(中期>REF(中期,1)AND 中期<5 AND C>REF(C,1),5)*0.25,COLORGREEN;
休闲者68
Lv.6
发表于 2020-2-15 12:48 复制 查看全部楼层
{1.买(用红色显示,三角高度为1)}
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
买:=LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2));
XG1:FILTER(买=1,5);
{2.加(用黄色显示,三角高度为0.75)}
A:=(3*C+L+O+H)/6;
VAR4:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/210;
{MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
CB:=EMA(VAR4,13);
买:=LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2));}
加仓:=SMA(EMA((C-REF(C,1))/REF(C,1),5)*100,3,1)*10;
XG2:FILTER((CROSS(加仓,0) OR CROSS(CLOSE,CB)) AND 买=1,3);
{3.跟(用兰色显示,三角高度为0.5)}
MA18:=MA(CLOSE,18);
跟:MA18>=REF(MA18,3) AND CROSS(CLOSE,MA18);
{4.买1(用绿色显示,三角高度为0.25)}
AA:=(O+H+L+C)/4;
B1:=HHV(AA,60);
B2:=LLV(AA,60);
B3:=B1-B2;
B4:=EMA((AA-B2)/B3,2)*100;
中期:=B4,COLORYELLOW;
XG3:FILTER(中期>REF(中期,1)AND 中期<5 AND C>REF(C,1),5);
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表