手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助编写个选股公式

[通达信]
设置
1962 6 理想b9addd Lv.3 发表于 · 2020-2-15 15:20 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
DKX:(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+
16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+
13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+
10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+
7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+
4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210;
MADKX:MA(DKX,M);
1出红箭头选股
2出红箭头+macd金叉共振选股,谢谢老师。
注册111
Lv.6
发表于 2020-2-17 07:34 复制 查看全部楼层
理想b9addd 发表于 2020-2-16 18:59
老师当前公式 : DKJC (条件选股公式)  
错误句 :
MADKX:=MA(DKX,M)

m是参数,如不知就把m换成6。
理想b9addd
Lv.3
发表于 2020-2-16 18:59 复制 查看全部楼层

老师当前公式 : DKJC (条件选股公式)  
错误句 :
MADKX:=MA(DKX,M)
详细信息 : 未知字符串 M
错误起始位置 : 342 ; 长度: 1
休闲者68
Lv.6
发表于 2020-2-15 16:11 复制 查看全部楼层
MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
DKX:(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210;
MADKX:=MA(DKX,M);
选股:CROSS(DKX,MADKX);





MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
DKX:(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210;
MADKX:=MA(DKX,M);
共振:CROSS(DKX,MADKX) AND CROSS(MACD.DIF,MACD.DEA);
注册111
Lv.6
发表于 2020-2-15 15:54 复制 查看全部楼层
本帖最后由 福阿德 于 2020-2-16 15:45 编辑
理想b9addd 发表于 2020-2-15 15:49
老师这个是通达信自带多空线


附件

回复.txt [预览]

814 Bytes, 下载次数: 1, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+8理想币 +7共享币 : 赠人玫瑰,手有余香。
理想b9addd
Lv.3
发表于 2020-2-15 15:49 复制 查看全部楼层
休闲者68 发表于 2020-2-15 15:45
公式中没有红箭头,且M没有赋值;

老师这个是通达信自带多空线
休闲者68
Lv.6
发表于 2020-2-15 15:45 复制 查看全部楼层
公式中没有红箭头,且M没有赋值;
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表