手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙修改:BSTS指标在365版本不显示

[大智慧]
设置
1362 0 钱途在望 Lv.5 发表于 · 2020-2-15 19:20 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
a:="[email protected]";
R1:="[email protected]_RISK1";
R2:="[email protected]_RISK2";
S1:="[email protected]_STS1";
S2:="[email protected]_STS2";
TBS:="[email protected]_STSBS";
DN:="[email protected]_STSDN";
UP:="[email protected]_STSUP";

压力位:UP,linethick0,color0000ff,PRECIS2;
支撑位:DN,linethick0,color00ff00,PRECIS2;
警示位:IF(R1<>0,ABS(R1),IF(R2<>0,ABS(R2),0)),linethick0,colorff00ff,PRECIS2;
MA5:MA(CLOSE,5),colorFFFFff,PRECIS2;
MA10:MA(CLOSE,10),color00FFff,PRECIS2;
MA24:MA(CLOSE,24),COLORFF00FF,PRECIS2;
DRAWLINE(UP>0,UP,UP<>REF(UP,1) OR C=DYNAINFO(7),REF(ABS(UP),1),0),dotline,color0000ff,LINETHICK1;
DRAWLINE(DN>0,DN,DN<>REF(DN,1) OR C=DYNAINFO(7),REF(ABS(DN),1),0),dotline,color00ff00,LINETHICK1;
DRAWLINE(UP<0,-UP,UP<>REF(UP,1) OR C=DYNAINFO(7),REF(ABS(UP),1),0),color0000ff;
DRAWLINE(DN<0,-DN,DN<>REF(DN,1) OR C=DYNAINFO(7),REF(ABS(DN),1),0),color00ff00;
DRAWLINE(R1>0,R1,R1<>REF(R1,1) OR C=DYNAINFO(7),REF(ABS(R1),1),0),dotline,colorEE88ff;
DRAWLINE(R2>0,R2,R2<>REF(R2,1) OR C=DYNAINFO(7),REF(ABS(R2),1),0),dotline,colorEE88ff;
DRAWLINE(R1<0,-R1,R1<>REF(R1,1) OR C=DYNAINFO(7),REF(ABS(R1),1),0),colorEE88ff;
DRAWLINE(R2<0,-R2,R2<>REF(R2,1) OR C=DYNAINFO(7),REF(ABS(R2),1),0),colorEE88ff;

drawbmp(TBS=1,l*0.96,'STSbuy1.bmp'),align1,valign0;
drawbmp(TBS=-1,h*1.07,'STSsell1.bmp'),align1,valign0;
drawbmp(S2=14,l*0.94,'STSbuy.bmp'),align1,valign0;
drawbmp(S2=-14,h*1.09,'STSsell.bmp'),align1,valign0;

drawtext(S1>0,L,STR(S1)),color00FF00,LINETHICK1,align1,valign0;
drawtext(S1<0,H*1.03,STR(-S1)),color00FF00,LINETHICK1,align1,valign0;
drawtext(S2>0 and S2<13,l*0.97,STR(S2)),color0000FF,LINETHICK1,align1,valign0;
drawtext(S2<0 and S2>-13,H*1.06,STR(-S2)),color0000FF,LINETHICK1,align1,valign0;
drawtext(S2=13,l*0.97,'+'),color0000FF,LINETHICK1,align1,valign0;
drawtext(S2=14,l*0.97,'13'),color0000FF,LINETHICK1,align1,valign0;
drawtext(S2=-13,h*1.06,'+'),color0000FF,LINETHICK1,align1,valign0;
drawtext(S2=-14,h*1.06,'13'),color0000FF,LINETHICK1,align1,valign0;

b:="[email protected]";
s11:="[email protected]_S1";
hs:="[email protected]_HS";
ls:="[email protected]_LS";
p1:="[email protected]_P1";
upp:="[email protected]_UPP";
udd:="[email protected]_UDD";

d1:=ema(abs("ddx.ddx"),60);
d2:=max("ddx.ddx"/d1+7.5,7.5);
d3:=min("ddx.ddx"/d1,10);
fb:=if(s11=0,hs,ls);
tr0:=ifs(p1=1,'明日收盘价<'+numtostrn(udd,2)+',出现S点\n','若明日收盘价>'+numtostrn(upp,2)+',出现B点\n');
tr1:=ifs(s11=1,'明日收盘价<'+numtostrn(ls,2)+',短线卖出机会','若明日收盘价>'+numtostrn(hs,2)+'短线买入机会');
tr2:=ifs(p1=1,ifs(cross(p1,0),'B点','持股'),ifs(cross(1,p1),'S点','持币'));
tr3:=ifs(s11=0,'向下,','向上,');
tr4:='3.能量级别:'+numtostrn(d3,1)+'级';

bs:='<*t=0092F7*><*c=FFFFFF*><*p=95*>'+datestr(date)+'买卖点决策系统提示\n'+'<*t=E7FFFF*><*c=000000*><*p=95*>'+'1.BS点:'+tr2+','+tr0+'<*t=E7FFFF*><*c=000000*><*p=95*>'+'2.短线:'+tr3+tr1+'\n'+'<*t=E7FFFF*><*c=000000*><*p=95*>'+tr4;
drawflagtext(1,fb,bs);

STICKLINE(p1=1 and c>=o and o<>0,c,o,d2,0),color5454ff;
STICKLINE(p1=1 and c>=o and o<>0,c,o,7.5,0),colorblack;
STICKLINE(p1=1 and c>=o and o<>0,c,c,7.5,0),color5454ff;
STICKLINE(p1=1 and c>=o and o<>0,o,o,7.5,0),color5454ff;
STICKLINE(p1=1 and c>=o and o<>0,o,c,7.5,1),color5454ff;
STICKLINE(p1=1 and c<=o,o,c,7.5,1),color5454ff;
STICKLINE(p1=1 and c<=o,l,c,0.5,1),color5454ff;
STICKLINE(p1=1 and c<=o,h,o,0.5,1),color5454ff;

STICKLINE((p1<>1 or barscount(c)<3) and c>=o,c,o,7.5,1),colorffff54;
STICKLINE((p1<>1 or barscount(c)<3) and c>=o,c,h,0.5,1),colorffff54;
STICKLINE((p1<>1 or barscount(c)<3) and c>=o,l,o,0.5,1),colorffff54;

drawbmp(p1=1 and ref(p1,1)=0,l,'buy1.bmp'),align1,valign0;
drawbmp(p1=0 and ref(p1,1)=1,h,'sell1.bmp'),align1,valign2;

drawbmp(s11=1 and ref(s11,1)=0 and (p1+ref(p1,1))<>1,l,'bs.bmp'),align1,valign0;
drawbmp(s11=0 and ref(s11,1)=1 and (p1+ref(p1,1))<>1,h,'ss.bmp'),align1,valign2;

流通盘大小:=FINANCE2(37)/1000000*100;
DRAWTEXTABS(20,20,'总股本:'+NUMTOSTR(FINANCE2(35)/10000 )+'亿'+' 流通股:'+ NUMTOSTR(CAPITAL/1000000)+'亿'),COLORACFFFF;
DRAWTEXTABS(20,35,'上市日期:'+STR(FINANCE2(2))+'日'),ColorACFFFF;
每股收益:=FINANCE2(3);
每股市盈率:=DYNAINFO(39);
每股净资产:=FINANCE2(4);
销售毛利率:=FINANCE2(12);
主营收入同比:=FINANCE2(11);  
净利润同比增长:=FINANCE2(10);
每股公积金:=FINANCE2(7);
每股未分配:=FINANCE2(8);
{DRAWTEXTABS(20,40,'基本面优劣提示:'),COLOR505050;}
DRAWTEXTABS(20,50,'每股收益:'+NUMTOSTRN(每股收益,2)+'元'),COLORACFFFF;
DRAWTEXTABS(20,65,'每股市盈率:'+NUMTOSTRN(每股市盈率,1)+'倍'),COLORACFFFF;
DRAWTEXTABS(20,80,'每股净资产:'+NUMTOSTRN(每股净资产,2)+'元'),COLORACFFFF;
DRAWTEXTABS(20,95,'每股公积金:'+NUMTOSTRN(每股公积金,2)+'元'),ColorACFFFF;
DRAWTEXTABS(20,110,'每股未分配:'+NUMTOSTRN(每股未分配,2)+'元'),ColorACFFFF;
DRAWTEXTABS(20,125,'销售毛利率:'+NUMTOSTRN(销售毛利率,2)+'%'),COLORACFFFF;
DRAWTEXTABS(20,140,'主营收入同比增长:'+NUMTOSTRN(主营收入同比,2)+'%'),COLORACFFFF;
DRAWTEXTABS(20,155,'净利润同比增长:'+NUMTOSTRN(净利润同比增长,2)+'%'),COLORACFFFF;
{DRAWTEXTABS(20,80,'换手率高低提示:'),COLOR505050;}
当日换手率:=sum(100*v/capital,1);
DRAWTEXTABS(170,135,'当日换手率: '+NUMTOSTRN(当日换手率,2)+'%'),COLORACFFFF;
五日换手率:=sum(100*v/capital,5);
DRAWTEXTABS(170,150,'5日换手率: '+NUMTOSTRN(五日换手率,2)+'%'),COLORACFFFF;
DRAWTEXTABS(20,5,'所属板块:'+BKNAME),COLORACFFFF;
DRAWTEXTABS(160,120,'上涨家数:'+NUMTOSTRN(INDEXADV,0)+'    下跌家数:'+NUMTOSTRN(INDEXDEC,0)),COLORACFFFF;

这个是‘BSTS选股’公式:
a:="[email protected]";
R1:="[email protected]_RISK1";
R2:="[email protected]_RISK2";
S1:="[email protected]_STS1";

b:="[email protected]";
s11:="[email protected]_S1";
p0:="[email protected]_P0";
p1:="[email protected]_P1";
b:="[email protected]";
s11:="[email protected]_s11";
p0:="[email protected]_P0";
p1:="[email protected]_P1";
s1<0 and ref(s1,1)>=0 and cross(p1,0);

D:=V/REF(V,1)>=1.5;
时长:=if(HOUR>=14 AND HOUR<15 ,1,0);{14点至 15点};
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表