手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助改下指标老版可以导入新版无法导入

[通达信]
设置
1537 4 旧记忆 Lv.4 发表于 · 2020-2-15 20:26 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
老师改下指标老板可以导入新版无法导入希望老师能给在优化下



RQ:=DATETODAY(DATE)-DATETODAY(REF(DATE,TOTALBARSCOUNT-CURRBARSCOUNT))+1;
JY:=BARSLAST((RQ-REF(RQ,1))!=WEEKDAY-REF(WEEKDAY,1) OR TOTALBARSCOUNT-CURRBARSCOUNT=0)+1;
MA1:=REF(C,JY);
MA2:=REF(MA1,JY);
MA3:=REF(MA2,JY);
MA4:=REF(MA3,JY);
MA5:=REF(MA4,JY);
MA6:=REF(MA5,JY);
MA7:=REF(MA6,JY);
MA8:=REF(MA7,JY);
MA9:=REF(MA8,JY);
CK:REFDATE((C+MA1+MA2+MA3+MA4+MA5+MA6+MA7+MA8+MA9)/10,DATE),COLORAC59FF,CIRCLEDOT;
DRAWTEXT(ISLASTBAR,CK,' 参考线'),COLOR0000FF;

GJ:C,COLORWHITE;
JJ:SUM(C*V,FROMOPEN)/SUM(V,FROMOPEN),COLORYELLOW,LINETHICK1.5;
均量:=MA(V,5);
量连增:=均量>REF(均量,1) AND REF(均量,1)>REF(均量,2);
价连涨:=C>=REF(C,1) AND REF(C,1)>REF(C,2);
价量线上:=C>JJ AND V>均量;
倍量:=V>=REF(V,1)*2 ;
价新高:=C>=HHV(C,FROMOPEN);
量新高:=V>=HHV(V,FROMOPEN);
限幅:=C/DYNAINFO(3)<=1.02;
起爆:=FILTER(量连增 AND 价连涨 AND 价量线上 AND 倍量 AND 价新高 AND 量新高 AND 限幅,20);
DRAWTEXT(起爆,C,'起爆'),COLOR00FFFF;
DRAWICON(起爆,C,1);
STICKLINE(起爆,C,JJ,1,0),COLOR1000FF;
VV:=BARSSINCE(起爆);
起爆价:=REF(C,VV);
起爆时间:=REF(TIME/10000,VV);
收益:=(DYNAINFO(7)-起爆价)/起爆价*100;
DRAWICON(VV>=2,起爆价,13);
DRAWTEXT_FIX(1,0,1,0,'起爆时间:'),COLOR00FFFF;
DRAWNUMBER_FIX(1,0.06,1,0,CONST(起爆时间)),COLOR00FFFF;
DRAWTEXT_FIX(1,0.12,1,0,'起爆价:'),COLOR00FFFF;
DRAWNUMBER_FIX(1,0.17,1,0,CONST(起爆价)),COLOR00FFFF;
DRAWTEXT_FIX(1,0.24,1,0,'收益:'),COLOR00FFFF;
DRAWNUMBER_FIX(1,0.28.06,1,0,CONST(收益)),COLOR00FFFF;
流通盘:CAPITAL*100/100000000,NODRAW;
资金流入:=SUM(IF(C>REF(C,1),V,0),FROMOPEN),NODRAW;
资金流出:=-SUM(IF(C<REF(C,1),V,0),FROMOPEN),NODRAW;
资金出入:=资金流入+资金流出,NODRAW;
NN:=2400,NODRAW;
HD:=HHV(资金出入,NN),NODRAW;
LD:=LLV(资金出入,NN),NODRAW;
最高:=CONST(HD),NODRAW;
最低:=CONST(LD),NODRAW;
HLMAX:=最高;
HLMIN:=最低;
HLMN1:=(HLMAX+HLMIN)/2;
HLMN2:=HLMAX-HLMIN;
HLMN3:=(100-0)/2*1.3;
HLMN4:=(100-0)/1*1.3;
中间价轴:=(50-HLMN3)*HLMN2/HLMN4+HLMN1;
轴差:=最高-最低;
DRAWBAND(资金出入,RGB(150,0,150),0,RGB(0,100,0)),NODRAW;
资金流量:资金出入,NODRAW;
资金比:资金出入/SUM(V,FROMOPEN)*100,NODRAW;
资金流量比:=IF(资金比>=0,(资金比+100)/2,100-ABS((资金比-100)/2)),NODRAW;
攻击量:=((HSL*0.50+REF(HSL,1)*0.33)+(REF(HSL,2)*0.17))*SUM(C,FROMOPEN)/FROMOPEN,NODRAW;
攻击量A:=SUM(IF(C>REF(C,1),攻击量*V,0),FROMOPEN),NODRAW;
攻击量B:=-SUM(IF(C<REF(C,1),攻击量*V,0),FROMOPEN),NODRAW;
攻击流量:攻击量A+攻击量B,NODRAW;
NOTEXT攻击线:攻击流量,NODRAW;
攻击比:攻击流量/SUM(V,FROMOPEN)*100,COLORRED,NODRAW;
资金攻击度:=IF(攻击比>=0,(攻击比+50),100-ABS((攻击比-50)));

{STICKLINE(攻击量A>0,攻击量A,0,1,0),COLOR0000FF;
STICKLINE(攻击量B<0,攻击量B,0,1,0),COLORFF0000;}

DRAWRECTREL(110,10,400,90,RGB(0,75,200));
DRAWRECTREL(110,10,250,90,RGB(0,250,50));
DRAWRECTREL(110,10,100+CONST(资金流量比*300/100),90,RGB(200,50,0));
DRAWTEXT_FIX(1,0.000,0.00,0,STRCAT(STRCAT('【资金流量比】',CON2STR(资金流量比,2)),'%买')),COLORYELLOW;
DRAWRECTREL(610,10,900,90,RGB(0,75,200));
DRAWRECTREL(610,10,750,90,RGB(0,250,50));
DRAWRECTREL(610,10,600+CONST(资金攻击度*300/100),90,RGB(175,50,0));
DRAWTEXT_FIX(1,0.500,0.00,0,STRCAT(STRCAT('【资金攻击度】',CON2STR(资金攻击度,2)),' %买')),COLORYELLOW;

H1:=MAX(DYNAINFO(3),DYNAINFO(5));
L1:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1-L1;
阻力:L1+P1*7/8,COLOR00DD00;

现价:CLOSE,COLORWHITE,LINETHICK1;

DRAWTEXT(LONGCROSS(现价,阻力,8),现价,'★S抛'),COLORGREEN;{抛};
{T+1止赢、止损}
止赢:H1,COLORRED,LINETHICK6;
DRAWTEXT(ISLASTBAR,H1,'当日止赢价位'),COLORRED,LINETHICK6;



UR:=10;LR:=10;
均价:SUM(V*C,0)/SUM(V,0),COLORYELLOW;

AAA:=MAX(DYNAINFO(3),DYNAINFO(5));
BBB:=MIN(DYNAINFO(3),DYNAINFO(6));
CCC:=AAA-BBB;
中轨:=(AAA+BBB)/1,POINTDOT;


上顶:BBB+CCC*2/3,POINTDOT;
下底:BBB+CCC/3,COLORBLUE,POINTDOT;
支撑:BBB+CCC*1/8,COLORMAGENTA,POINTDOT;
支撑1:BBB+CCC*0.5/8,POINTDOT;
STICKLINE(C>阻力,阻力,C,2,0),COLORGREEN;
STICKLINE(C<支撑,支撑,C,2,0),COLORLIMAGENTA;
DRAWTEXT(LONGCROSS(支撑1,C,2),下底,'B'),COLORYELLOW;{B}
DRAWTEXT(LONGCROSS(C,阻力,2),上顶,'S'),COLORRED;{S};

{反线}
长周期:EMA(CLOSE,250),NODRAW,COLOR8000FF;
NOTEXTA:IF(长周期>=REF(长周期,1),长周期,DRAWNULL),COLORRED,LINETHICK4,POINTDOT;
NOTEXTB:IF(长周期<REF(长周期,1),长周期,DRAWNULL),COLOR006A6A,LINETHICK4,POINTDOT;
反线:EMA((长周期-(EMA(CLOSE,3)-长周期)),5),LINETHICK2,COLORBLUE;
效果:=CROSS(长周期,反线);
DRAWICON(CROSS(C,反线) AND MA(反线,3)<REF(MA(反线,3),1),反线*0.999,23);{起爆点做标记}
DRAWTEXT(效果,长周期*0.998,'起爆'),COLOR8000FF;



箱顶:HHV(MA((LOW+HIGH+CLOSE+O)/4,5),58),COLORGREEN,LINETHICK1;
箱底:LLV(MA((LOW+HIGH+CLOSE+O)/4,6),88),COLORGREEN ,LINETHICK1;

W1:=C=HHV(C,20);
W2:=BARSLAST(W1);
W3:=IF(W2>0,REF(C,W2),REF(C,W2));
W4:=CROSS(C,REF(W3,1));
突破盘整:=W4 AND COUNT(W4,5)=1;
DRAWICON(突破盘整,L-0.10,9);AHIGHN:=10;ALOWN:=10;AHIGHDISPLAY:=0;ALOWDISPLAY:=0;AZGDISPLAY:=0;AMADISPLAY:=0;

AA:=MAX(DYNAINFO(3),DYNAINFO(5));
CC:=MIN(DYNAINFO(3),DYNAINFO(6));
DD:=AA-CC;
EE:=CC+DD*7/8;
GG:=CC+DD*0.5/8;
DRAWICON(LONGCROSS(GG,CLOSE,2),CLOSE,1);
DRAWICON(LONGCROSS(CLOSE,EE,2),CLOSE,2);
M1:=DYNAINFO(4);
M2:=DYNAINFO(5);
M3:=DYNAINFO(6);
M4:=DYNAINFO(11);
M5:=CLOSE;
M6:=BARSCOUNT(M5);
M7:=SUM(VOL*CLOSE,0)/SUM(VOL,0);
M8:=MA(M5,M6);
M9:=M8+2*STD(M5,3);
M10:=M8-2*STD(M5,3);
DRAWICON(CROSS(M7,M8),M7,38);
M11:=TIME>93000;
M12:=M5/REF(CLOSE,1)>1.02;
M13:=M5/REF(CLOSE,1)<0.98;
M14:=(HHV(M5,M6)-LLV(M5,M6))/M5<0.05;
M15:=SMA(VOL,30,1);
M16:=(M15-LLV(LLV(M15,1),30))/(HHV(HHV(M15,1),30)-LLV(LLV(M15,1),30))>0.95;
M17:=M12 OR M13;
M18:=M17=0 AND M14 AND M16 AND CROSS(M7,M8);
DRAWTEXT(FILTER(M18,10),M7,3),COLORYELLOW;
M19:=M17=0 AND M14 AND M16 AND CROSS(CLOSE,M7) AND CROSS(CLOSE,M8);
DRAWTEXT(FILTER(M19,10),M7*0.99,4),COLORRED;

箱顶2:HHV(MA((LOW+HIGH+CLOSE+O)/4,5),58),COLORYELLOW,LINETHICK1;
旧记忆
Lv.4
发表于 2020-2-15 21:02 复制 查看全部楼层
许昌舍得 发表于 2020-2-15 20:45
RQ:=DATETODAY(DATE)-DATETODAY(REF(DATE,TOTALBARSCOUNT-CURRBARSCOUNT))+1;
JY:=BARSLAST((RQ-REF(RQ,1) ...

谢谢老师老师辛苦了
旧记忆
Lv.4
发表于 2020-2-15 21:02 复制 查看全部楼层
暴富的蜗牛 发表于 2020-2-15 20:32
JJ:SUM(C*V,FROMOPEN)/SUM(V,FROMOPEN),COLORYELLOW,LINETHICK1.5;  1.5是不行的,只能是整数,可以改成1或 ...

谢谢老师,老师辛苦了
许昌舍得
Lv.6
发表于 2020-2-15 20:45 复制 查看全部楼层
RQ:=DATETODAY(DATE)-DATETODAY(REF(DATE,TOTALBARSCOUNT-CURRBARSCOUNT))+1;
JY:=BARSLAST((RQ-REF(RQ,1))!=WEEKDAY-REF(WEEKDAY,1) OR TOTALBARSCOUNT-CURRBARSCOUNT=0)+1;
MA1:=REF(C,JY);
MA2:=REF(MA1,JY);
MA3:=REF(MA2,JY);
MA4:=REF(MA3,JY);
MA5:=REF(MA4,JY);
MA6:=REF(MA5,JY);
MA7:=REF(MA6,JY);
MA8:=REF(MA7,JY);
MA9:=REF(MA8,JY);
CK:REFDATE((C+MA1+MA2+MA3+MA4+MA5+MA6+MA7+MA8+MA9)/10,DATE),COLORAC59FF,CIRCLEDOT;
DRAWTEXT(ISLASTBAR,CK,' 参考线'),COLOR0000FF;

GJ:C,COLORWHITE;
JJ:SUM(C*V,FROMOPEN)/SUM(V,FROMOPEN),COLORYELLOW,LINETHICK1;
均量:=MA(V,5);
量连增:=均量>REF(均量,1) AND REF(均量,1)>REF(均量,2);
价连涨:=C>=REF(C,1) AND REF(C,1)>REF(C,2);
价量线上:=C>JJ AND V>均量;
倍量:=V>=REF(V,1)*2 ;
价新高:=C>=HHV(C,FROMOPEN);
量新高:=V>=HHV(V,FROMOPEN);
限幅:=C/DYNAINFO(3)<=1.02;
起爆:=FILTER(量连增 AND 价连涨 AND 价量线上 AND 倍量 AND 价新高 AND 量新高 AND 限幅,20);
DRAWTEXT(起爆,C,'起爆'),COLOR00FFFF;
DRAWICON(起爆,C,1);
STICKLINE(起爆,C,JJ,1,0),COLOR1000FF;
VV:=BARSSINCE(起爆);
起爆价:=REF(C,VV);
起爆时间:=REF(TIME/10000,VV);
收益:=(DYNAINFO(7)-起爆价)/起爆价*100;
DRAWICON(VV>=2,起爆价,13);
DRAWTEXT_FIX(1,0,1,0,'起爆时间:'),COLOR00FFFF;
DRAWNUMBER_FIX(1,0.06,1,0,CONST(起爆时间)),COLOR00FFFF;
DRAWTEXT_FIX(1,0.12,1,0,'起爆价:'),COLOR00FFFF;
DRAWNUMBER_FIX(1,0.17,1,0,CONST(起爆价)),COLOR00FFFF;
DRAWTEXT_FIX(1,0.24,1,0,'收益:'),COLOR00FFFF;
DRAWNUMBER_FIX(1,0.28.06,1,0,CONST(收益)),COLOR00FFFF;
流通盘:CAPITAL*100/100000000,NODRAW;
资金流入:=SUM(IF(C>REF(C,1),V,0),FROMOPEN),NODRAW;
资金流出:=-SUM(IF(C<REF(C,1),V,0),FROMOPEN),NODRAW;
资金出入:=资金流入+资金流出,NODRAW;
NN:=2400,NODRAW;
HD:=HHV(资金出入,NN),NODRAW;
LD:=LLV(资金出入,NN),NODRAW;
最高:=CONST(HD),NODRAW;
最低:=CONST(LD),NODRAW;
HLMAX:=最高;
HLMIN:=最低;
HLMN1:=(HLMAX+HLMIN)/2;
HLMN2:=HLMAX-HLMIN;
HLMN3:=(100-0)/2*1.3;
HLMN4:=(100-0)/1*1.3;
中间价轴:=(50-HLMN3)*HLMN2/HLMN4+HLMN1;
轴差:=最高-最低;
DRAWBAND(资金出入,RGB(150,0,150),0,RGB(0,100,0)),NODRAW;
资金流量:资金出入,NODRAW;
资金比:资金出入/SUM(V,FROMOPEN)*100,NODRAW;
资金流量比:=IF(资金比>=0,(资金比+100)/2,100-ABS((资金比-100)/2)),NODRAW;
攻击量:=((HSL*0.50+REF(HSL,1)*0.33)+(REF(HSL,2)*0.17))*SUM(C,FROMOPEN)/FROMOPEN,NODRAW;
攻击量A:=SUM(IF(C>REF(C,1),攻击量*V,0),FROMOPEN),NODRAW;
攻击量B:=-SUM(IF(C<REF(C,1),攻击量*V,0),FROMOPEN),NODRAW;
攻击流量:攻击量A+攻击量B,NODRAW;
NOTEXT攻击线:攻击流量,NODRAW;
攻击比:攻击流量/SUM(V,FROMOPEN)*100,COLORRED,NODRAW;
资金攻击度:=IF(攻击比>=0,(攻击比+50),100-ABS((攻击比-50)));

{STICKLINE(攻击量A>0,攻击量A,0,1,0),COLOR0000FF;
STICKLINE(攻击量B<0,攻击量B,0,1,0),COLORFF0000;}

DRAWRECTREL(110,10,400,90,RGB(0,75,200));
DRAWRECTREL(110,10,250,90,RGB(0,250,50));
DRAWRECTREL(110,10,100+CONST(资金流量比*300/100),90,RGB(200,50,0));
DRAWTEXT_FIX(1,0.000,0.00,0,STRCAT(STRCAT('【资金流量比】',CON2STR(资金流量比,2)),'%买')),COLORYELLOW;
DRAWRECTREL(610,10,900,90,RGB(0,75,200));
DRAWRECTREL(610,10,750,90,RGB(0,250,50));
DRAWRECTREL(610,10,600+CONST(资金攻击度*300/100),90,RGB(175,50,0));
DRAWTEXT_FIX(1,0.500,0.00,0,STRCAT(STRCAT('【资金攻击度】',CON2STR(资金攻击度,2)),' %买')),COLORYELLOW;

H1:=MAX(DYNAINFO(3),DYNAINFO(5));
L1:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1-L1;
阻力:L1+P1*7/8,COLOR00DD00;

现价:CLOSE,COLORWHITE,LINETHICK1;

DRAWTEXT(LONGCROSS(现价,阻力,8),现价,'★S抛'),COLORGREEN;{抛};
{T+1止赢、止损}
止赢:H1,COLORRED,LINETHICK6;
DRAWTEXT(ISLASTBAR,H1,'当日止赢价位'),COLORRED,LINETHICK6;



UR:=10;LR:=10;
均价:SUM(V*C,0)/SUM(V,0),COLORYELLOW;

AAA:=MAX(DYNAINFO(3),DYNAINFO(5));
BBB:=MIN(DYNAINFO(3),DYNAINFO(6));
CCC:=AAA-BBB;
中轨:=(AAA+BBB)/1,POINTDOT;


上顶:BBB+CCC*2/3,POINTDOT;
下底:BBB+CCC/3,COLORBLUE,POINTDOT;
支撑:BBB+CCC*1/8,COLORMAGENTA,POINTDOT;
支撑1:BBB+CCC*0.5/8,POINTDOT;
STICKLINE(C>阻力,阻力,C,2,0),COLORGREEN;
STICKLINE(C<支撑,支撑,C,2,0),COLORLIMAGENTA;
DRAWTEXT(LONGCROSS(支撑1,C,2),下底,'B'),COLORYELLOW;{B}
DRAWTEXT(LONGCROSS(C,阻力,2),上顶,'S'),COLORRED;{S};

{反线}
长周期:EMA(CLOSE,250),NODRAW,COLOR8000FF;
NOTEXTA:IF(长周期>=REF(长周期,1),长周期,DRAWNULL),COLORRED,LINETHICK4,POINTDOT;
NOTEXTB:IF(长周期<REF(长周期,1),长周期,DRAWNULL),COLOR006A6A,LINETHICK4,POINTDOT;
反线:EMA((长周期-(EMA(CLOSE,3)-长周期)),5),LINETHICK2,COLORBLUE;
效果:=CROSS(长周期,反线);
DRAWICON(CROSS(C,反线) AND MA(反线,3)<REF(MA(反线,3),1),反线*0.999,23);{起爆点做标记}
DRAWTEXT(效果,长周期*0.998,'起爆'),COLOR8000FF;



箱顶:HHV(MA((LOW+HIGH+CLOSE+O)/4,5),58),COLORGREEN,LINETHICK1;
箱底:LLV(MA((LOW+HIGH+CLOSE+O)/4,6),88),COLORGREEN ,LINETHICK1;

W1:=C=HHV(C,20);
W2:=BARSLAST(W1);
W3:=IF(W2>0,REF(C,W2),REF(C,W2));
W4:=CROSS(C,REF(W3,1));
突破盘整:=W4 AND COUNT(W4,5)=1;
DRAWICON(突破盘整,L-0.10,9);AHIGHN:=10;ALOWN:=10;AHIGHDISPLAY:=0;ALOWDISPLAY:=0;AZGDISPLAY:=0;AMADISPLAY:=0;

AA:=MAX(DYNAINFO(3),DYNAINFO(5));
CC:=MIN(DYNAINFO(3),DYNAINFO(6));
DD:=AA-CC;
EE:=CC+DD*7/8;
GG:=CC+DD*0.5/8;
DRAWICON(LONGCROSS(GG,CLOSE,2),CLOSE,1);
DRAWICON(LONGCROSS(CLOSE,EE,2),CLOSE,2);
M1:=DYNAINFO(4);
M2:=DYNAINFO(5);
M3:=DYNAINFO(6);
M4:=DYNAINFO(11);
M5:=CLOSE;
M6:=BARSCOUNT(M5);
M7:=SUM(VOL*CLOSE,0)/SUM(VOL,0);
M8:=MA(M5,M6);
M9:=M8+2*STD(M5,3);
M10:=M8-2*STD(M5,3);
DRAWICON(CROSS(M7,M8),M7,38);
M11:=TIME>93000;
M12:=M5/REF(CLOSE,1)>1.02;
M13:=M5/REF(CLOSE,1)<0.98;
M14:=(HHV(M5,M6)-LLV(M5,M6))/M5<0.05;
M15:=SMA(VOL,30,1);
M16:=(M15-LLV(LLV(M15,1),30))/(HHV(HHV(M15,1),30)-LLV(LLV(M15,1),30))>0.95;
M17:=M12 OR M13;
M18:=M17=0 AND M14 AND M16 AND CROSS(M7,M8);
DRAWTEXT(FILTER(M18,10),M7,3),COLORYELLOW;
M19:=M17=0 AND M14 AND M16 AND CROSS(CLOSE,M7) AND CROSS(CLOSE,M8);
DRAWTEXT(FILTER(M19,10),M7*0.99,4),COLORRED;

箱顶2:HHV(MA((LOW+HIGH+CLOSE+O)/4,5),58),COLORYELLOW,LINETHICK1;
暴富的蜗牛
Lv.2
发表于 2020-2-15 20:32 复制 查看全部楼层
JJ:SUM(C*V,FROMOPEN)/SUM(V,FROMOPEN),COLORYELLOW,LINETHICK1.5;  1.5是不行的,只能是整数,可以改成1或者其他小于9的整数
查看全部打赏
  • 福阿德+6理想币 +4共享币 : 赠人玫瑰,手有余香。
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表