手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙编写个选股和预警公式

[通达信]
设置
1470 1 你好9368 Lv.2 发表于 · 2020-2-17 10:15 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请老师帮忙编写一个 分时图幅图 出现 白色柱体   的选股 和 预警公式 谢谢


{摸底}

DR:=100;

ZRQ:=3;

DJ:=REF(LLV(L,100),3);

ZD:=REFDATE(DJ,DATE);

XG:=L=ZD;

STICKLINE(XG,0,80,1,0),COLORWHITE;

{涨停公式}

A1:=((MA(C,60)-L)/MA(C,20))*200;

B1:=((MA(C,60)-L)/MA(C,60))*200;

C1:=((MA(C,30)-L)/MA(C,60))*200;

M1:=REF(CLOSE,1);

M2:=SMA(MAX(CLOSE-M1,0),7,1)/SMA(ABS(CLOSE-M1),7,1)*100;

G1:=FILTER(REF(M2,1)<20 AND M2>REF(M2,1),5);

TU:=C/MA(C,40)<0.74;

PER1:=5;

MMA:=EMA(C,PER1);

SMMA:=EMA(MMA,PER1);

IMPETMMA:=MMA - REF(MMA,1);

IMPETSMMA:=SMMA - REF(SMMA,1);

DIVMA:= ABS(MMA - SMMA);

TDJ:=(H-L)/REF(C,1)>0.05;

AVERIMPET:= (IMPETMMA+IMPETSMMA)/2;

TDF:= POW(DIVMA,1)*POW(AVERIMPET,3);

NTDF:=TDF/HHV(ABS(TDF),PER1*3);

YUL:=COUNT(TDJ,5)>1;

启动:=TU AND TDJ AND YUL;

确定:=CROSS(NTDF,-0.9);

波段:=FILTER((G1 AND C1>20 OR C>REF(C,1)) AND REF(启动,1),10);

选股:=FILTER(REF(启动,1) AND (确定 OR C>REF(C,1)) AND MACD.MACD>-1.5,10);

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-2-17 10:42 复制 查看全部楼层

DR:=100;

ZRQ:=3;

DJ:=REF(LLV(L,100),3);

ZD:=REFDATE(DJ,DATE);

XG:=L=ZD;

SC:XG;

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表