手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助编写个30日均线与13天成本线粘合的选股公式

[通达信]
设置
2054 9 与庄共伍 Lv.4 发表于 · 2020-2-18 21:52 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请老师编写一个30日均线与13天成本线粘合的选股公式,
13天 成本线的源码如下:
F:=COST(70 );
成本13:MA(F,13)COLORMAGENTA ;
                                                          谢谢!

举报

扔鸡蛋(0) 回复

与庄共伍
Lv.4
发表于 2020-2-22 21:32 复制 查看全部楼层
龙喜糖 发表于 2020-2-19 12:36
F:=COST(70 );
成本13:MA(F,13);
b:if(max(ma(c,30),成本13)/min(ma(c,30),成本13)

谢谢老师的指导!

举报

扔鸡蛋(0) 回复

龙喜糖
Lv.4
发表于 2020-2-19 12:36 复制 查看全部楼层
F:=COST(70 );
成本13:MA(F,13);
b:if(max(ma(c,30),成本13)/min(ma(c,30),成本13)<1.05,1,0);

举报

点亮(0) 扔鸡蛋(0) 回复

与庄共伍
Lv.4
发表于 2020-2-19 00:07 复制 查看全部楼层
没想到还有借窝下蛋的!

举报

扔鸡蛋(0) 回复

与庄共伍
Lv.4
发表于 2020-2-19 00:06 复制 查看全部楼层
许昌舍得 发表于 2020-2-18 22:10
N:=5;{自定义 粘合千分数}

谢谢老师的指导,完全正确。

举报

扔鸡蛋(0) 回复

张兴兵
Lv.3
发表于 2020-2-18 22:44 复制 查看全部楼层
许昌舍得 发表于 2020-2-18 22:40
N1:=5;N2:=7;N3:=11;EM1:=EMA(C,N1),COLORWHITE;
EM2:=EMA(C,N2),COLORRED;EM3:=EMA(C,N3),COLORGREEN;
T ...

感谢老师  感谢

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-2-18 22:40 复制 查看全部楼层
N1:=5;N2:=7;N3:=11;EM1:=EMA(C,N1),COLORWHITE;
EM2:=EMA(C,N2),COLORRED;EM3:=EMA(C,N3),COLORGREEN;
TJ:=BETWEEN(EM2,EM1,EM3);
MA20:=MA(C,20)LINETHICK3;

立桩量:=FILTER(TJ=0,5);
价:=REF(H,BARSLAST(立桩量));
XG:CROSS(C,价);

举报

扔鸡蛋(0) 回复

张兴兵
Lv.3
发表于 2020-2-18 22:17 复制 查看全部楼层
AAA:=(3*C+H+L+O)/6;VAR1:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;
VAR2:=(HHV(VAR1,5)+HHV(VAR1,10)+HHV(VAR1,20))/3;
VAR3:=(LLV(VAR1,5)+LLV(VAR1,10)+LLV(VAR1,20))/3;
VAR4:=(HHV(VAR2,5)+HHV(VAR2,10)+HHV(VAR2,20))/3;
VAR5:=(LLV(VAR3,5)+LLV(VAR3,10)+LLV(VAR3,20))/3;
VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;
DRAWBAND(VAR1,RGB(155,50,50),VAR6,RGB(250,250,0));
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
短线:VAR1,COLORWHITE;
中线:VAR6,COLORYELLOW;
下跌:IF(VAR1=VAR6,VAR6,DRAWNULL),COLORGREEN;
N1:=5;N2:=7;N3:=11;EM1:=EMA(C,N1),COLORWHITE;
EM2:=EMA(C,N2),COLORRED;EM3:=EMA(C,N3),COLORGREEN;
TJ:=BETWEEN(EM2,EM1,EM3);
MA20:MA(C,20)LINETHICK3;
IF(MA20>REF(MA20,1),MA20,DRAWNULL)COLORRED,LINETHICK3;
立桩量:=FILTER(TJ=0,5);
价:REF(H,BARSLAST(立桩量)),NODRAW;STICKLINE(C,REF(H,BARSLAST(立桩量)),REF(H,BARSLAST(立桩量)),6,0),COLORGREEN;DRAWTEXT(C AND ISLASTBAR,价,'     突破买入');
出水芙蓉:=(OPEN<EMA(C,20) OR OPEN<EMA(C,40) OR OPEN<EMA(C,60)) AND (C>MAX(EMA(C,20),MAX(EMA(C,40),EMA(C,60))))AND (V/MA(V,30)>1.2 AND C/REF(C,1)>1.049);
DRAWTEXT(出水芙蓉,L-L*0.0005,'出水芙蓉'),COLORYELLOW;
AAA1:=CLOSE>OPEN;
BBB1:=AAA1&&CLOSE>MA(CLOSE,5)&&CLOSE>MA(CLOSE,10)&&CLOSE>MA(CLOSE,20);
CCC1:=BBB1&&OPEN<MA(CLOSE,10)&&OPEN<MA(CLOSE,20);
出水芙蓉2:=CCC1&&(CLOSE-OPEN)>0.0618*CLOSE;DRAWTEXT(出水芙蓉2,H,'出水芙蓉2'),COLORLIMAGENTA;
STICKLINE(出水芙蓉,C,O,2,0),COLORYELLOW;
DRAWICON(CROSS(C,价),H,1);
ZT:=C>REF(C,1)*1.09 AND C<REF(C,1)*1.102;
DT:=C<REF(C,1)*0.901 AND C>REF(C,1)*0.898;
STICKLINE(ZT,C,O,4,0),COLORRED;
STICKLINE(DT,C,O,4,0),COLORBLUE;
DRAWTEXT(ZT,L-0.1,'涨停'),COLORRED;
DRAWTEXT(DT,H+0.3,'跌停'),COLORBLUE;
XJ:C,LINETHICK0;

请老师把突破买入做一个预警公式   谢谢

举报

点亮(1) 扔鸡蛋(0) 回复

张兴兵
Lv.3
发表于 2020-2-18 22:15 复制 查看全部楼层
许昌舍得 发表于 2020-2-18 22:10
N:=5;{自定义 粘合千分数}

老师 怎么编写一进二选股公式?

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-2-18 22:10 复制 查看全部楼层
本帖最后由 许昌舍得 于 2020-2-18 22:12 编辑


N:=5;{自定义 粘合千分数}


F:=COST(70 );
成本13:=MA(F,13);
MA30:=MA(C,30);

TJ:ABS((成本13/MA30-1)*100)<N/1000;

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表