手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助编写个蓝三角条件成立时的选股公式

[通达信]
设置
2755 3 雪山响松 Lv.3 发表于 · 2020-2-19 00:37 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
SJ1:=(REF(HIGH,3) = HHV(HIGH,((2 * 3) + 1)));
SJ2:=FILTER(SJ1,3);
SJ3:=BACKSET(SJ2,(3 + 1));
SJ4:=FILTER(SJ3,3);
SJ5:=(REF(LOW,3) = LLV(LOW,((2 * 3) + 1)));
SJ6:=FILTER(SJ5,3);
SJ7:=BACKSET(SJ6,(3 + 1));
SJ8:=FILTER(SJ7,3);
SJ9:=((REF(LLV(LOW,(2 * 3)),1) + REF(HHV(HIGH,(2 * 3)),1)) / 2);
SJ10:=((HIGH + LOW) / 2);
SJ11:=(((SJ4 AND NOT((SJ8 AND (SJ9 >= SJ10)))) OR BARSTATUS) OR (BARSCOUNT(CLOSE) = 1));
SJ12:=(SJ8 AND NOT((SJ4 AND (SJ9 < SJ10))));
SJ13:=(SJ4 AND NOT((SJ8 AND (SJ9 >= SJ10))));
SJ14:=(REF(BARSLAST(SJ11),1) + 1);
SJ15:=BACKSET((SJ11 AND (COUNT(SJ12,SJ14) > 0)),LLVBARS(IF(SJ12,LOW,10000),SJ14));
SJ16:=(SJ15 > REF(SJ15,1));{WWW.GOODGUPIAO.COM}
SJ17:=BACKSET(SJ16,2);
SJ18:=(SJ17 > REF(SJ17,1));
SJ19:=((SJ18 OR BARSTATUS) OR (BARSCOUNT(CLOSE) = 1));
SJ20:=(REF(BARSLAST(SJ19),1) + 1);
SJ21:=BACKSET((SJ19 AND (COUNT(SJ13,SJ20) > 0)),HHVBARS(IF(SJ13,HIGH,0),SJ20));
SJ22:=(SJ21 > REF(SJ21,1));
SJ23:=BACKSET(SJ22,2);
SJ24:=(SJ23 > REF(SJ23,1));
SJ25:=BACKSET(BARSTATUS,(BARSLAST(SJ18) + 1));
SJ26:=(SJ25 > REF(SJ25,1));
SJ27:=BACKSET(BARSTATUS,(BARSLAST(SJ24) + 1));
SJ28:=(SJ27 > REF(SJ27,1));
底:=REF(LOW,BARSLAST(SJ26));
頂:=REF(HIGH,BARSLAST(SJ28));
STICKLINE(SJ26,頂,底,0,0),COLORBLUE,LINETHICK2;
DRAWLINE(SJ28,HIGH,SJ26,LOW,0),COLORBLUE,LINETHICK2;
DRAWLINE(SJ28,HIGH,SJ26,頂,1),COLORBLUE,LINETHICK2;
STICKLINE(SJ28,頂,底,0,0),COLORRED,LINETHICK2;
DRAWLINE(SJ26,LOW,SJ28,HIGH,0),COLORRED,LINETHICK2;
DRAWLINE(SJ26,LOW,SJ28,底,0),COLORRED,LINETHICK2;
糡三角画完出局:DRAWTEXT((BARSCOUNT(CLOSE)=BARSTATUS=2),HIGH,' 糡色三角形画完出局'),COLOR0000FF;
蓝三角:DRAWTEXT((BARSCOUNT(CLOSE)=BARSTATUS=2),HIGH,' 藍色三角形画完介入'),COLORBLUE;

DRAWTEXT(CROSS(MA(C,20)*1.005,MA(C,5)) AND MA(C,5)>=MA(C,20),L,'不破则入,破了观察'),COLORMAGENTA;
本主题由 任务系统 于 2020-2-19 00:39 审核通过

举报

扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-2-20 09:19 复制 查看全部楼层
雪山响松 发表于 2020-2-19 12:54
这今天找到得都是新股,我要突破蓝上线的股票,谢谢!

上穿蓝水平线
SJ1:=(REF(HIGH,3) = HHV(HIGH,((2 * 3) + 1)));
SJ2:=FILTER(SJ1,3);
SJ3:=BACKSET(SJ2,(3 + 1));
SJ4:=FILTER(SJ3,3);
SJ5:=(REF(LOW,3) = LLV(LOW,((2 * 3) + 1)));
SJ6:=FILTER(SJ5,3);
SJ7:=BACKSET(SJ6,(3 + 1));
SJ8:=FILTER(SJ7,3);
SJ9:=((REF(LLV(LOW,(2 * 3)),1) + REF(HHV(HIGH,(2 * 3)),1)) / 2);
SJ10:=((HIGH + LOW) / 2);
SJ11:=(((SJ4 AND NOT((SJ8 AND (SJ9 >= SJ10)))) OR BARSTATUS) OR (BARSCOUNT(CLOSE) = 1));
SJ12:=(SJ8 AND NOT((SJ4 AND (SJ9 < SJ10))));
SJ13:=(SJ4 AND NOT((SJ8 AND (SJ9 >= SJ10))));
SJ14:=(REF(BARSLAST(SJ11),1) + 1);
SJ15:=BACKSET((SJ11 AND (COUNT(SJ12,SJ14) > 0)),LLVBARS(IF(SJ12,LOW,10000),SJ14));
SJ16:=(SJ15 > REF(SJ15,1));{WWW.GOODGUPIAO.COM}
SJ17:=BACKSET(SJ16,2);
SJ18:=(SJ17 > REF(SJ17,1));
SJ19:=((SJ18 OR BARSTATUS) OR (BARSCOUNT(CLOSE) = 1));
SJ20:=(REF(BARSLAST(SJ19),1) + 1);
SJ21:=BACKSET((SJ19 AND (COUNT(SJ13,SJ20) > 0)),HHVBARS(IF(SJ13,HIGH,0),SJ20));
SJ22:=(SJ21 > REF(SJ21,1));
SJ23:=BACKSET(SJ22,2);
SJ24:=(SJ23 > REF(SJ23,1));
SJ25:=BACKSET(BARSTATUS,(BARSLAST(SJ18) + 1));
SJ26:=(SJ25 > REF(SJ25,1));
SJ27:=BACKSET(BARSTATUS,(BARSLAST(SJ24) + 1));
SJ28:=(SJ27 > REF(SJ27,1));
底:=REF(LOW,BARSLAST(SJ26));
頂:=REF(HIGH,BARSLAST(SJ28));
X:=DRAWLINE(SJ28,HIGH,SJ26,頂,1);
CROSS(C,X);

举报

点亮(0) 扔鸡蛋(0) 回复

雪山响松
Lv.3
发表于 2020-2-19 12:54 复制 查看全部楼层
休闲者68 发表于 2020-2-19 08:27
{指标很有未来函数BACKSET,慎用!}
SJ1:=(REF(HIGH,3)=HHV(HIGH,((2*3)+1)));
SJ2:=FILTER(SJ1,3);

这今天找到得都是新股,我要突破蓝上线的股票,谢谢!

举报

点亮(0) 扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-2-19 08:27 复制 查看全部楼层
{指标很有未来函数BACKSET,慎用!}
SJ1:=(REF(HIGH,3)=HHV(HIGH,((2*3)+1)));
SJ2:=FILTER(SJ1,3);
SJ3:=BACKSET(SJ2,(3+1));
SJ4:=FILTER(SJ3,3);
SJ5:=(REF(LOW,3)=LLV(LOW,((2*3)+1)));
SJ6:=FILTER(SJ5,3);
SJ7:=BACKSET(SJ6,(3+1));
SJ8:=FILTER(SJ7,3);
SJ9:=((REF(LLV(LOW,(2*3)),1)+REF(HHV(HIGH,(2*3)),1))/2);
SJ10:=((HIGH+LOW)/2);
SJ11:=(((SJ4 AND NOT((SJ8 AND (SJ9>=SJ10)))) OR BARSTATUS) OR (BARSCOUNT(CLOSE)=1));
SJ12:=(SJ8 AND NOT((SJ4 AND (SJ9<SJ10))));
SJ13:=(SJ4 AND NOT((SJ8 AND (SJ9>=SJ10))));
SJ14:=(REF(BARSLAST(SJ11),1)+1);
SJ15:=BACKSET((SJ11 AND (COUNT(SJ12,SJ14)>0)),LLVBARS(IF(SJ12,LOW,10000),SJ14));
SJ16:=(SJ15>REF(SJ15,1));
SJ17:=BACKSET(SJ16,2);
SJ18:=(SJ17>REF(SJ17,1));
SJ19:=((SJ18 OR BARSTATUS) OR (BARSCOUNT(CLOSE)=1));
SJ20:=(REF(BARSLAST(SJ19),1) + 1);
SJ21:=BACKSET((SJ19 AND (COUNT(SJ13,SJ20)>0)),HHVBARS(IF(SJ13,HIGH,0),SJ20));
SJ22:=(SJ21>REF(SJ21,1));
SJ23:=BACKSET(SJ22,2);
SJ24:=(SJ23>REF(SJ23,1));
SJ25:=BACKSET(BARSTATUS,(BARSLAST(SJ18)+1));
ZT:=C>REF(C,1)*1.095 AND C=H;
T:=BARSCOUNT(V>O);
A:=BARSLASTCOUNT(ZT);
蓝三角:(SJ25>REF(SJ25,1)) AND NOT(A=T);
查看全部打赏
  • 雪山响松+10理想币 : 很给力,理想因你而精彩;

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表