手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙修改一下通达信的副图指标,显示有压缩的问题

[通达信]
设置
9517 12 木子9857 Lv.4 发表于 · 2020-3-6 10:01 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
在显示个股时,有的出现压缩情况,看不全了。哪位老师能够帮助修改一下,万分感谢!






股价趋势:=((3 * SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1)) - (2 *
SMA(SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1),3,1)));
底部警戒:=10;
买入警戒:STICKLINE((股价趋势 <= 10),0,20,2,0),LINETHICK2,COLORYELLOW;
买入信号:=STICKLINE(CROSS(股价趋势,底部警戒),0,30,3,0),COLORWHITE;
顶部警戒:=90;
卖出警戒:STICKLINE((股价趋势 >= 85),100,80,2,0),LINETHICK2,COLOR66FF00;
止损出局:STICKLINE(CROSS(顶部警戒,股价趋势),130,90,3,0),LINETHICK5,COLORFF3300;
QQQ:=CROSS(顶部警戒,股价趋势);
{DRAWICON(QQQ,70,19);
DRAWTEXT(QQQ,130,'*止损');}
多方趋势线:(((7 * SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 30),4,1))
- (3 * SMA(SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 30),4,1),3,1)))
- SMA(SMA(SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 30),4,1),3,1),2,1)),COLOR8811FF,LINETHICK2;
主升线:=14;
天线:=78.89;
抄底:=CROSS(多方趋势线,主升线);
逃顶:=CROSS(天线,多方趋势线);
DRAWICON(抄底,多方趋势线,5);
DRAWICON(逃顶,110,6);
VARX:=((3 * SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1))
- (2 * SMA(SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1),3,1)));
股价启动在即:=IF(CROSS(VARX,3),100,0);
捕食秘密买点:=IF((VARX <= 3),25,0);
建增补仓:IF((VARX < 5),100,0),COLORRED;
VAR2D1:=REF(CLOSE,1);
VAR2D2:=((SMA(MAX((CLOSE - VAR2D1),0),6,1) / SMA(ABS((CLOSE - VAR2D1)),6,1)) * 100);
短期顶部:(CROSS(80,VAR2D2) * 80),COLORWHITE;
DRAWTEXT(CROSS(80,VAR2D2),60,'★见顶 '),COLORWHITE;
VAR31:=((SMA(MAX((CLOSE - VAR2D1),0),7,1) / SMA(ABS((CLOSE - VAR2D1)),7,1)) * 100);
VAR41:=((SMA(MAX((CLOSE - VAR2D1),0),13,1) / SMA(ABS((CLOSE - VAR2D1)),13,1)) * 100);
VAR51:=BARSCOUNT(CLOSE);
短期底部:=(((VAR31 < 20) AND (VAR41 < 25)) AND (VAR51 > (50 * 300)));
DRAWTEXT(CROSS(100,短期底部),40,'☆短底 '),COLORBROWN;
VAR441:=((LLV(LOW,5) = LLV(LOW,45)) AND (CLOSE >= (OPEN * 1.04)));
VAR442:=(CLOSE > ((REF(HIGH,1) + REF(LOW,1)) / 2));
红灯:=(VAR441 AND VAR442);
VAR33:=REF(CLOSE,1);
VAR43:=((SMA(MAX((CLOSE - VAR33),0),6,1) / SMA(ABS((CLOSE - VAR33)),6,1)) * 100);
绿灯:=CROSS(80,VAR43);
VAR2D:=REF(LOW,1);
VAR3D:=((SMA(ABS((LOW - VAR2D)),3,1) / SMA(MAX((LOW - VAR2D),0),3,1)) * 100);
VAR4D:=EMA(IF((CLOSE * 1.2),(VAR3D * 10),(VAR3D / 10)),3);
VAR5D:=LLV(LOW,38);
VAR6D:=HHV(VAR4D,38);
VAR7D:=IF(LLV(LOW,90),1,0);
VAR8D:=((EMA(IF((LOW <= VAR5D),((VAR4D + (VAR6D * 2)) / 2),0),3) / 618) * VAR7D);
秘密吸筹:STICKLINE(VAR8D,0,VAR8D,6,1),COLORFFFF66;
XL1:=(MA(LOW,2) * 0.96);
XL2:=(MA(LOW,26) * 0.85);
XL3:=(((REF(XL1,1) < XL2) AND (REF(XL1,1) < XL1)) AND (REF(XL1,1) < REF(XL1,2)));
STICKLINE(XL3,0,(VAR8D * 2),6,0),COLORFF00CC;
{DRAWTEXT(XL3,(VAR8D * 2),'短线出击'),COLORRED;}
↑短线突击:DRAWICON(XL3,40,25),COLORFF99CC;
DRAWICON(红灯,1.1,9);
DRAWICON(绿灯,30,15);






本主题由 任务系统 于 2020-3-6 10:05 审核通过

举报

扔鸡蛋(0) 回复

浏览蒲公英
Lv.3
发表于 2020-3-6 17:13 复制 查看全部楼层
可以把以下部分剪接出来重新做个公式就能简单解决了:VAR2D:=REF(LOW,1);
VAR3D:=((SMA(ABS((LOW - VAR2D)),3,1) / SMA(MAX((LOW - VAR2D),0),3,1)) * 100);
VAR4D:=EMA(IF((CLOSE * 1.2),(VAR3D * 10),(VAR3D / 10)),3);
VAR5D:=LLV(LOW,38);
VAR6D:=HHV(VAR4D,38);
VAR7D:=IF(LLV(LOW,90),1,0);
VAR8D:=((EMA(IF((LOW <= VAR5D),((VAR4D + (VAR6D * 2)) / 2),0),3) / 618) * VAR7D);
秘密吸筹:STICKLINE(VAR8D,0,VAR8D,6,1),COLORFFFF66;
XL1:=(MA(LOW,2) * 0.96);
XL2:=(MA(LOW,26) * 0.85);
XL3:=(((REF(XL1,1) < XL2) AND (REF(XL1,1) < XL1)) AND (REF(XL1,1) < REF(XL1,2)));
STICKLINE(XL3,0,(VAR8D * 2),6,0),COLORFF00CC;
{DRAWTEXT(XL3,(VAR8D * 2),'短线出击'),COLORRED;}
↑短线突击:DRAWICON(XL3,40,25),COLORFF99CC;

举报

扔鸡蛋(0) 回复

浏览蒲公英
Lv.3
发表于 2020-3-6 17:11 复制 查看全部楼层
本帖最后由 浏览蒲公英 于 2020-3-6 17:16 编辑

可以把以下剪接出来做另外一个公式,就能解决了:VAR2D:=REF(LOW,1); VAR3D:=((SMA(ABS((LOW - VAR2D)),3,1) / SMA(MAX((LOW - VAR2D),0),3,1)) * 100); VAR4D:=EMA(IF((CLOSE * 1.2),(VAR3D * 10),(VAR3D / 10)),3); VAR5D:=LLV(LOW,38); VAR6D:=HHV(VAR4D,38); VAR7D:=IF(LLV(LOW,90),1,0); VAR8D:=((EMA(IF((LOW <= VAR5D),((VAR4D + (VAR6D * 2)) / 2),0),3) / 618) * VAR7D); 秘密吸筹:STICKLINE(VAR8D,0,VAR8D,6,1)*0.1,COLORFFFF66; XL1:=(MA(LOW,2) * 0.96); XL2:=(MA(LOW,26) * 0.85); XL3:=(((REF(XL1,1) < XL2) AND (REF(XL1,1) < XL1)) AND (REF(XL1,1) < REF(XL1,2))); STICKLINE(XL3,0,(VAR8D * 2),6,0),COLORFF00CC; {DRAWTEXT(XL3,(VAR8D * 2),'短线出击'),COLORRED;} ↑短线突击:DRAWICON(XL3,40,25),COLORFF99CC;

举报

扔鸡蛋(0) 回复

北沙
Lv.7
发表于 2020-3-6 12:02 复制 查看全部楼层
木子9857 发表于 2020-3-6 11:40
我是一个主图 三个附图。有的显示正常有的就出现压缩情况,应该比原来好很多了。谢谢老师!

柱子太长,所以压缩,改成了1/3。

举报

扔鸡蛋(0) 回复

木子9857
Lv.4
发表于 2020-3-6 11:40 复制 查看全部楼层
我是一个主图 三个附图。有的显示正常有的就出现压缩情况,应该比原来好很多了。谢谢老师!

举报

点亮(0) 扔鸡蛋(0) 回复

北沙
Lv.7
发表于 2020-3-6 11:30 复制 查看全部楼层
木子9857 发表于 2020-3-6 11:23
不管行不行,还是非常感谢北沙老师,辛苦了!

股价趋势:=((3 * SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1)) - (2 *
SMA(SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1),3,1)));
底部警戒:=10;
买入警戒:STICKLINE((股价趋势 <= 10),0,20,2,0),LINETHICK2,COLORYELLOW;
买入信号:=STICKLINE(CROSS(股价趋势,底部警戒),0,30,3,0),COLORWHITE;
顶部警戒:=90;
卖出警戒:STICKLINE((股价趋势 >= 85),100,80,2,0),LINETHICK2,COLOR66FF00;
止损出局:STICKLINE(CROSS(顶部警戒,股价趋势),130,90,3,0),LINETHICK5,COLORFF3300;
QQQ:=CROSS(顶部警戒,股价趋势);
{DRAWICON(QQQ,70,19);
DRAWTEXT(QQQ,130,'*止损');}
多方趋势线:(((7 * SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 30),4,1))
- (3 * SMA(SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 30),4,1),3,1)))
- SMA(SMA(SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 30),4,1),3,1),2,1)),COLOR8811FF,LINETHICK2;
主升线:=14;
天线:=78.89;
抄底:=CROSS(多方趋势线,主升线);
逃顶:=CROSS(天线,多方趋势线);
DRAWICON(抄底,多方趋势线,5);
DRAWICON(逃顶,110,6);
VARX:=((3 * SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1))
- (2 * SMA(SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1),3,1)));
股价启动在即:=IF(CROSS(VARX,3),100,0);
捕食秘密买点:=IF((VARX <= 3),25,0);
建增补仓:IF((VARX < 5),100,0),COLORRED;
VAR2D1:=REF(CLOSE,1);
VAR2D2:=((SMA(MAX((CLOSE - VAR2D1),0),6,1) / SMA(ABS((CLOSE - VAR2D1)),6,1)) * 100);
短期顶部:(CROSS(80,VAR2D2) * 80),COLORWHITE;
DRAWTEXT(CROSS(80,VAR2D2),60,'★见顶 '),COLORWHITE;
VAR31:=((SMA(MAX((CLOSE - VAR2D1),0),7,1) / SMA(ABS((CLOSE - VAR2D1)),7,1)) * 100);
VAR41:=((SMA(MAX((CLOSE - VAR2D1),0),13,1) / SMA(ABS((CLOSE - VAR2D1)),13,1)) * 100);
VAR51:=BARSCOUNT(CLOSE);
短期底部:=(((VAR31 < 20) AND (VAR41 < 25)) AND (VAR51 > (50 * 300)));
DRAWTEXT(CROSS(100,短期底部),40,'☆短底 '),COLORBROWN;
VAR441:=((LLV(LOW,5) = LLV(LOW,45)) AND (CLOSE >= (OPEN * 1.04)));
VAR442:=(CLOSE > ((REF(HIGH,1) + REF(LOW,1)) / 2));
红灯:=(VAR441 AND VAR442);
VAR33:=REF(CLOSE,1);
VAR43:=((SMA(MAX((CLOSE - VAR33),0),6,1) / SMA(ABS((CLOSE - VAR33)),6,1)) * 100);
绿灯:=CROSS(80,VAR43);
VAR2D:=REF(LOW,1);
VAR3D:=((SMA(ABS((LOW - VAR2D)),3,1) / SMA(MAX((LOW - VAR2D),0),3,1)) * 100);
VAR4D:=EMA(IF((CLOSE * 1.2),(VAR3D * 10),(VAR3D / 10)),3);
VAR5D:=LLV(LOW,38);
VAR6D:=HHV(VAR4D,38);
VAR7D:=IF(LLV(LOW,90),1,0);
VAR8D:=((EMA(IF((LOW <= VAR5D),((VAR4D + (VAR6D * 2)) / 2),0),3) / 618) * VAR7D);
秘密吸筹:STICKLINE(VAR8D,0,VAR8D/3,6,1),COLORFFFF66;
XL1:=(MA(LOW,2) * 0.96);
XL2:=(MA(LOW,26) * 0.85);
XL3:=(((REF(XL1,1) < XL2) AND (REF(XL1,1) < XL1)) AND (REF(XL1,1) < REF(XL1,2)));
STICKLINE(XL3,0,VAR8D/3,6,0),COLORFF00CC;
{DRAWTEXT(XL3,(VAR8D * 2),'短线出击'),COLORRED;}
↑短线突击:DRAWICON(XL3,40,25),COLORFF99CC;
DRAWICON(红灯,1.1,9);
DRAWICON(绿灯,30,15);


举报

点亮(0) 扔鸡蛋(0) 回复

北沙
Lv.7
发表于 2020-3-6 11:28 复制 查看全部楼层
木子9857 发表于 2020-3-6 11:23
不管行不行,还是非常感谢北沙老师,辛苦了!

股价趋势:=((3 * SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1)) - (2 *
SMA(SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1),3,1)));
底部警戒:=10;
买入警戒:STICKLINE((股价趋势 <= 10),0,20,2,0),LINETHICK2,COLORYELLOW;
买入信号:=STICKLINE(CROSS(股价趋势,底部警戒),0,30,3,0),COLORWHITE;
顶部警戒:=90;
卖出警戒:STICKLINE((股价趋势 >= 85),100,80,2,0),LINETHICK2,COLOR66FF00;
止损出局:STICKLINE(CROSS(顶部警戒,股价趋势),130,90,3,0),LINETHICK5,COLORFF3300;
QQQ:=CROSS(顶部警戒,股价趋势);
{DRAWICON(QQQ,70,19);
DRAWTEXT(QQQ,130,'*止损');}
多方趋势线:(((7 * SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 30),4,1))
- (3 * SMA(SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 30),4,1),3,1)))
- SMA(SMA(SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 30),4,1),3,1),2,1)),COLOR8811FF,LINETHICK2;
主升线:=14;
天线:=78.89;
抄底:=CROSS(多方趋势线,主升线);
逃顶:=CROSS(天线,多方趋势线);
DRAWICON(抄底,多方趋势线,5);
DRAWICON(逃顶,110,6);
VARX:=((3 * SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1))
- (2 * SMA(SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1),3,1)));
股价启动在即:=IF(CROSS(VARX,3),100,0);
捕食秘密买点:=IF((VARX <= 3),25,0);
建增补仓:IF((VARX < 5),100,0),COLORRED;
VAR2D1:=REF(CLOSE,1);
VAR2D2:=((SMA(MAX((CLOSE - VAR2D1),0),6,1) / SMA(ABS((CLOSE - VAR2D1)),6,1)) * 100);
短期顶部:(CROSS(80,VAR2D2) * 80),COLORWHITE;
DRAWTEXT(CROSS(80,VAR2D2),60,'★见顶 '),COLORWHITE;
VAR31:=((SMA(MAX((CLOSE - VAR2D1),0),7,1) / SMA(ABS((CLOSE - VAR2D1)),7,1)) * 100);
VAR41:=((SMA(MAX((CLOSE - VAR2D1),0),13,1) / SMA(ABS((CLOSE - VAR2D1)),13,1)) * 100);
VAR51:=BARSCOUNT(CLOSE);
短期底部:=(((VAR31 < 20) AND (VAR41 < 25)) AND (VAR51 > (50 * 300)));
DRAWTEXT(CROSS(100,短期底部),40,'☆短底 '),COLORBROWN;
VAR441:=((LLV(LOW,5) = LLV(LOW,45)) AND (CLOSE >= (OPEN * 1.04)));
VAR442:=(CLOSE > ((REF(HIGH,1) + REF(LOW,1)) / 2));
红灯:=(VAR441 AND VAR442);
VAR33:=REF(CLOSE,1);
VAR43:=((SMA(MAX((CLOSE - VAR33),0),6,1) / SMA(ABS((CLOSE - VAR33)),6,1)) * 100);
绿灯:=CROSS(80,VAR43);
VAR2D:=REF(LOW,1);
VAR3D:=((SMA(ABS((LOW - VAR2D)),3,1) / SMA(MAX((LOW - VAR2D),0),3,1)) * 100);
VAR4D:=EMA(IF((CLOSE * 1.2),(VAR3D * 10),(VAR3D / 10)),3);
VAR5D:=LLV(LOW,38);
VAR6D:=HHV(VAR4D,38);
VAR7D:=IF(LLV(LOW,90),1,0);
VAR8D:=((EMA(IF((LOW <= VAR5D),((VAR4D + (VAR6D * 2)) / 2),0),3) / 618) * VAR7D);
秘密吸筹:STICKLINE(VAR8D,0,VAR8D/3,6,1),COLORFFFF66;
XL1:=(MA(LOW,2) * 0.96);
XL2:=(MA(LOW,26) * 0.85);
XL3:=(((REF(XL1,1) < XL2) AND (REF(XL1,1) < XL1)) AND (REF(XL1,1) < REF(XL1,2)));
STICKLINE(XL3,0,VAR8D/3,6,0),COLORFF00CC;
{DRAWTEXT(XL3,(VAR8D * 2),'短线出击'),COLORRED;}
↑短线突击:DRAWICON(XL3,40,25),COLORFF99CC;
DRAWICON(红灯,1.1,9);
DRAWICON(绿灯,30,15);


举报

点亮(0) 扔鸡蛋(0) 回复

木子9857
Lv.4
发表于 2020-3-6 11:23 复制 查看全部楼层
不管行不行,还是非常感谢北沙老师,辛苦了!

举报

点亮(0) 扔鸡蛋(0) 回复

木子9857
Lv.4
发表于 2020-3-6 11:21 复制 查看全部楼层
搞不懂为何有的显示正常,有的就不行了呢?

附件

360截图16310331155750.jpg

举报

扔鸡蛋(0) 回复

木子9857
Lv.4
发表于 2020-3-6 11:18 复制 查看全部楼层
非常感谢北沙老师,我试了一下有的还是有压缩,不知道是哪里的问题。

举报

点亮(0) 扔鸡蛋(0) 回复

北沙
Lv.7
发表于 2020-3-6 11:06 复制 查看全部楼层
股价趋势:=((3 * SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1)) - (2 *
SMA(SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1),3,1)));
底部警戒:=10;
买入警戒:STICKLINE((股价趋势 <= 10),0,20,2,0),LINETHICK2,COLORYELLOW;
买入信号:=STICKLINE(CROSS(股价趋势,底部警戒),0,30,3,0),COLORWHITE;
顶部警戒:=90;
卖出警戒:STICKLINE((股价趋势 >= 85),100,80,2,0),LINETHICK2,COLOR66FF00;
止损出局:STICKLINE(CROSS(顶部警戒,股价趋势),130,90,3,0),LINETHICK5,COLORFF3300;
QQQ:=CROSS(顶部警戒,股价趋势);
{DRAWICON(QQQ,70,19);
DRAWTEXT(QQQ,130,'*止损');}
多方趋势线:(((7 * SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 30),4,1))
- (3 * SMA(SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 30),4,1),3,1)))
- SMA(SMA(SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 30),4,1),3,1),2,1)),COLOR8811FF,LINETHICK2;
主升线:=14;
天线:=78.89;
抄底:=CROSS(多方趋势线,主升线);
逃顶:=CROSS(天线,多方趋势线);
DRAWICON(抄底,多方趋势线,5);
DRAWICON(逃顶,110,6);
VARX:=((3 * SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1))
- (2 * SMA(SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1),3,1)));
股价启动在即:=IF(CROSS(VARX,3),100,0);
捕食秘密买点:=IF((VARX <= 3),25,0);
建增补仓:IF((VARX < 5),100,0),COLORRED;
VAR2D1:=REF(CLOSE,1);
VAR2D2:=((SMA(MAX((CLOSE - VAR2D1),0),6,1) / SMA(ABS((CLOSE - VAR2D1)),6,1)) * 100);
短期顶部:(CROSS(80,VAR2D2) * 80),COLORWHITE;
DRAWTEXT(CROSS(80,VAR2D2),60,'★见顶 '),COLORWHITE;
VAR31:=((SMA(MAX((CLOSE - VAR2D1),0),7,1) / SMA(ABS((CLOSE - VAR2D1)),7,1)) * 100);
VAR41:=((SMA(MAX((CLOSE - VAR2D1),0),13,1) / SMA(ABS((CLOSE - VAR2D1)),13,1)) * 100);
VAR51:=BARSCOUNT(CLOSE);
短期底部:=(((VAR31 < 20) AND (VAR41 < 25)) AND (VAR51 > (50 * 300)));
DRAWTEXT(CROSS(100,短期底部),40,'☆短底 '),COLORBROWN;
VAR441:=((LLV(LOW,5) = LLV(LOW,45)) AND (CLOSE >= (OPEN * 1.04)));
VAR442:=(CLOSE > ((REF(HIGH,1) + REF(LOW,1)) / 2));
红灯:=(VAR441 AND VAR442);
VAR33:=REF(CLOSE,1);
VAR43:=((SMA(MAX((CLOSE - VAR33),0),6,1) / SMA(ABS((CLOSE - VAR33)),6,1)) * 100);
绿灯:=CROSS(80,VAR43);
VAR2D:=REF(LOW,1);
VAR3D:=((SMA(ABS((LOW - VAR2D)),3,1) / SMA(MAX((LOW - VAR2D),0),3,1)) * 100);
VAR4D:=EMA(IF((CLOSE * 1.2),(VAR3D * 10),(VAR3D / 10)),3);
VAR5D:=LLV(LOW,38);
VAR6D:=HHV(VAR4D,38);
VAR7D:=IF(LLV(LOW,90),1,0);
VAR8D:=((EMA(IF((LOW <= VAR5D),((VAR4D + (VAR6D * 2)) / 2),0),3) / 618) * VAR7D);
秘密吸筹:STICKLINE(VAR8D,0,VAR8D,6,1),COLORFFFF66;
XL1:=(MA(LOW,2) * 0.96);
XL2:=(MA(LOW,26) * 0.85);
XL3:=(((REF(XL1,1) < XL2) AND (REF(XL1,1) < XL1)) AND (REF(XL1,1) < REF(XL1,2)));
STICKLINE(XL3,0,VAR8D,6,0),COLORFF00CC;
{DRAWTEXT(XL3,(VAR8D * 2),'短线出击'),COLORRED;}
↑短线突击:DRAWICON(XL3,40,25),COLORFF99CC;
DRAWICON(红灯,1.1,9);
DRAWICON(绿灯,30,15);

举报

扔鸡蛋(0) 回复

北沙
Lv.7
发表于 2020-3-6 11:06 复制 查看全部楼层
股价趋势:=((3 * SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1)) - (2 *
SMA(SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1),3,1)));
底部警戒:=10;
买入警戒:STICKLINE((股价趋势 <= 10),0,20,2,0),LINETHICK2,COLORYELLOW;
买入信号:=STICKLINE(CROSS(股价趋势,底部警戒),0,30,3,0),COLORWHITE;
顶部警戒:=90;
卖出警戒:STICKLINE((股价趋势 >= 85),100,80,2,0),LINETHICK2,COLOR66FF00;
止损出局:STICKLINE(CROSS(顶部警戒,股价趋势),130,90,3,0),LINETHICK5,COLORFF3300;
QQQ:=CROSS(顶部警戒,股价趋势);
{DRAWICON(QQQ,70,19);
DRAWTEXT(QQQ,130,'*止损');}
多方趋势线:(((7 * SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 30),4,1))
- (3 * SMA(SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 30),4,1),3,1)))
- SMA(SMA(SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 30),4,1),3,1),2,1)),COLOR8811FF,LINETHICK2;
主升线:=14;
天线:=78.89;
抄底:=CROSS(多方趋势线,主升线);
逃顶:=CROSS(天线,多方趋势线);
DRAWICON(抄底,多方趋势线,5);
DRAWICON(逃顶,110,6);
VARX:=((3 * SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1))
- (2 * SMA(SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1),3,1)));
股价启动在即:=IF(CROSS(VARX,3),100,0);
捕食秘密买点:=IF((VARX <= 3),25,0);
建增补仓:IF((VARX < 5),100,0),COLORRED;
VAR2D1:=REF(CLOSE,1);
VAR2D2:=((SMA(MAX((CLOSE - VAR2D1),0),6,1) / SMA(ABS((CLOSE - VAR2D1)),6,1)) * 100);
短期顶部:(CROSS(80,VAR2D2) * 80),COLORWHITE;
DRAWTEXT(CROSS(80,VAR2D2),60,'★见顶 '),COLORWHITE;
VAR31:=((SMA(MAX((CLOSE - VAR2D1),0),7,1) / SMA(ABS((CLOSE - VAR2D1)),7,1)) * 100);
VAR41:=((SMA(MAX((CLOSE - VAR2D1),0),13,1) / SMA(ABS((CLOSE - VAR2D1)),13,1)) * 100);
VAR51:=BARSCOUNT(CLOSE);
短期底部:=(((VAR31 < 20) AND (VAR41 < 25)) AND (VAR51 > (50 * 300)));
DRAWTEXT(CROSS(100,短期底部),40,'☆短底 '),COLORBROWN;
VAR441:=((LLV(LOW,5) = LLV(LOW,45)) AND (CLOSE >= (OPEN * 1.04)));
VAR442:=(CLOSE > ((REF(HIGH,1) + REF(LOW,1)) / 2));
红灯:=(VAR441 AND VAR442);
VAR33:=REF(CLOSE,1);
VAR43:=((SMA(MAX((CLOSE - VAR33),0),6,1) / SMA(ABS((CLOSE - VAR33)),6,1)) * 100);
绿灯:=CROSS(80,VAR43);
VAR2D:=REF(LOW,1);
VAR3D:=((SMA(ABS((LOW - VAR2D)),3,1) / SMA(MAX((LOW - VAR2D),0),3,1)) * 100);
VAR4D:=EMA(IF((CLOSE * 1.2),(VAR3D * 10),(VAR3D / 10)),3);
VAR5D:=LLV(LOW,38);
VAR6D:=HHV(VAR4D,38);
VAR7D:=IF(LLV(LOW,90),1,0);
VAR8D:=((EMA(IF((LOW <= VAR5D),((VAR4D + (VAR6D * 2)) / 2),0),3) / 618) * VAR7D);
秘密吸筹:STICKLINE(VAR8D,0,VAR8D,6,1),COLORFFFF66;
XL1:=(MA(LOW,2) * 0.96);
XL2:=(MA(LOW,26) * 0.85);
XL3:=(((REF(XL1,1) < XL2) AND (REF(XL1,1) < XL1)) AND (REF(XL1,1) < REF(XL1,2)));
STICKLINE(XL3,0,VAR8D,6,0),COLORFF00CC;
{DRAWTEXT(XL3,(VAR8D * 2),'短线出击'),COLORRED;}
↑短线突击:DRAWICON(XL3,40,25),COLORFF99CC;
DRAWICON(红灯,1.1,9);
DRAWICON(绿灯,30,15);

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表