手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助做个选股预警

[通达信]
设置
1470 4 林198612 Lv.2 发表于 · 2020-3-26 16:16 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
公式1
VAR1Z1:=(CLOSE-LLV(LOW,45))/(HHV(HIGH,45)-LLV(LOW,45));
VAR2Z1:=SMA(VAR1Z1,3,1);
VAR3Z1:=SMA(VAR2Z1,3,1);
VAR4Z1:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
抄底:CROSS(VAR4Z1,10) AND VAR3Z1<12;

公式2
均价:=DYNAINFO(11)*(1+0.021);
DIFA:=EMA(CLOSE,6)-EMA(CLOSE,13);
DEA:=EMA(DIFA,5);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
MK日金叉:=CROSS(DIFA,DEA) AND CROSS(K,D);
ST:=IF(NAMELIKE('ST') OR NAMELIKE('*ST'),0,1);
MK日金叉共振:IF(MK日金叉,5,0) AND ST AND DYNAINFO(11)>DYNAINFO(3) AND IF(DYNAINFO(7)>均价,1,0);


请老师合并这2个公式   老师看看可不可以把公式1昨天有信号  公式2今天有信号   并且今天发出信号预警

举报

扔鸡蛋(0) 回复

林198612
Lv.2
发表于 2020-3-26 16:57 复制 查看全部楼层
休闲者68 发表于 2020-3-26 16:50
2楼选股公式就是不是同一天出的信号。

谢谢老师   

举报

扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-3-26 16:50 复制 查看全部楼层
林198612 发表于 2020-3-26 16:43
谢谢老师帮忙  可不可以改成这两个公式不是同一天出的信号选出来

2楼选股公式就是不是同一天出的信号。

举报

扔鸡蛋(0) 回复

林198612
Lv.2
发表于 2020-3-26 16:43 复制 查看全部楼层
休闲者68 发表于 2020-3-26 16:25
VAR1Z1:=(CLOSE-LLV(LOW,45))/(HHV(HIGH,45)-LLV(LOW,45));
VAR2Z1:=SMA(VAR1Z1,3,1);
VAR3Z1:=SMA(VAR ...

谢谢老师帮忙  可不可以改成这两个公式不是同一天出的信号选出来

举报

点亮(0) 扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-3-26 16:25 复制 查看全部楼层

VAR1Z1:=(CLOSE-LLV(LOW,45))/(HHV(HIGH,45)-LLV(LOW,45));
VAR2Z1:=SMA(VAR1Z1,3,1);
VAR3Z1:=SMA(VAR2Z1,3,1);
VAR4Z1:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
抄底:=CROSS(VAR4Z1,10) AND VAR3Z1<12;


均价:=DYNAINFO(11)*(1+0.021);
DIFA:=EMA(CLOSE,6)-EMA(CLOSE,13);
DEA:=EMA(DIFA,5);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
MK日金叉:=CROSS(DIFA,DEA) AND CROSS(K,D);
ST:=IF(NAMELIKE('ST') OR NAMELIKE('*ST'),0,1);
MK日金叉共振:=IF(MK日金叉,5,0) AND ST AND DYNAINFO(11)>DYNAINFO(3) AND IF(DYNAINFO(7)>均价,1,0);

REF(抄底,1) AND MK日金叉共振;
查看全部打赏
  • 林198612+8理想币 +2共享币 : 很给力,投资愉快,理想因你而精彩;

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表