手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助根据主图买入做个选股器

[通达信]
设置
1895 8 卡卡a Lv.2 发表于 · 2020-3-26 17:22 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
HHJSJDA:=(3*CLOSE+OPEN+LOW+HIGH)/6;
HHJSJDB:(20*HHJSJDA+19*REF(HHJSJDA,1)+18*REF(HHJSJDA,2)+17*REF(HHJSJDA,3)+16*REF(HHJSJDA,4)+15*REF(HHJSJDA,5)+14*REF(HHJSJDA,6)
+13*REF(HHJSJDA,7)+12*REF(HHJSJDA,8)+11*REF(HHJSJDA,9)+10*REF(HHJSJDA,10)+9*REF(HHJSJDA,11)+8*REF(HHJSJDA,12)
+7*REF(HHJSJDA,13)+6*REF(HHJSJDA,14)+5*REF(HHJSJDA,15)+4*REF(HHJSJDA,16)+3*REF(HHJSJDA,17)+2*REF(HHJSJDA,18)+
REF(HHJSJDA,20))/210,COLORYELLOW;
HHJSJDC:MA(HHJSJDB,5),COLORRED;
{买入卖出}
VAR35:=LLV(HIGH,240);
VAR40:=100*(CLOSE-VAR35)/VAR35;
VAR50:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;
VAR60:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;
VAR70:=0;
VAR80:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;
VAR90:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;
VAR100:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VAR110:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR120:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR130:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR140:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR150:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR160:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR170:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR180:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR190:=EMA(CLOSE,2)-EMA(CLOSE,150);
买1:=VAR100;
买2:=(VAR110+VAR130+VAR150+VAR170);
卖1:=(VAR120+VAR140+VAR160+VAR180);
DRAWTEXT(买1>0 OR 买2>0,LOW*0.98,'←买入'),COLORRED;
DRAWTEXT(卖1>0,HIGH*1.02,'←卖出'),COLORGREEN;

举报

扔鸡蛋(0) 回复

飞机大大炮
Lv.3
发表于 2020-3-27 09:47 复制 查看全部楼层
延进那里,你不是回复了吗?

举报

扔鸡蛋(0) 回复

卡卡a
Lv.2
发表于 2020-3-27 06:34 复制 查看全部楼层
飞机大大炮 发表于 2020-3-26 22:49
QQ发你了啊,一起研究

在那呢没收到啊,

举报

扔鸡蛋(0) 回复

飞机大大炮
Lv.3
发表于 2020-3-26 22:55 复制 查看全部楼层
你家我,我给你撬开看看源码

举报

扔鸡蛋(0) 回复

飞机大大炮
Lv.3
发表于 2020-3-26 22:49 复制 查看全部楼层
QQ发你了啊,一起研究

举报

扔鸡蛋(0) 回复

卡卡a
Lv.2
发表于 2020-3-26 21:57 复制 查看全部楼层
飞机大大炮 发表于 2020-3-26 18:00
VAR35:=LLV(HIGH,240);
VAR40:=100*(CLOSE-VAR35)/VAR35;
VAR50:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528) ...

老师,非常感谢

举报

扔鸡蛋(0) 回复

飞机大大炮
Lv.3
发表于 2020-3-26 18:00 复制 查看全部楼层

VAR35:=LLV(HIGH,240);
VAR40:=100*(CLOSE-VAR35)/VAR35;
VAR50:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;
VAR60:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;
VAR70:=0;
VAR80:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;
VAR90:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;
VAR100:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VAR110:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR120:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR130:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR140:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR150:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR160:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR170:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR180:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR190:=EMA(CLOSE,2)-EMA(CLOSE,150);
买1:=VAR100;
买2:=(VAR110+VAR130+VAR150+VAR170);
卖1:=(VAR120+VAR140+VAR160+VAR180);
XXG:买1>0 OR 买2>0;

举报

扔鸡蛋(0) 回复

飞机大大炮
Lv.3
发表于 2020-3-26 17:58 复制 查看全部楼层
zig   做了也没什么用啊

举报

扔鸡蛋(0) 回复

卡卡a
Lv.2
发表于 2020-3-26 17:44 复制 查看全部楼层
在帮做个盘中预警

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表