手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

【已解决】7%以上的跌幅用蓝色高亮标示,跌停用绿色高亮标示指标怎么编写

[互 助]
设置
5444 30 阿宾睡妖 Lv.7 发表于 · 2020-3-26 18:32 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
本帖最后由 阿宾睡妖 于 2020-3-26 19:31 编辑

7%阴:=IF((REF(C,1)-C)*100/REF(C,1)>=(7-0.01*100/REF(C,1)),3,0);
跌停:=IF((REF(C,1)-C)*100/REF(C,1)>=(10-0.01*100/REF(C,1)),3,0);
STICKLINE(7%阴,O,C,7,0),COLORBLUE,Layer1;
STICKLINE(跌停(ref(7%阴,1),O,C,7,0)),COLORGREEN,Layer3;


搞了一半不对。。。。
谢谢10楼帮忙:
STICKLINE(C/REF(C,1)<0.93 and C<>L,O,C,7,0),COLORBLUE,Layer1;
STICKLINE(C/REF(C,1)<0.905 AND C=L,O,C,7,0),COLORGREEN,Layer3;

微信截图_20200326193018.png

附件

微信截图_20200326183149.png

举报

扔鸡蛋(0) 回复

从哪里来您
Lv.3
发表于 2020-3-27 18:22 复制 查看全部楼层
谢谢各位的指导

举报

扔鸡蛋(0) 回复

高价股庄股
Lv.1
发表于 2020-3-27 10:36 复制 查看全部楼层
谢谢各位的指导

举报

扔鸡蛋(0) 回复

黄歌
Lv.4
发表于 2020-3-27 09:55 复制 查看全部楼层
王人二 发表于 2020-3-26 18:50
你要分科创板 ST和其他的,然后就简单的了。
然后分假阴和假阳。

这个图不错,能否提供code,谢谢哈

举报

点亮(0) 扔鸡蛋(0) 回复

宝贝凌云
Lv.3
发表于 2020-3-26 23:48 复制 查看全部楼层
这个对了,谢谢啦

举报

扔鸡蛋(0) 回复

天津饭
Lv.4
发表于 2020-3-26 23:29 复制 查看全部楼层
这样也不错
ZDF:=(C-REF(C,1))/REF(C,1)*100;
STICKLINE(ZDF>7,H,L,0,1),COLORYELLOW;
STICKLINE(ZDF>7,C,O,-1,1),COLORYELLOW;
STICKLINE(ZDF>9.95,H,L,0,0),COLORRED;
STICKLINE(ZDF>9.95,C,O,-1,0),COLORRED;
STICKLINE(ZDF<-7,H,L,0,1),COLORBLUE;
STICKLINE(ZDF<-7,C,O,-1,1),COLORBLUE;
STICKLINE(ZDF<-9.95,H,L,0,0),COLORGREEN;
STICKLINE(ZDF<-9.95,C,O,-1,0),COLORGREEN;

举报

点亮(0) 扔鸡蛋(0) 回复

三板红K
Lv.4
发表于 2020-3-26 21:48 复制 查看全部楼层
谢                                

举报

扔鸡蛋(0) 回复

吴怡
Lv.5
发表于 2020-3-26 21:37 复制 查看全部楼层
本帖最后由 吴怡 于 2020-3-26 21:45 编辑

。。。。。。

举报

点亮(0) 扔鸡蛋(0) 回复

阿宾睡妖
Lv.7
发表于 2020-3-26 21:27 复制 查看全部楼层
散户柚子 发表于 2020-3-26 19:57
我快速粗复盘用这个:http://pro.gw.com.cn/newfpsq/index.html#/  链接到通达信上。

我是看技术形态复盘,不是热点复盘的,热点复盘那些看一眼就够了

举报

点亮(1) 扔鸡蛋(0) 回复

阿宾睡妖
Lv.7
发表于 2020-3-26 21:20 复制 查看全部楼层
往事642 发表于 2020-3-26 20:36
谢谢阿宾老师无私分享!这么多楼内朋友提醒你多看看自己的系统提醒,有意外惊喜!

我的系统提醒没有什么啊

附件

微信截图_20200326212000.png

举报

扔鸡蛋(0) 回复

往事642
Lv.4
发表于 2020-3-26 20:36 复制 查看全部楼层
谢谢阿宾老师无私分享!这么多楼内朋友提醒你多看看自己的系统提醒,有意外惊喜!

举报

点亮(2) 扔鸡蛋(0) 回复

散户柚子
Lv.3
发表于 2020-3-26 19:57 复制 查看全部楼层
阿宾睡妖 发表于 2020-3-26 19:52
也玩啊,不过复盘不用通达信

我快速粗复盘用这个:http://pro.gw.com.cn/newfpsq/index.html#/  链接到通达信上。

举报

点亮(0) 扔鸡蛋(0) 回复

阿宾睡妖
Lv.7
发表于 2020-3-26 19:52 复制 查看全部楼层

也玩啊,不过复盘不用通达信

举报

扔鸡蛋(0) 回复

阿宾睡妖
Lv.7
发表于 2020-3-26 19:51 复制 查看全部楼层
圣虎战狼 发表于 2020-3-26 19:35
你现在用这个是粗犷型的,99%表达。

用涨跌停,是精细型的,可以说100%表达。

粗犷就可以了,一眼看过去涨停跌停比较醒目就达到要求了,不用太精细了,我本来就不懂公式,没必要搞那么复杂

举报

点亮(1) 扔鸡蛋(0) 回复

散户柚子
Lv.3
发表于 2020-3-26 19:49 复制 查看全部楼层
阿宾睡妖 发表于 2020-3-26 18:54
用的是操盘手,用你的这个公式能通过,但是跌停和跌幅的颜色还是没有分开

不玩通达信了?

举报

扔鸡蛋(0) 回复

圣虎战狼
Lv.4
发表于 2020-3-26 19:35 复制 查看全部楼层

你现在用这个是粗犷型的,99%表达。

用涨跌停,是精细型的,可以说100%表达。

举报

点亮(1) 扔鸡蛋(0) 回复

圣虎战狼
Lv.4
发表于 2020-3-26 19:31 复制 查看全部楼层
本帖最后由 圣虎战狼 于 2020-3-26 21:42 编辑

.................................................................................................

举报

点亮(1) 扔鸡蛋(0) 回复

阿宾睡妖
Lv.7
发表于 2020-3-26 19:27 复制 查看全部楼层
圣虎战狼 发表于 2020-3-26 19:05
K线上这样表达应该就OK了。

STICKLINE(C/REF(C,1)

STICKLINE(C/REF(C,1)<0.93 and C<>L,O,C,7,0),COLORBLUE,Layer1;
STICKLINE(C/REF(C,1)<0.905 AND C=L,O,C,7,0)),COLORGREEN,Layer3;

这个对了,谢谢啦

附件

微信截图_20200326192730.png

举报

点亮(1) 扔鸡蛋(0) 回复

阿宾睡妖
Lv.7
发表于 2020-3-26 19:25 复制 查看全部楼层
王人二 发表于 2020-3-26 19:11
ZDF:=(C-REF(C,1))/REF(C,1)*100;
STICKLINE(ZDF>7,H,L,0,1),COLORYELLOW;
STICKLINE(ZDF>7,C,O,-1,1),C ...

这个也不是那个效果

举报

扔鸡蛋(0) 回复

阿宾睡妖
Lv.7
发表于 2020-3-26 19:21 复制 查看全部楼层
圣虎战狼 发表于 2020-3-26 19:15
如果操盘手有像通达信一样的ZTPRICE、DTPRICE这两个函数,就更简单了。

涨停:=ZTPRICE(ref(close,1),if( ...

就是没有这两个函数啊

举报

扔鸡蛋(0) 回复

圣虎战狼
Lv.4
发表于 2020-3-26 19:15 复制 查看全部楼层
本帖最后由 圣虎战狼 于 2020-3-26 19:16 编辑

如果操盘手有像通达信一样的ZTPRICE、DTPRICE这两个函数,就更简单了。

涨停:=ZTPRICE(ref(close,1),if(inblock('ST板块'),0.05,if(inblock('科创板'),0.2,0.1)));
跌停:=DTPRICE(ref(close,1),if(inblock('ST板块'),0.05,if(inblock('科创板'),0.2,0.1)));
STICKLINE(C>=涨停,C,O,2.7,0),COLOR00FFFF;
STICKLINE(C>=涨停,L,H,0,0),COLOR00FFFF;
STICKLINE(C<=跌停,C,O,2.7,0),COLOR00FF00;
STICKLINE(C<=跌停,L,H,0,0),COLOR00FF00;
STICKLINE(C/REF(C,1)<0.93 and C<>L  and  NOT(C<=跌停),O,C,7,0),COLOR0000FF;

举报

点亮(1) 扔鸡蛋(0) 回复

王人二
Lv.3
发表于 2020-3-26 19:11 复制 查看全部楼层
本帖最后由 王人二 于 2020-3-26 19:15 编辑

ZDF:=(C-REF(C,1))/REF(C,1)*100;
STICKLINE(ZDF>7,H,L,0,1),COLORYELLOW;
STICKLINE(ZDF>7,C,O,-1,1),COLORYELLOW;
STICKLINE(ZDF<-7,H,L,0,0),COLORBLUE;
STICKLINE(ZDF<-7,C,O,-1,0),COLORBLUE;

举报

点亮(1) 扔鸡蛋(0) 回复

圣虎战狼
Lv.4
发表于 2020-3-26 19:05 复制 查看全部楼层
阿宾睡妖 发表于 2020-3-26 18:54
用的是操盘手,用你的这个公式能通过,但是跌停和跌幅的颜色还是没有分开

K线上这样表达应该就OK了。

STICKLINE(C/REF(C,1)<0.93 and C<>L,O,C,7,0),COLORBLUE,Layer1;
STICKLINE(C/REF(C,1)<0.905 AND C=L,O,C,7,0)),COLORGREEN,Layer3;

<>不等于号,我没有用过操盘手,不知道是不是这个符号,还是!=

Layer这个函数,应该是数字越大,越是底层吧,你可以把蓝色的那个换成Layer3,绿色的那个换成Layer1,这样看看行不行。
查看全部打赏

举报

点亮(1) 扔鸡蛋(0) 回复

阿宾睡妖
Lv.7
发表于 2020-3-26 19:01 复制 查看全部楼层
CS1:=IF(CODELIKE('688'),0.2,0.1);
MA1:MA(CLOSE,M1);
MA2:MA(CLOSE,M2);
MA3:MA(CLOSE,M3);
MA4:MA(CLOSE,M4);
MA5:MA(CLOSE,M5);
MA6:MA(CLOSE,M6);
MA7:MA(CLOSE,M7);
STICKLINE(C>=ZTPRICE(REF(C,1),CS1),C,O,2.7,0),COLOR00FFFF;
STICKLINE(C>=ZTPRICE(REF(C,1),CS1),L,H,0,0),COLOR00FFFF;

这个是涨停的

举报

点亮(1) 扔鸡蛋(0) 回复

阿宾睡妖
Lv.7
发表于 2020-3-26 18:55 复制 查看全部楼层
王人二 发表于 2020-3-26 18:50
你要分科创板 ST和其他的,然后就简单的了。
然后分假阴和假阳。


就跟前一天比,跌幅大于7个点就蓝色,跌停就绿色。不用管科创板这些
查看全部打赏
  • 吴怡+10理想币 : 点:只看该作者,第一页

举报

点亮(1) 扔鸡蛋(0) 回复

阿宾睡妖
Lv.7
发表于 2020-3-26 18:54 复制 查看全部楼层
圣虎战狼 发表于 2020-3-26 18:47
应该是大智慧软件吧?

STICKLINE(C/REF(C,1)

用的是操盘手,用你的这个公式能通过,但是跌停和跌幅的颜色还是没有分开

附件

微信截图_20200326185320.png

举报

点亮(1) 扔鸡蛋(0) 回复

长长的枪
Lv.3
发表于 2020-3-26 18:53 复制 查看全部楼层
支持,烦请论坛大师帮忙解决!

举报

扔鸡蛋(0) 回复

王人二
Lv.3
发表于 2020-3-26 18:50 复制 查看全部楼层
你要分科创板 ST和其他的,然后就简单的了。
然后分假阴和假阳。
QQ图片20200326184907.png

举报

点亮(2) 扔鸡蛋(0) 回复

阿宾睡妖
Lv.7
发表于 2020-3-26 18:50 复制 查看全部楼层
一路畅通98 发表于 2020-3-26 18:39
跌停:=STICKLINE((C=DTPRICE(REF(CLOSE,1),0.1) AND C=L),O,C,3,0),COLORGREEN;

DTPRICE  这个函数不支持,用的是操盘手,谢谢啦

举报

点亮(2) 扔鸡蛋(0) 回复

圣虎战狼
Lv.4
发表于 2020-3-26 18:47 复制 查看全部楼层
应该是大智慧软件吧?

STICKLINE(C/REF(C,1)<0.93,O,C,7,0),COLORBLUE,Layer1;
STICKLINE(C/REF(C,1)<0.905 AND C=L,O,C,7,0)),COLORGREEN,Layer3;

举报

点亮(2) 扔鸡蛋(0) 回复

一路畅通98
Lv.4
发表于 2020-3-26 18:39 复制 查看全部楼层
跌停:=STICKLINE((C=DTPRICE(REF(CLOSE,1),0.1) AND C=L),O,C,3,0),COLORGREEN;

举报

点亮(2) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表