手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙改写个分时图出现红色B的选股公式,谢谢啦

[通达信]
设置
1455 5 鹏来 Lv.2 发表于 · 2020-3-26 19:35 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
FX1:=VOL/CLOSE/3;
FX2:=SUM(IF(FX1>0.2 AND CLOSE>REF(CLOSE,1),FX1,0),0);
FX3:=SUM(IF(FX1>0.2 AND CLOSE<REF(CLOSE,1),FX1,0),0);
FX4:=FX2+FX3;
FX5:=1;
FX6:=FX2/FX3;
FX7:=EMA((-100)*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4)+100;
FX8:=MAX(DYNAINFO(3),DYNAINFO(5));
FX9:=MIN(DYNAINFO(3),DYNAINFO(6));
FX10:=FX8-FX9;
FX11:=FX9+FX10*7/8;
FX12:=FX9+FX10*0.5/8;
FX13:=SUM(CLOSE*VOL,240)/SUM(VOL,240);
FX14:=BARSCOUNT(CLOSE);
FX15:=MA(CLOSE,FX14);
FX16:=FX15+2*STD(CLOSE,3);
FX17:=FX15-2*STD(CLOSE,3);
FX18:=TIME>93000;
FX19:=CLOSE/REF(CLOSE,1)>1.02;
FX20:=CLOSE/REF(CLOSE,1)<0.98;
FX21:=(HHV(CLOSE,FX14)-LLV(CLOSE,FX14))/CLOSE<0.05;
FX22:=SMA(VOL,30,1);
FX23:=(FX22-LLV(LLV(FX22,1),30))/(HHV(HHV(FX22,1),30)-LLV(LLV(FX22,1),30))>0.95;
FX24:=FX19 OR FX20;
FX25:=FX24=0 AND FX21 AND FX23 AND CROSS(FX13,FX15);
IF(MACD.DEA<0,CLOSE,DRAWNULL),COLORYELLOW,LINETHICK9;
FX26:=SUM(AMOUNT,BARSCOUNT(CLOSE))/SUM(VOL*100,BARSCOUNT(CLOSE));
FX27:=EXPMA(CLOSE/FX26,20);
FX28:=EXPMA(CLOSE/FX26,60);
FX29:=EXPMA(CLOSE/FX26,120);
FX30:=1;
1.02,NODRAW;
FX31:=1.03;
FX32:=FX27>FX28 AND FX27>1.003 AND FX28>FX29 AND CLOSE>EXPMA(CLOSE,20) AND EXPMA(CLOSE,10)>EXPMA(CLOSE,20) AND EXPMA(CLOSE,20)>EXPMA(CLOSE,60);
DRAWICON(FX27>FX28 AND FX28>FX29 AND CLOSE>EXPMA(CLOSE,20) AND EXPMA(CLOSE,10)>EXPMA(CLOSE,20) AND EXPMA(CLOSE,20)>EXPMA(CLOSE,60) AND FX27=HHV(FX27,30) AND CROSS(FX27,1.003),CLOSE,25);
DRAWICON(CROSS(FX27,1.02),CLOSE,24);
DRAWICON(CROSS(FX27,1.04),CLOSE,26);
FX33:=MAX(DYNAINFO(3),DYNAINFO(5));
FX34:=MIN(DYNAINFO(3),DYNAINFO(6));
FX35:=FX33-FX34;
压力线:FX34+FX35*7/8,COLORMAGENTA,LINETHICK2;
支撑线:FX34+FX35*0.5/8,COLORGREEN,LINETHICK2;
中线:(支撑线+压力线)/2,COLORWHITE,LINETHICK2;
FX36:=SUM(IF(CLOSE>REF(CLOSE,1) AND VOL>4000,VOL/1000,0),0);
FX37:=SUM(IF(CLOSE<REF(CLOSE,1) AND VOL>4000,VOL/1000,0),0);
FX38:=SUM(IF(CLOSE>REF(CLOSE,1),VOL/1000,0),0);
FX39:=SUM(IF(CLOSE<REF(CLOSE,1),VOL/1000,0),0);
FX40:=FX38-FX36;
FX41:=FX39-FX37;
FX42:=FX36;
FX43:=FX37;
FX44:=FX40;
FX45:=FX41;
FX46:=FX36-FX37;
FX47:=FX40-FX41;
FX48:=FX38-FX39;
FX49:=CONST(MAX(ABS(FX42),MAX(ABS(FX43),MAX(ABS(FX44),ABS(FX45)))));
地:EMA(FX13,50)/0.97,COLORGREEN,LINETHICK2;
IF(地>REF(地,1),地,DRAWNULL),COLORRED,LINETHICK2;
平衡线:(FX13+地)/2,DOTLINE,COLORGREEN;
FX50:=COUNT(VOL>4000 AND CLOSE>REF(CLOSE,1),0);
黄次数:COUNT(VOL>DYNAINFO(16)*10 AND CLOSE>REF(CLOSE,1),0),NODRAW,COLORYELLOW;
DRAWICON(FX50>REF(FX50,1) AND 黄次数>REF(黄次数,1) AND CROSS(CLOSE,地),CLOSE,7);
DRAWICON(FX40>FX41 AND FX36>FX40 AND FX41>FX37,FX13,38);
SUM(VOL*CLOSE,0)/SUM(VOL,0),COLORYELLOW;

举报

扔鸡蛋(0) 回复

马啃波罗
Lv.2
发表于 2020-3-26 22:23 复制 查看全部楼层
FX1:=VOL/CLOSE/3; FX2:=SUM(IF(FX1>0.2 AND CLOSE>REF(CLOSE,1),FX1,0),0); FX3:=SUM(IF(FX1>0.2 AND CLOSE<REF(CLOSE,1),FX1,0),0); FX4:=FX2+FX3; FX5:=1; FX6:=FX2/FX3; FX7:=EMA((-100)*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4)+100; FX8:=MAX(DYNAINFO(3),DYNAINFO(5)); FX9:=MIN(DYNAINFO(3),DYNAINFO(6)); FX10:=FX8-FX9; FX11:=FX9+FX10*7/8; FX12:=FX9+FX10*0.5/8; FX13:=SUM(CLOSE*VOL,240)/SUM(VOL,240); FX14:=BARSCOUNT(CLOSE); FX15:=MA(CLOSE,FX14); FX16:=FX15+2*STD(CLOSE,3); FX17:=FX15-2*STD(CLOSE,3); FX18:=TIME>93000; FX19:=CLOSE/REF(CLOSE,1)>1.02; FX20:=CLOSE/REF(CLOSE,1)<0.98; FX21:=(HHV(CLOSE,FX14)-LLV(CLOSE,FX14))/CLOSE<0.05; FX22:=SMA(VOL,30,1); FX23:=(FX22-LLV(LLV(FX22,1),30))/(HHV(HHV(FX22,1),30)-LLV(LLV(FX22,1),30))>0.95; FX24:=FX19 OR FX20; FX25:=FX24=0 AND FX21 AND FX23 AND CROSS(FX13,FX15); IF(MACD.DEA<0,CLOSE,DRAWNULL),COLORYELLOW,LINETHICK9; FX26:=SUM(AMOUNT,BARSCOUNT(CLOSE))/SUM(VOL*100,BARSCOUNT(CLOSE)); FX27:=EXPMA(CLOSE/FX26,20); FX28:=EXPMA(CLOSE/FX26,60); FX29:=EXPMA(CLOSE/FX26,120); FX30:=1; 1.02,NODRAW; FX31:=1.03; FX32:=FX27>FX28 AND FX27>1.003 AND FX28>FX29 AND CLOSE>EXPMA(CLOSE,20) AND EXPMA(CLOSE,10)>EXPMA(CLOSE,20) AND EXPMA(CLOSE,20)>EXPMA(CLOSE,60); DRAWICON(FX27>FX28 AND FX28>FX29 AND CLOSE>EXPMA(CLOSE,20) AND EXPMA(CLOSE,10)>EXPMA(CLOSE,20) AND EXPMA(CLOSE,20)>EXPMA(CLOSE,60) AND FX27=HHV(FX27,30) AND CROSS(FX27,1.003),CLOSE,25); DRAWICON(CROSS(FX27,1.02),CLOSE,24); DRAWICON(CROSS(FX27,1.04),CLOSE,26); FX33:=MAX(DYNAINFO(3),DYNAINFO(5)); FX34:=MIN(DYNAINFO(3),DYNAINFO(6)); FX35:=FX33-FX34; 压力线:FX34+FX35*7/8,COLORMAGENTA,LINETHICK2; 支撑线:FX34+FX35*0.5/8,COLORGREEN,LINETHICK2; 中线:(支撑线+压力线)/2,COLORWHITE,LINETHICK2; FX36:=SUM(IF(CLOSE>REF(CLOSE,1) AND VOL>4000,VOL/1000,0),0); FX37:=SUM(IF(CLOSE<REF(CLOSE,1) AND VOL>4000,VOL/1000,0),0); FX38:=SUM(IF(CLOSE>REF(CLOSE,1),VOL/1000,0),0); FX39:=SUM(IF(CLOSE<REF(CLOSE,1),VOL/1000,0),0); FX40:=FX38-FX36; FX41:=FX39-FX37; FX42:=FX36; FX43:=FX37; FX44:=FX40; FX45:=FX41; FX46:=FX36-FX37; FX47:=FX40-FX41; FX48:=FX38-FX39; FX49:=CONST(MAX(ABS(FX42),MAX(ABS(FX43),MAX(ABS(FX44),ABS(FX45))))); 地:EMA(FX13,50)/0.97,COLORGREEN,LINETHICK2; IF(地>REF(地,1),地,DRAWNULL),COLORRED,LINETHICK2; 平衡线:(FX13+地)/2,DOTLINE,COLORGREEN; FX50:=COUNT(VOL>4000 AND CLOSE>REF(CLOSE,1),0); 黄次数:COUNT(VOL>DYNAINFO(16)*10 AND CLOSE>REF(CLOSE,1),0),NODRAW,COLORYELLOW; DRAWICON(FX50>REF(FX50,1) AND 黄次数>REF(黄次数,1) AND CROSS(CLOSE,地),CLOSE,7); DRAWICON(FX40>FX41 AND FX36>FX40 AND FX41>FX37,FX13,38); SUM(VOL*CLOSE,0)/SUM(VOL,0),COLORYELLOW;

举报

扔鸡蛋(0) 回复

鹏来
Lv.2
发表于 2020-3-26 20:53 复制 查看全部楼层
好的,谢谢老师。刚接触到公式这些东西,我来看看怎么放到放到附图里

举报

点亮(0) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-3-26 20:36 复制 查看全部楼层
下载刷新数据后选股  或放到附图里看信号

举报

扔鸡蛋(0) 回复

鹏来
Lv.2
发表于 2020-3-26 20:08 复制 查看全部楼层
谢谢许老师啦,我刚才测试了下,选出44只,有一些出现“B”,还有不少没有出现B,能不能烦请您在修改一下

举报

点亮(0) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-3-26 19:41 复制 查看全部楼层
FX1:=VOL/CLOSE/3;
FX2:=SUM(IF(FX1>0.2 AND CLOSE>REF(CLOSE,1),FX1,0),0);
FX3:=SUM(IF(FX1>0.2 AND CLOSE<REF(CLOSE,1),FX1,0),0);
FX4:=FX2+FX3;
FX5:=1;
FX6:=FX2/FX3;
FX7:=EMA((-100)*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4)+100;
FX8:=MAX(DYNAINFO(3),DYNAINFO(5));
FX9:=MIN(DYNAINFO(3),DYNAINFO(6));
FX10:=FX8-FX9;
FX11:=FX9+FX10*7/8;
FX12:=FX9+FX10*0.5/8;
FX13:=SUM(CLOSE*VOL,240)/SUM(VOL,240);

地:=EMA(FX13,50)/0.97,COLORGREEN,LINETHICK2;

平衡线:=(FX13+地)/2;
FX50:=COUNT(VOL>4000 AND CLOSE>REF(CLOSE,1),0);
黄次数:=COUNT(VOL>DYNAINFO(16)*10 AND CLOSE>REF(CLOSE,1),0);
XG:FX50>REF(FX50,1) AND 黄次数>REF(黄次数,1) AND CROSS(CLOSE,地);

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表