手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙编写个预警公式

[通达信]
设置
1466 6 风中点烟sh Lv.2 发表于 · 2020-3-26 23:36 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
只有当智勇出击:1.00 时出预警

F:=100*(C-REF(C,1))/REF(C,1);
今小昨:=IF(C<REF(O,1) AND F<0,1,0);
S1:=今小昨;
今小前:=IF(C<REF(O,2) AND F<0,1,0),LINETHICK0;
S2:=今小前;
A1:=S1=0 AND REF(S1,1)=1 AND S2=0 AND REF(S2,1)=1 AND CROSS(ZIG(3,3) ,REF(ZIG(3 ,3),1));
A2:=S1=0 AND REF(S1,1)=1 AND S2=0 AND REF(S2,1)=1 AND CROSS(ZIG(3,5) ,REF(ZIG(3 ,5),1));
A3:=S1=0 AND REF(S1,1)=1 AND S2=0 AND REF(S2,1)=1 AND CROSS(ZIG(3,10) ,REF(ZIG(3 ,10),1));
STICKLINE(A1 AND A2 ,0,3,3,0)COLORGREEN;
STICKLINE(A1 AND A2 ,0,1,3,0)COLORBLUE;
STICKLINE(A1 AND A2 AND A3,0,5,3,0)COLORYELLOW;
STICKLINE(A1 AND A2 AND A3,0,3,3,0)COLORFF00FF;
STICKLINE(A1 AND A2 AND A3,0,1,3,0)COLORBLUE;
DRAWTEXT(A3=1,4.8,'长攻!'),COLORYELLOW;
智勇出击: ZIG(3,6)>REF(ZIG(3,6),1)AND REF(ZIG(3,6),1)<REF(ZIG
(3,6),2),COLORWHITE,LINETHICK2;
DRAWTEXT(智勇出击=1,0.8,'突袭!'),COLORWHITE;
小获且退: ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>REF(ZIG
(3,10),2),COLORYELLOW,LINETHICK2;
DRAWTEXT(小获且退=1,1.3,'退!'),COLORYELLOW;
VAR3:=PEAKBARS(2,15,1)<10;
VAR5:=IF(VAR3=1,2,0);
顶:= IF(VAR5=2,2,0);
大胜且归:IF(顶>REF(顶,1),2,0),COLORRED,LINETHICK2;
DRAWTEXT(大胜且归=2,2,'撤!'),COLORRED;

举报

扔鸡蛋(0) 回复

老鹰的天空
Lv.2
发表于 2020-3-27 18:16 复制 查看全部楼层
关注站内驿站   布谷鸟   我会不定期发一些好的指标公式,也会给大家谈谈交易理念。

举报

点亮(0) 扔鸡蛋(0) 回复

风中点烟sh
Lv.2
发表于 2020-3-27 17:50 复制 查看全部楼层
老鹰的天空 发表于 2020-3-27 17:08
智勇出击: ZIG(3,6)>REF(ZIG(3,6),1)AND REF(ZIG(3,6),1)

收到 谢谢~

举报

扔鸡蛋(0) 回复

老鹰的天空
Lv.2
发表于 2020-3-27 17:08 复制 查看全部楼层
智勇出击: ZIG(3,6)>REF(ZIG(3,6),1)AND REF(ZIG(3,6),1)<REF(ZIG (3,6),2);

举报

点亮(0) 扔鸡蛋(0) 回复

风中点烟sh
Lv.2
发表于 2020-3-27 10:26 复制 查看全部楼层
老鹰的天空 发表于 2020-3-27 01:17
有ZIG(3,10)未来函数,建议不要使用

没关系的 知道有未来 老师可以的话帮忙编一个

举报

点亮(0) 扔鸡蛋(0) 回复

万山村
Lv.2
发表于 2020-3-27 06:22 复制 查看全部楼层
请老师写个选股公式   9 点 20 的最高价小于9点25的收盘价    也就是从9点20到9点25分股价步步升高  万分感谢老师

举报

扔鸡蛋(0) 回复

老鹰的天空
Lv.2
发表于 2020-3-27 01:17 复制 查看全部楼层
有ZIG(3,10)未来函数,建议不要使用

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表