手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助将这个统计公式改成东财通版

[东财通]
设置
1296 2 多多苏苏 Lv.4 发表于 · 2020-3-27 10:49 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
A:=BARSLAST(WEEKOFYEAR!=REF(WEEKOFYEAR,1));
YA:=BARSLAST(MONTH!=REF(MONTH,1));
JA:=MOD(MONTH,3);
JD:=BARSLAST(CROSS(JA,0.5));
NA:=BARSLAST(YEAR!=REF(YEAR,1));
QT:=BACKSET(A=0,2);
YQT:=BACKSET(YA=0,2);
JQT:=BACKSET(JD=0,2);
NQT:=BACKSET(NA=0,2);
T:=BARSLAST(CROSS(QT=1,0.5));
YT:=BARSLAST(CROSS(YQT=1,0.5));
JT:=BARSLAST(CROSS(JQT=1,0.5));
NT:=BARSLAST(CROSS(NQT=1,0.5));
CC:=REF(REF(C,T),1);
YC:=REF(REF(C,YT),1);
JC:=REF(REF(C,JT),1);
NC:=REF(REF(C,NT),1);
周涨幅:(C-CC)/CC*100 NODRAW;
月涨幅:(C-YC)/YC*100 NODRAW;
季涨幅:(C-JC)/JC*100 NODRAW;
年涨幅:(C-NC)/NC*100 NODRAW;

附件

88888888.jpg

举报

扔鸡蛋(0) 回复

多多苏苏
Lv.4
发表于 2020-3-27 20:54 复制 查看全部楼层
注册111 发表于 2020-3-27 16:08
A:=BARSLAST(WEEK=(1)!=REF(WEEK=(1),1));
YA:=BARSLAST(MONTH!=REF(MONTH,1));
JA:=MOD(MONTH,3);

非常准确,谢谢老师帮助!

举报

扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-3-27 16:08 复制 查看全部楼层
A:=BARSLAST(WEEK=(1)!=REF(WEEK=(1),1));
YA:=BARSLAST(MONTH!=REF(MONTH,1));
JA:=MOD(MONTH,3);
JD:=BARSLAST(CROSS(JA,0.5));
NA:=BARSLAST(YEAR!=REF(YEAR,1));
QT:=BACKSET(A=0,2);
YQT:=BACKSET(YA=0,2);
JQT:=BACKSET(JD=0,2);
NQT:=BACKSET(NA=0,2);
T:=BARSLAST(CROSS(QT=1,0.5));
YT:=BARSLAST(CROSS(YQT=1,0.5));
JT:=BARSLAST(CROSS(JQT=1,0.5));
NT:=BARSLAST(CROSS(NQT=1,0.5));
CC:=REF(REF(C,T),1);
YC:=REF(REF(C,YT),1);
JC:=REF(REF(C,JT),1);
NC:=REF(REF(C,NT),1);
周涨幅:(C-CC)/CC*100,NODRAW;
月涨幅:(C-YC)/YC*100,NODRAW;
季涨幅:(C-JC)/JC*100,NODRAW;
年涨幅:(C-NC)/NC*100,NODRAW;

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表