手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助给预警公式加一个条件

[通达信]
设置
1076 3 范特西sen Lv.2 发表于 · 2020-3-27 12:34 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
这个预警公式出来的股票,当天成交量大于前一天的成交量时,发出预警信号,谢谢老师

JX:=MA(C,5)>MA(C,10) AND MA(C,10)>MA(C,20) AND MA(C,20)>MA(C,60);
ZT:=C>=ZTPRICE(REF(C,1),0.1);   
XG:REF(BARSLASTCOUNT(ZT)=2,1) AND JX AND C>HHV(REF(H,1),240) AND REF(V/REF(V,1)<1.9,1) AND  O!=C;

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-3-27 13:10 复制 查看全部楼层
范特西sen 发表于 2020-3-27 12:57
谢谢老师,
可以帮我移植主图公式里面吗?

JXV:=MA(C,5)>MA(C,10) AND MA(C,10)>MA(C,20) AND MA(C,20)>MA(C,60);
ZTV:=C>=ZTPRICE(REF(C,1),0.1);   
XGV:REF(BARSLASTCOUNT(ZTV)=2,1) AND JXV AND C>HHV(REF(H,1),240) AND REF(V/REF(V,1)<1.9,1) AND  O!=C AND V>REF(V,1);
DRAWTEXT(XGV,H,'注意成交量放大'),COLORMAGENTA;
MA5:MA(CLOSE,5);
MA10:MA(CLOSE,10);
MA20:MA(CLOSE,20);
MA60:MA(CLOSE,60);
MA200:MA(CLOSE,200);
M:=5;
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR7:=LLV(LOW,M);
VAR8:=HHV(HIGH,M);
VAR9:=EMA((VAR6-VAR7)/(VAR8-VAR7)*100,13);
VARA:=EMA(0.667*REF(VAR9,1)+0.333*VAR9,2);
TJ0:=CROSS(VAR9,VARA);
TJ2:=CROSS(VARA,VAR9);
板块类别:=STRCAT(STRCAT(STRCAT(STRCAT(DYBLOCK,HYBLOCK),FGBLOCK),ZHBLOCK),GNBLOCK);
DRAWTEXT_FIX(ISLASTBAR,0.95,1,2,板块类别),COLORGREEN;
ZT:=(C-REF(C,1))/REF(C,1)*100>9.5 AND C=H;
STICKLINE(ZT,C,O,2.5,0),COLORRED;
PH:=TROUGHBARS(2,5,1);
LL:=HHV(H,PH);
TJ1:=LL=HIGH AND LL<REF(LL,1);{//=1}
TS:=SUMBARS(TJ1,2);
TJ:=PEAKBARS(2,5,1)=1 AND TS>=PH;
PL:=BARSLAST(TJ);
支撑:IF(BARSLAST(TJ1),
REF(LOW,BARSLAST(TJ1)),DRAWNULL),COLOREA91B5;
压力:IF(BARSLAST(TJ),REF(HIGH,PL),DRAWNULL),COLORYELLOW;
TJ_2:=LOW>REF(REF(LOW,TS),PL);

TJ11:= MA(C,10)>MA(C,20) AND MA(C,20)>MA(C,60);
TJ22:=MA(C,5)>REF(MA(C,5),1) AND MA(C,10)>REF(MA(C,10),1) AND MA(C,20)>REF(MA(C,20),1) AND MA(C,60)>REF(MA(C,60),1);
买入:TJ11 AND TJ22 AND CROSS(C,MA(C,5)) AND CROSS(MA(C,5),MA(C,10)) ;
DRAWTEXT(买入,L*0.98,'买入'),COLORYELLOW;
幅度:(ROUND((C/MA(C,5)-1)*100*100))/100,NODRAW;
{幅度:(ROUND((C/MA(C,5)-1)*100*100))/100,NODRAW;}
DRAWNUMBER(ISLASTBAR,H*1.01,幅度),COLORYELLOW;
DRAWTEXT(ISLASTBAR,H*1.005,'           %'),COLORYELLOW;

JX:=MA(C,5)>MA(C,10) AND MA(C,10)>MA(C,20) AND MA(C,20)>MA(C,60);
ZT1:=C>=ZTPRICE(REF(C,1),0.1);
XGS:REF(BARSLASTCOUNT(ZT1)=0,1) AND JX AND C>HHV(REF(H,1),240) AND ZT1;
DRAWTEXT(XGS,L*0.99,''),COLORYELLOW;



XG:REF(BARSLASTCOUNT(ZT1)=2,1) AND JX AND C>HHV(REF(H,1),240),NODRAW;
DRAWTEXT(XG,L*0.99,'↖打板'),COLORYELLOW;


JX2:=MA(C,5)>MA(C,10) AND MA(C,10)>MA(C,20) AND MA(C,20)>MA(C,60) AND MA(C,60)>MA(C,200);

XG2:=JX2 AND C>HHV(REF(H,1),240) AND REF(V/REF(V,1)<1.9,1) AND  O!=C;

T:=BARSLAST(XG2);

FB:CROSS(C,REF(H,T)) AND C>O,NODRAW;

DRAWTEXT(FB,H,''),COLORCYAN;


附件

tdxjietu11.JPG

举报

点亮(0) 扔鸡蛋(0) 回复

范特西sen
Lv.2
发表于 2020-3-27 12:57 复制 查看全部楼层
许昌舍得 发表于 2020-3-27 12:44
JX:=MA(C,5)>MA(C,10) AND MA(C,10)>MA(C,20) AND MA(C,20)>MA(C,60);
ZT:=C>=ZTPRICE(REF(C,1),0.1);   ...

谢谢老师,
可以帮我移植主图公式里面吗?

当出现这个信号的时候在K线的旁边写“注意成交量放大”,
谢谢
MA5:MA(CLOSE,5);
MA10:MA(CLOSE,10);
MA20:MA(CLOSE,20);
MA60:MA(CLOSE,60);
MA200:MA(CLOSE,200);
M:=5;
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR7:=LLV(LOW,M);
VAR8:=HHV(HIGH,M);
VAR9:=EMA((VAR6-VAR7)/(VAR8-VAR7)*100,13);
VARA:=EMA(0.667*REF(VAR9,1)+0.333*VAR9,2);
TJ0:=CROSS(VAR9,VARA);
TJ2:=CROSS(VARA,VAR9);
板块类别:=STRCAT(STRCAT(STRCAT(STRCAT(DYBLOCK,HYBLOCK),FGBLOCK),ZHBLOCK),GNBLOCK);
DRAWTEXT_FIX(ISLASTBAR,0.95,1,2,板块类别),COLORGREEN;
ZT:=(C-REF(C,1))/REF(C,1)*100>9.5 AND C=H;
STICKLINE(ZT,C,O,2.5,0),COLORRED;
PH:=TROUGHBARS(2,5,1);
LL:=HHV(H,PH);
TJ1:=LL=HIGH AND LL<REF(LL,1);{//=1}
TS:=SUMBARS(TJ1,2);
TJ:=PEAKBARS(2,5,1)=1 AND TS>=PH;
PL:=BARSLAST(TJ);
支撑:IF(BARSLAST(TJ1),
REF(LOW,BARSLAST(TJ1)),DRAWNULL),COLOREA91B5;
压力:IF(BARSLAST(TJ),REF(HIGH,PL),DRAWNULL),COLORYELLOW;
TJ_2:=LOW>REF(REF(LOW,TS),PL);

TJ11:= MA(C,10)>MA(C,20) AND MA(C,20)>MA(C,60);
TJ22:=MA(C,5)>REF(MA(C,5),1) AND MA(C,10)>REF(MA(C,10),1) AND MA(C,20)>REF(MA(C,20),1) AND MA(C,60)>REF(MA(C,60),1);
买入:TJ11 AND TJ22 AND CROSS(C,MA(C,5)) AND CROSS(MA(C,5),MA(C,10)) ;
DRAWTEXT(买入,L*0.98,'买入'),COLORYELLOW;
幅度:(ROUND((C/MA(C,5)-1)*100*100))/100,NODRAW;
{幅度:(ROUND((C/MA(C,5)-1)*100*100))/100,NODRAW;}
DRAWNUMBER(ISLASTBAR,H*1.01,幅度),COLORYELLOW;
DRAWTEXT(ISLASTBAR,H*1.005,'           %'),COLORYELLOW;

JX:=MA(C,5)>MA(C,10) AND MA(C,10)>MA(C,20) AND MA(C,20)>MA(C,60);
ZT1:=C>=ZTPRICE(REF(C,1),0.1);
XGS:REF(BARSLASTCOUNT(ZT1)=0,1) AND JX AND C>HHV(REF(H,1),240) AND ZT1;
DRAWTEXT(XGS,L*0.99,''),COLORYELLOW;



XG:REF(BARSLASTCOUNT(ZT1)=2,1) AND JX AND C>HHV(REF(H,1),240),NODRAW;
DRAWTEXT(XG,L*0.99,'↖打板'),COLORYELLOW;


JX2:=MA(C,5)>MA(C,10) AND MA(C,10)>MA(C,20) AND MA(C,20)>MA(C,60) AND MA(C,60)>MA(C,200);

XG2:=JX2 AND C>HHV(REF(H,1),240) AND REF(V/REF(V,1)<1.9,1) AND  O!=C;

T:=BARSLAST(XG2);

FB:CROSS(C,REF(H,T)) AND C>O,NODRAW;

DRAWTEXT(FB,H,''),COLORCYAN;




举报

点亮(0) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-3-27 12:44 复制 查看全部楼层

JX:=MA(C,5)>MA(C,10) AND MA(C,10)>MA(C,20) AND MA(C,20)>MA(C,60);
ZT:=C>=ZTPRICE(REF(C,1),0.1);   
XG:REF(BARSLASTCOUNT(ZT)=2,1) AND JX AND C>HHV(REF(H,1),240) AND REF(V/REF(V,1)<1.9,1) AND  O!=C AND V>REF(V,1);

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表