手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助改一下这个公式只出三角提示,不出梯形的

[通达信]
设置
1305 1 中国饭店 Lv.4 发表于 · 2020-3-27 14:57 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
每天符合的话就出三角,不出梯形,意思就是输出就一个,也不知道表述的意思明白不,谢谢老师。

XAZ_1:=MA(KDJ.K#MONTH(9,3,3),21);
XAZ_2:=MA(KDJ.D#MONTH(9,3,3),21);
XAZ_3:=MA(KDJ.J#MONTH(9,3,3),21);
XAZ_4:=MA(KDJ.K#WEEK(9,3,3),5);
XAZ_5:=MA(KDJ.D#WEEK(9,3,3),5);
XAZ_6:=MA(KDJ.J#WEEK(9,3,3),5);
XAZ_7:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
XAZ_8:=SMA(XAZ_7,3,1);
XAZ_9:=SMA(XAZ_8,3,1);
XAZ_10:=3*XAZ_8-2*XAZ_9;
XG1:XAZ_3>REF(XAZ_3,1) AND XAZ_6>REF(XAZ_6,1) AND XAZ_10>REF(XAZ_10,1) AND XAZ_10<40 COLORFFCC00;
UEJ1:=5*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1);
UEJ2:=3*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
UEJ3:=SMA(SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),2,1);
IDG:=UEJ1-UEJ2-UEJ3;

举报

扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-3-27 19:52 复制 查看全部楼层
中国饭店 发表于 2020-3-27 15:20
@许昌舍得 老师抽空不忙了帮我看看呗,现在是连续出信号的时候出梯形,我需要只出一个三角的提示,即便是连 ...

XAZ_1:=MA(KDJ.K#MONTH(9,3,3),21);
XAZ_2:=MA(KDJ.D#MONTH(9,3,3),21);
XAZ_3:=MA(KDJ.J#MONTH(9,3,3),21);
XAZ_4:=MA(KDJ.K#WEEK(9,3,3),5);
XAZ_5:=MA(KDJ.D#WEEK(9,3,3),5);
XAZ_6:=MA(KDJ.J#WEEK(9,3,3),5);
XAZ_7:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
XAZ_8:=SMA(XAZ_7,3,1);
XAZ_9:=SMA(XAZ_8,3,1);
XAZ_10:=3*XAZ_8-2*XAZ_9;
XG1:=XAZ_3>REF(XAZ_3,1) AND XAZ_6>REF(XAZ_6,1) AND XAZ_10>REF(XAZ_10,1) AND XAZ_10<40 COLORFFCC00;
UEJ1:=5*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1);
UEJ2:=3*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
UEJ3:=SMA(SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),2,1);
IDG:=UEJ1-UEJ2-UEJ3;
FILTER(XG1,3),COLORFFCC00;

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表