手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助在主图出现钻石时做成选股公式

[通达信]
设置
1951 2 强少73 Lv.2 发表于 · 2020-3-28 20:13 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
主图出现钻石时做成选股公式,非常感谢!



趋势线:MA(CLOSE,7),COLORGREEN;


牛熊:MA(CLOSE,54),COLORRED;


半年价:MA(CLOSE,99),NODRAW,COLORWHITE;


年价:MA(CLOSE,177),NODRAW,COLOR0080FF;


VAR1:=MA(CLOSE,120);


VAR2:=MA(VAR1-(EMA(CLOSE,3)-VAR1),5);


VAR3:=CLOSE/REF(CLOSE,1)>1.0993 AND CLOSE=HIGH;


STICKLINE(VAR3,OPEN,CLOSE,2,0),COLORRED;


VAR4:=CLOSE/REF(CLOSE,1)<0.913 AND CLOSE=LOW;


STICKLINE(VAR4,OPEN,CLOSE,2,0),COLORGREEN;


VAR5:=HIGH/REF(CLOSE,1)>1.0975 AND HIGH>CLOSE;


STICKLINE(VAR5,OPEN,CLOSE,1.5,0),COLOR871F78;


STICKLINE(CROSS(趋势线,半年价) AND CLOSE>牛熊,OPEN,CLOSE,0.5,0),COLORWHITE;


STICKLINE(CROSS(趋势线,年价) AND CLOSE>牛熊,OPEN,CLOSE,0.5,0),COLOR0080FF;


VAR6:=(HIGH+LOW+CLOSE)/3;


VAR7:=(VAR6-MA(VAR6,14))/(0.015*AVEDEV(VAR6,14));


DRAWICON(CROSS(VAR7,(-95)),LOW,26);


DRAWICON(CROSS(VAR7,100),HIGH,9);


VAR8:=EMA(CLOSE,5)-EMA(CLOSE,35);


VAR9:=EMA(VAR8,5);



DRAWICON(CROSS(VAR8,VAR9),LOW,1),NODRAW;


DRAWICON(CROSS(VAR9,VAR8),HIGH,2),NODRAW;


总周转率:FINANCE(20)/FINANCE(10)*100,NODRAW,COLORGREEN;


流动比:100*FINANCE(11)/FINANCE(15),NODRAW,COLORFF80FF;


速动比:100*(FINANCE(11)-FINANCE(27))/FINANCE(15),NODRAW,COLORLIMAGENTA;


净利率:FINANCE(30)/FINANCE(20)*100,NODRAW,COLORYELLOW;


现金负债比:FINANCE(25)/FINANCE(15),NODRAW,COLOR0080FF;


DRAWTEXT_FIX(CURRBARSCOUNT=1,0.939,0.88,0,VARCAT(VARCAT(1,VAR2STR(FINANCE(9),0)),2)),COLORLIRED;


DRAWTEXT_FIX(CURRBARSCOUNT=1,0.939,0.91,0,VARCAT(VARCAT(3,VAR2STR((1-FINANCE(21)/FINANCE(20))*100,0)),2)),COLORLIBLUE;


DRAWTEXT_FIX(CURRBARSCOUNT=1,0.939,0.935,0,VARCAT(VARCAT(4,VAR2STR(100*FINANCE(25)/FINANCE(30),0)),2)),COLORCYAN;


VAR10:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);


VAR11:=HIGH-REF(HIGH,1);



VAR12:=REF(LOW,1)-LOW;


VAR13:=EXPMEMA(IF(VAR11>0 AND VAR11>VAR12,VAR11,0),14);


VAR14:=EXPMEMA(IF(VAR12>0 AND VAR12>VAR11,VAR12,0),14);


VAR15:=VAR13*100/VAR10;


VAR16:=VAR14*100/VAR10;


VAR17:=EXPMEMA(ABS(VAR16-VAR15)/(VAR16+VAR15)*100,6);


VAR18:=EXPMEMA(VAR17,6);


DRAWICON(CROSS(VAR15,VAR16),HIGH*1.089,1),NODRAW;


DRAWICON(CROSS(VAR16,VAR15),LOW*0.998,8),NODRAW;


VAR19:=EMA(CLOSE,5)-EMA(CLOSE,35);


VAR20:=EMA(VAR19,5);


VAR21:=(VAR19-VAR20)*2;


DRAWICON(CROSS(VAR21,0),LOW*0.999,1),NODRAW;


DRAWICON(CROSS(0,VAR21),HIGH*1.003,2),NODRAW;

举报

扔鸡蛋(0) 回复

强少73
Lv.2
发表于 2020-3-28 22:24 复制 查看全部楼层
休闲者68 发表于 2020-3-28 20:27
VAR6:=(HIGH+LOW+CLOSE)/3;
VAR7:=(VAR6-MA(VAR6,14))/(0.015*AVEDEV(VAR6,14));
钻石:CROSS(VAR7,(-95)) ...

非常感谢老师!!!

举报

扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-3-28 20:27 复制 查看全部楼层
VAR6:=(HIGH+LOW+CLOSE)/3;
VAR7:=(VAR6-MA(VAR6,14))/(0.015*AVEDEV(VAR6,14));
钻石:CROSS(VAR7,(-95));

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表