手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS
江海会
Lv.2
发表于 2020-4-21 10:23 复制 查看全部楼层
论坛这二天又把我的指标抬出来,说明不少人认可。在此,我特别补充,参数可以设置成9,3,3。
查看全部打赏
  • 李金鑫+2理想币 : 点赞,知识的价值在于分享,谢谢!

举报

点亮(0) 扔鸡蛋(0) 回复

江海会
Lv.2
发表于 2020-4-21 10:17 复制 查看全部楼层
桃花剑神 发表于 2020-3-31 16:06
谢谢分享  请问期货适用吗

抱歉,我不懂期货,但我的波段经过多周期调试,比较符合实际。而且,我把参数保留空间,可以自己再调整优化。

举报

点亮(0) 扔鸡蛋(0) 回复

江海会
Lv.2
发表于 2020-4-21 09:34 复制 查看全部楼层
股市长1 发表于 2020-4-20 16:32
J是不是中间的N参数在设

参数9,3,3或5,3,3

举报

扔鸡蛋(0) 回复

股市长1
Lv.2
发表于 2020-4-20 16:32 复制 查看全部楼层
J是不是中间的N参数在设

举报

扔鸡蛋(0) 回复

陶瓷纤维
Lv.2
发表于 2020-4-20 13:36 复制 查看全部楼层
共同学习交流,感谢有理想论坛这个平台!

举报

扔鸡蛋(0) 回复

拾阶而上
Lv.3
发表于 2020-4-19 23:23 复制 查看全部楼层
下载源码后 飞狐通达信都不能用

举报

扔鸡蛋(0) 回复

拾阶而上
Lv.3
发表于 2020-4-19 23:22 复制 查看全部楼层
RSV:=(C-LLV(L,N))/(HHV(H,N)-LLV(L,N))*100;  
KO:=SMA(RSV,N1,1),Precision1;
DK:=SMA(KO,N2,1),Precision1;
JO:=3*KO-2*DK,Precision1;
FILLRGN(JO>90,JO,90),COLOR20E839;   
FILLRGN(JO<12,JO,12),COLORRED;   
FILLRGN(JO<>90,90,10),COLOR000000;
DRAWBAND(90,0,10,0);
J:JO,LINETHICK1,ColorWhite,Precision1;DRAWTEXT(ISLASTBAR,J,' J'),ColorWhite,LINETHICK16;
K:KO,COLORFF00FF,Precision1,nodraw;
D:DK,ColorGreen,Precision1,nodraw;
A2:=BARSLAST(REF(CROSS(KO,DK),1));
B2:=REF(C,A2+1)>C AND REF(KO,A2+1)<KO AND CROSS(KO,DK),coloryellow;
C2:=BARSLAST(REF(CROSS(DK,KO),1));
D2:=REF(C,C2+1)<C AND REF(KO,C2+1)>KO AND CROSS(DK,KO);
KDJ底背:=B2>0;
DRAWTEXT(B2>0,k*1.1,'   K底背'),COLORFF00FF;DRAWICON(B2>0,k*1.1,1);
KDJ顶背:=D2>0;DRAWTEXT(D2>0,k*1.2,'K顶背'),ColorGreen;
DRAWTEXT(CROSS(K,D),k*0.95,' K金'),ColorYellow;
RSI:SMA(MAX(c-REF(c,1),0),6,1)/SMA(ABS(c-REF(c,1)),6,1)*100,Precision0,COLORred;DRAWTEXT(ISLASTBAR,RSI,'       RSI'),ColorRed;
tja:=(2*C+H+L)/4;
tjb:=LLV(L,9);
tja1:=HHV(H,9);
BX:=EMA((tja-tjb)/(tja1-tjb)*100,8);
BX1:=EMA(BX,5);
DRAWBAND(BX,RGB(255,00,255),BX1,RGB(110,200,255));
短线多空:PARTLINE(bX>BX1,0),COLOR0000FF,LINETHICK2;DRAWTEXT(ISLASTBAR,短线多空,' 短线多空'),ColorBlue,LINETHICK15;
PARTLINE(BX<=BX1,0),ColorGreen,LINETHICK2;
DRAWTEXT(CROSS(BX,BX1),BX*0.95,' ↑▲反向'),ColorYellow;
TR1:=SMA(MAX(MAX(H-L,ABS(H-REF(C,1))),ABS(L-REF(C,1))),14,1);
HD:=H-REF(H,1);
LD:=REF(L,1)-L;
DMP:=SMA(IF(HD>0 AND HD>LD,HD,0),14,1);
DMM:=SMA(IF(LD>0 AND LD>HD,LD,0),14,1);
PDI:=DMP*100/TR1;
STICKLINE(RSI>90,0,30,0.5,0),ColorGreen;
DRAWTEXT(RSI>90,30*1.1,'!RIS'),ColorGreen;
10,linedot;  90,linedot;

举报

扔鸡蛋(0) 回复

桃花剑神
Lv.2
发表于 2020-3-31 21:22 复制 查看全部楼层

是直接复制这一段代码到公式里面吗?复制之后也不能用,而且没看懂为啥有两个n2。设置参数还是一样不能用。

举报

点亮(0) 扔鸡蛋(0) 回复

江海会
Lv.2
发表于 2020-3-31 18:04 复制 查看全部楼层
桃花剑神 发表于 2020-3-31 16:21
通达信删除了你说的那一行之后  还是提示
当前公式 : 短线双龙 (画线指标公式)  
错误句 : RSV:=(C-LLV(L ...

n=5,n1=3,n2=5,n2=3

举报

扔鸡蛋(0) 回复

江海会
Lv.2
发表于 2020-3-31 18:01 复制 查看全部楼层
马泰效应 发表于 2020-3-31 16:10
短线双龙(副,源码,无未来,开放式) [飞 狐]
这样不行。
标题这样写

xiao 哈

举报

扔鸡蛋(0) 回复

绿色心路
Lv.3
发表于 2020-3-31 17:39 复制 查看全部楼层
当前公式 : 短线双龙 (画线指标公式)  
错误句 : RSV:=(C-LLV(L,N))/(HHV(H,N)-LLV(L,N))*100
详细信息 : 未知字符串 N
错误起始位置 : 14 ; 长度: 1
拜托正确了再发行吗?缺共享币说啊。

举报

点亮(0) 扔鸡蛋(0) 回复

理想12a1dd
Lv.2
发表于 2020-3-31 16:38 复制 查看全部楼层
本帖最后由 理想12a1dd 于 2020-3-31 16:41 编辑

当前公式 : 短线双龙 (画线指标公式)  
错误句 : RSV:=(C-LLV(L,N))/(HHV(H,N)-LLV(L,N))*100
详细信息 : 未知字符串 N
错误起始位置 : 14 ; 长度: 1

举报

扔鸡蛋(0) 回复

桃花剑神
Lv.2
发表于 2020-3-31 16:21 复制 查看全部楼层
通达信删除了你说的那一行之后  还是提示
当前公式 : 短线双龙 (画线指标公式)  
错误句 : RSV:=(C-LLV(L,N))/(HHV(H,N)-LLV(L,N))*100
详细信息 : 未知字符串 N
错误起始位置 : 14 ; 长度: 1

举报

扔鸡蛋(0) 回复

马泰效应
Lv.8
发表于 2020-3-31 16:10 复制 查看全部楼层
短线双龙(副,源码,无未来,开放式) [飞 狐]
这样不行。
标题这样写

短线双龙(源码,副图,飞狐,贴图) 无未来
帮你再做一次规范
下次应该会了吧!

举报

点亮(1) 扔鸡蛋(0) 回复

江海会
Lv.2
发表于 2020-3-31 15:31 复制 查看全部楼层
本帖最后由 江海会 于 2020-3-31 15:32 编辑
利剑889 发表于 2020-3-31 15:13
不会弄。从来没有学过。


删除这一行:DRAWBAND(BX,RGB(255,00,255),BX1,RGB(110,200,255));
看波段趋势时看零轴颜色。红色为多。

举报

点亮(0) 扔鸡蛋(0) 回复

利剑889
Lv.3
发表于 2020-3-31 15:13 复制 查看全部楼层
不会弄。从来没有学过。

举报

扔鸡蛋(0) 回复

江海会
Lv.2
发表于 2020-3-31 15:06 复制 查看全部楼层
利剑889 发表于 2020-3-31 15:01
通达信不能用,可惜

把显示彩色带的一行删除就行。

举报

扔鸡蛋(0) 回复

利剑889
Lv.3
发表于 2020-3-31 15:01 复制 查看全部楼层
通达信不能用,可惜

举报

扔鸡蛋(0) 回复

江海会
Lv.2
发表于 2020-3-31 14:57 复制 查看全部楼层
一春一秋 发表于 2020-3-31 14:48
谢了大哥,通达信能用吧?

可以。会搞的,把显示彩色带的改一下。否则把一行删除就行。

举报

点亮(0) 扔鸡蛋(0) 回复

一春一秋
Lv.2
发表于 2020-3-31 14:48 复制 查看全部楼层
谢了大哥,通达信能用吧?

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表