请老师帮忙合成一个选股

[通达信] 1550 1
设置
2864019 Lv.2

专栏

发表于 2020-4-8 10:29 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
选股一
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
A:=250;
DIFF:=(EMA(CLOSE,12) - EMA(CLOSE,26));
DEA:=EMA(DIFF,9);
JH:=HHV(MAX(K,MAX(D,J)),A);
DH:=HHV(MAX(DIFF,DEA),A);
SH:=INTPART(JH/DH)/2;
DIFF50:=SH*DIFF+50;
DEA50:=SH*DEA+50;
红柱:=IF(1.5*(DIFF50-DEA50)>REF(1.5*(DIFF50-DEA50),1),1.5*(DIFF50-DEA50),0);
缩脚:=IF(1.5*(DIFF50-DEA50)<0 AND REF(1.5*(DIFF50-DEA50),1)< REF(1.5*(DIFF50-DEA50),2) AND 1.5*(DIFF50-DEA50)>REF(1.5*(DIFF50-DEA50),1),1,0);
红柱<-20 AND FILTER(缩脚,3) AND 缩脚;


选股二
X1:=BARSLAST(FILTER(((REF(C,3)-C)/REF(C,3)*100>3.2),10));
X2:=MAX(MAX(REF(H,X1+2),REF(H,X1+1)),REF(H,X1));
X3:=((C-REF(C,1))/REF(C,1)*100>5)AND ((C-REF(C,90))/REF(C,90)*100<80)AND((O-X2)/X2*100<30)AND(X1<150);
X4:= (V/MA(V,5)<3.5)AND (X1<150) AND ((C-LLV(L,X1))/LLV(L,X1)*100<50) AND ((C-REF(O,5))/REF(O,5)*100<30) ;
X5:=((((((C-MA(C,60))/MA(C,60))<0.1)=1) AND ((((C-MA(C,10))/MA(C,10))<0.3)=1))*0.2);
X6:=  ((((((X5=0) AND (REF(X5,1)=0.2)) AND (REF((COUNT((X5=0.2),10)=10),1)=1))*-0.1))=-0.1) OR FILTER((X3 AND X4),15);
X8:=(V/REF(V,1)>1.2 AND COUNT(C>O,1)) OR (L>REF(H,1) AND COUNT(O>C,1) AND V/REF(V,1)>1.2);
X9:X6 AND CROSS(KDJ.K,KDJ.D) AND (C/O>1.03)  AND X8   AND C>MA(C,20)  AND C/(REF(C,1))>1.08   AND MA(C,60)>MA(C,120)  ;

举报

使用道具 扔鸡蛋 回复

2437593
Lv.7

专栏

发表于 2020-4-8 10:37 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
  • 狼要吃肉+2共享币 : 理想精神:分享,互助,友善,传递正能量!
查看全部打赏

举报

使用道具 点亮 (1) 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
2楼
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表