手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

波浪理论画线修改版(指标、主图、通达信、贴图)

[通达信] 71个推荐71
设置
9338 18 阿_都 Lv.3 发表于 · 2020-4-9 18:14 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
在论坛看到有网友在找通达信版本的波浪理论画线指标,特此奉上,我也是股友给的,然后经过一些修改调整。
指标效果如下图:

附件

画线3.png
画线2.png
画线1.png

波浪理论画线.tn6

10.02 KB, 下载次数: 112, 下载积分: 共享币 -10 个

举报

扔鸡蛋(0) 回复

铁劳
Lv.2
发表于 2020-4-18 06:29 复制 查看全部楼层
谢谢你的分享!!

举报

扔鸡蛋(0) 回复

阿_都
Lv.3
发表于 2020-4-10 19:50 复制 查看全部楼层

对于我来说,不适用,信号太频繁了。

举报

扔鸡蛋(0) 回复

乐了09
Lv.3
发表于 2020-4-10 17:18 复制 查看全部楼层
阿杜不懂 发表于 2020-4-9 23:34
最新:C,COLORFFFF00,LINETHICK5;
IF(C>=REF(C,1),C,DRAWNULL),COLOR0000FF,LINETHICK5;
AA:=SUM(AMOUNT ...

这是什么主图

举报

扔鸡蛋(0) 回复

古神2013
Lv.3
发表于 2020-4-10 16:10 复制 查看全部楼层
这个我喜欢,

举报

扔鸡蛋(0) 回复

阿_都
Lv.3
发表于 2020-4-10 09:02 复制 查看全部楼层
理想0251b0 发表于 2020-4-9 23:30
看趋势很不错,谢谢楼主分享

多谢认同,不过这个指标在我的指标库中只能算一般般的指标了。

举报

点亮(0) 扔鸡蛋(0) 回复

猎人刘长青
Lv.6
发表于 2020-4-10 07:04 复制 查看全部楼层
/:M

举报

扔鸡蛋(0) 回复

阿杜不懂
Lv.2
发表于 2020-4-9 23:34 复制 查看全部楼层
最新:C,COLORFFFF00,LINETHICK5;
IF(C>=REF(C,1),C,DRAWNULL),COLOR0000FF,LINETHICK5;
AA:=SUM(AMOUNT,BARSCOUNT(C))/SUM(VOL*100,BARSCOUNT(C));
BB:=BETWEEN(C/AA,C+H,C-H);
DRAWICON(ISLASTBAR AND C>REF(C,1),C,1);
DRAWICON(ISLASTBAR AND C<REF(C,1),C,2);
MD:=EMA(C,0)-EMA(C,5);

所属板块:=STRCAT('所属板块: ',STRCAT(STRCAT(STRCAT('[行业]-',HYBLOCK),STRCAT(' [地域]-',
DYBLOCK)),STRCAT(' [概念]-',GNBLOCK)));
总股本:=STRCAT(STRCAT('总股本: ',CON2STR(TOTALCAPITAL/1000000,2)),'亿');
流通盘:=STRCAT(STRCAT(' 流通盘: ',CON2STR(CAPITAL/1000000,2)),'亿');
全流通:=STRCAT(' 全流通: ',CON2STR((CAPITAL/1000000)/(TOTALCAPITAL/1000000),2));
市值:=STRCAT(STRCAT(' 流通市值: ',CON2STR((CAPITAL/1000000)*C,2)),'亿');
股本市值:=STRCAT('股本市值: ',STRCAT(STRCAT(STRCAT(总股本,流通盘),全流通),市值));
{业绩}
净资收益率:=STRCAT(' 净资收益率: ',CON2STR(FINANCE(29)/FINANCE(19)*100,2));
毛利率:=STRCAT(' 毛利率: ',CON2STR((FINANCE(20)-FINANCE(21))/FINANCE(20)*100,2));
主营利润率:=STRCAT(' 主营利润率 ',CON2STR(FINANCE(23)/FINANCE(20)*100,2));
当前业绩:=STRCAT('当前业绩: ',STRCAT(STRCAT(净资收益率,毛利率),主营利润率));
{主图显示}
DRAWTEXT_FIX(ISLASTBAR,0.020,0.700,0,所属板块),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0.020,0.800,0,股本市值),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.020,0.900,0,当前业绩),COLORGREEN;

绝密线:EXPMA(C,17),COLORRED,LINETHICK1;
乾坤线:EXPMA(EXPMA(CLOSE,50),1),LINETHICK1,COLORBLUE;
IF(乾坤线>=REF(乾坤线,1),乾坤线,DRAWNULL),COLORYELLOW,LINETHICK1;
买入:DRAWICON(CROSS(绝密线,乾坤线),乾坤线,34);
卖出:DRAWICON(CROSS(乾坤线,绝密线),乾坤线,35);
DRAWTEXT_FIX(1,0.70,0.55,0,STRCAT('净流入(万元):= ',CON2STR(ZJBY.净流入#DAY,2))),COLORWHITE;
DRAWTEXT_FIX(1,0.70,0.62,0,STRCAT('超大单(万元):= ',CON2STR(ZJBY.超大单#DAY,2))),COLORRED;
DRAWTEXT_FIX(1,0.70,0.69,0,STRCAT('大单(万元):= ',CON2STR(ZJBY.大单#DAY,2))),COLORGREEN;
DRAWTEXT_FIX(1,0.70,0.76,0,STRCAT('中单(万元):= ',CON2STR(ZJBY.中单#DAY,2))),COLORMAGENTA;
DRAWTEXT_FIX(1,0.70,0.83,0,STRCAT('小单(万元):= ',CON2STR(ZJBY.小单#DAY,2))),COLORCYAN;

{开盘后30分钟最高最低价}
NN:=BARSLAST(TIME2=100000);
ZSC:=BARSCOUNT(C);
GJ:=IF(ZSC=30,HHV(HIGH,30),0);
DJ:=IF(ZSC=30,LLV(LOW,30),0);
{最高价1:=DRAWLINE(GJ,GJ,REF(GJ,1),REF(GJ,1),1),COLORMAGENTA,DOTLINE;}
{最低价1:=DRAWLINE(DJ,DJ,REF(DJ,1),REF(DJ,1),1),COLORGREEN,DOTLINE;}
最高价30:IF(TIME2<=100000,HHV(H,FROMOPEN),REF(GJ,NN)),COLORMAGENTA,DOTLINE;
最低价30:IF(TIME2<=100000,LLV(LOW,FROMOPEN),REF(DJ,NN)),COLORCYAN,DOTLINE;
DRAWTEXT(ISLASTBAR,最高价30,CON2STR(最高价30,2)),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,最低价30,CON2STR(最低价30,2)),COLORCYAN;

开盘:DYNAINFO(4),COLORLICYAN,LINETHICK2;

RQ:=DATETODAY(DATE)-DATETODAY(REF(DATE,TOTALBARSCOUNT-CURRBARSCOUNT))+1;
JY:=BARSLAST((RQ-REF(RQ,1))!=WEEKDAY-REF(WEEKDAY,1) OR TOTALBARSCOUNT-CURRBARSCOUNT=0)+1;
MA1:=REF(C,JY);
MA2:=REF(MA1,JY);
MA3:=REF(MA2,JY);
MA4:=REF(MA3,JY);
MA5:=REF(MA4,JY);
MA6:=REF(MA5,JY);
MA7:=REF(MA6,JY);
MA8:=REF(MA7,JY);
MA9:=REF(MA8,JY);
CK:REFDATE((C+MA1+MA2+MA3+MA4+MA5+MA6+MA7+MA8+MA9)/10,DATE),COLORMAGENTA,LINETHICK2;
DRAWTEXT(ISLASTBAR,CK,'--- --- --- --- 参考线'),COLORAC59FF;

超大单:="ZJBY.超大单#DAY";
大单:="ZJBY.大单#DAY";
中单:="ZJBY.中单#DAY";
小单:="ZJBY.小单#DAY";
ZDZ:=MAX(MAX(ABS(超大单),ABS(大单)),MAX(ABS(中单),ABS(小单)));
M1:=超大单/ZDZ*300;
M2:=大单/ZDZ*300;
M3:=中单/ZDZ*300;
M4:=小单/ZDZ*300;
DRAWRECTREL(850,500-M1,870,500,RGB(255,0,0));
DRAWRECTREL(875,500-M2,895,500,RGB(0,255,0));
DRAWRECTREL(900,500-M3,920,500,RGB(255,0,255));
DRAWRECTREL(925,500-M4,945,500,RGB(0,255,255));

举报

点亮(0) 扔鸡蛋(0) 回复

云起168
Lv.2
发表于 2020-4-9 22:51 复制 查看全部楼层
有未来函数的画线图形都非常漂亮

举报

扔鸡蛋(0) 回复

阿_都
Lv.3
发表于 2020-4-9 21:21 复制 查看全部楼层
这么多人推荐呀

举报

扔鸡蛋(0) 回复

逍遥村夫
Lv.3
发表于 2020-4-9 20:54 复制 查看全部楼层
/:M/:M/:M/:M/:M

举报

扔鸡蛋(0) 回复

阿_都
Lv.3
发表于 2020-4-9 19:15 复制 查看全部楼层
无时间限制,未来函数只用来画线

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表