手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助改成通达信选股公式

[通达信]
设置
1745 9 刘写乐乐 Lv.3 发表于 · 2020-5-19 11:32 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
麻烦老师帮改一个公式,条件是:主力资金=1 的时候的选股预警公式,谢谢

DRAWGBK(CLOSE>0,RGB(0,0,0),RGB(0,50,50),0,1,0);
X_1:=VOL;
X_2:=SMA((CLOSE-REF(CLOSE,1))*X_1,3,1)/10000;
X_3:=EMA(X_2,12)-EMA(X_2,26);
X_4:=EMA(X_3,9);
X_5:=(X_3-X_4)*2;
主力资金:X_5,NODRAW,COLORYELLOW;
流入:CROSS(X_5,0),NODRAW,COLORRED;
DRAWICON(CROSS(X_5,0),REF(X_5,1),38);
流出:CROSS(0,X_5),NODRAW,COLORGREEN;
DRAWICON(CROSS(0,X_5),REF(X_5,1),39);
X_6:=1;


X1:=CLOSE*VOL,NODRAW;
X2:=EMA((EMA(X1,3)/EMA(VOL,3)+EMA(X1,6)/EMA(VOL,6)+EMA(X1,12)/EMA(VOL,12)+EMA(X1,24)/EMA(VOL,24))/4,13),NODRAW;
X3:=(EMA(CLOSE,5)*7+EMA(CLOSE,10)*3)/10,NODRAW;


X_7:=X3;
X_8:=X1;
X_9:=X2;
X_10:=1.06*X_9;
X_11:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>6;
X_12:=EMA(HIGH,10)*(1+6/100);
X_13:=X_6 AND X_11>0 AND CROSS(CLOSE,X_12) AND CROSS(CLOSE,X_10);
X_14:=FILTER(CROSS(X_7,EMA(HIGH,55)*(1+10/100)),5);
黑马启动:IF(X_6 AND X_13,1,0),NODRAW,COLORRED;
非妖即顶:IF(X_6 AND X_14,1,0),NODRAW,COLORMAGENTA;
STICKLINE(X_5>0 AND X_5>=REF(X_5,1),X_5,0,3,1),COLORRED;
STICKLINE(X_5>0 AND X_5<REF(X_5,1),X_5,0,3,1),COLORGREEN;
STICKLINE(X_5<0,X_5,0,3,1),COLORCYAN;
STICKLINE(黑马启动>0,X_5,0,4,0),COLORRED;
STICKLINE(非妖即顶>0,X_5,0,4,0),COLORMAGENTA;
X_15:=X_6;
X_16:=IF(X_6<=0,0,HHVBARS(X_5,BARSLAST(X_5<0)+1));
X_17:=IF(X_15>0,CROSS(BACKSET(CROSS(0,X_5),REF(X_16,1)+2),0.5),0);
X_18:=CROSS(BACKSET(CROSS(0,X_5) OR (ISLASTBAR AND X_5>0),REF(X_16,1)+2),0.5);
X_19:=DRAWLINE(X_17,X_5,REF(X_17,1),REF(X_5,1),1);
NOTEXT前高:X_19,COLORGRAY;
X_20:=LLVBARS(X_5,BARSLAST(X_5>0)+1);
X_21:=CROSS(BACKSET(CROSS(X_5,0),REF(X_20,1)+2),0.5);

X_22:=BARSLAST(FILTERX(CROSS(0,X_5),BARSCOUNT(CLOSE)));
X_23:=DRAWLINE(X_21,X_5,REF(X_21,1),REF(X_5,1),1);
NOTEXT前低:X_23,COLORGRAY;
X_24:=IF(X_5<0,FILTERX(X_5=LLV(X_5,BARSLAST(X_5>0)),BARSCOUNT(CLOSE)),DRAWNULL);
X_25:=BARSLAST(X_24);
X_26:=FILTERX(X_5<CONST(LLV(X_5,X_22+1)),BARSCOUNT(CLOSE));
X_27:=BARSLAST(X_26);
X_28:=IF(X_22+1>=1,CONST(LLV(X_5,X_22+1)),DRAWNULL);
NOTEXT本低:X_28,COLORWHITE;
X_29:=CROSS(COUNT(CROSS(X_5>X_28/2 AND X_5<0,0.5),X_25)=1,0.5) AND X_25>=0;
X_30:=IF(ISLASTBAR AND X_5>0 AND X_5=HHV(X_5,BARSLAST(X_5<0)),1,IF(FILTERX(X_18,BARSCOUNT(CLOSE)),2,DRAWNULL));
X_31:=X_30=1 OR X_30=2 AND X_5>0;
X_32:=FILTERX(X_31,BARSCOUNT(CLOSE));
X_33:=DRAWLINE(X_32,X_5,REF(X_32,1),REF(X_5,1),1);
NOTEXT本高:X_33,COLORWHITE;
X_34:=CONST(REF(X_5,BARSLAST(X_32)));
X_35:=X_5>X_34;
X_36:=FILTERX(REFX(BARSLAST(X_35),1)=1,BARSCOUNT(CLOSE));
NOTEXT天数:BARSLAST(X_36),NODRAW,COLORYELLOW;
NOTEXT上横线:DRAWLINE(X_36,X_34,X_32,X_34,0),DOTLINE,COLORGREEN;
NOTEXT下横线:DRAWLINE(X_26,CONST(LLV(X_5,X_22+1)),X_24=1,X_5,0),DOTLINE,COLORYELLOW;
X_37:=IF(X_36,BARSNEXT(X_32),DRAWNULL);
X_38:=IF(NOTEXT天数>0 AND NOTEXT天数<=REF(X_37,NOTEXT天数),SUM(X_5>0,NOTEXT天数),DRAWNULL);
X_39:=REF(CLOSE,NOTEXT天数);
X_40:=(X_39-CLOSE)/CLOSE*100;
X_41:=BARSLAST(X_32);
X_42:=CROSS(COUNT(CROSS(X_5<X_33/2 AND X_5>0,0.5),X_32)=1,0.5) AND X_32>=0;
STICKLINE(X_5>X_19 AND X_33>X_19 AND BARSLAST(CROSS(X_5<X_33/2,0.5))>0 AND X_5>(X_19+X_33)/2,X_5,X_19,1,0),COLORYELLOW;
X_43:=IF(X_5>0 AND X_33!=X_19,DRAWLINE(X_42,(X_19+X_33)/2,REF(X_42,1),REF((X_19+X_33)/2,1),1),DRAWNULL);
STICKLINE(X_5>X_19,X_5,X_19,1,0),COLORYELLOW;
STICKLINE(X_42,X_5,0,1,0),COLORGREEN;
STICKLINE(X_5<0 AND X_5<X_23 AND X_23<0,X_5,X_23,1,0),COLORBLUE;
X_44:=IF(CROSS(X_5<0,0.5),BARSNEXT(X_24),DRAWNULL);
X_45:=BARSLAST(X_5>0)-1;
STICKLINE(BARSLAST(X_29)>=0 AND X_5<X_23 AND X_5<0,X_5,X_23,1,0),COLORGREEN;
STICKLINE(X_29,X_5,0,1,0),COLORWHITE;
STICKLINE(X_5>X_19 AND X_33>X_19 AND BARSLAST(X_42)>0,X_5,X_19,1,0),COLORRED;
STICKLINE(CROSS(X_19,0.01) OR CROSS(X_33,0.01),X_5,0,0,0),COLORWHITE;
STICKLINE(CROSS(X_23<0,0.01) OR CROSS(X_28<0,0.01),X_5,0,0,0),COLORWHITE;
IF(BARSLAST(X_29)>=0,X_28/2,DRAWNULL),DOTLINE,COLORRED;
股海淘金:DRAWNULL,COLORCCCCCC;
原创指标:DRAWNULL,COLORCCCCCC;

举报

扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-5-20 12:14 复制 查看全部楼层
注册111 发表于 2020-5-20 07:09
是不是这个意思。
TJ:=VOL>=REF(V,1)*1.91 AND C>REF(C,1)*1.07&&C=HHV(H,15)&&C>O;
T:=BARSLAST(TJ);
...

不明白你的意思。看看这样可以吗。
TJ:=VOL>=REF(V,1)*1.91 AND C>REF(C,1)*1.07&&C=HHV(H,15)&&C>O;
T:=BARSLAST(TJ);
L>REF(L,REF(T,1))&&TJ;

举报

点亮(0) 扔鸡蛋(0) 回复

刘写乐乐
Lv.3
发表于 2020-5-20 09:10 复制 查看全部楼层
注册111 发表于 2020-5-20 07:09
是不是这个意思。
TJ:=VOL>=REF(V,1)*1.91 AND C>REF(C,1)*1.07&&C=HHV(H,15)&&C>O;
T:=BARSLAST(TJ);
...

所有的高量柱都选出来,怎么就只有一个呢

举报

扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-5-20 07:09 复制 查看全部楼层
刘写乐乐 发表于 2020-5-19 19:41
谢谢。再麻烦老师根据下面的指标帮写个选股公式,条件是:1、高量柱的涨幅大于7%;2、高量柱收盘价是前 ...

是不是这个意思。
TJ:=VOL>=REF(V,1)*1.91 AND C>REF(C,1)*1.07&&C=HHV(H,15)&&C>O;
T:=BARSLAST(TJ);
L>REF(L,REF(T,1))&&REF(EVERY(C>REF(L,REF(T,1)),REF(T,1)),1)&&TJ;

附件

捕获.JPG

举报

点亮(0) 扔鸡蛋(0) 回复

刘写乐乐
Lv.3
发表于 2020-5-19 19:41 复制 查看全部楼层
注册111 发表于 2020-5-19 18:22
有未来。
X_1:=MAX(CLOSE,OPEN);
X_2:=MIN(CLOSE,OPEN);


谢谢。再麻烦老师根据下面的指标帮写个选股公式,条件是:1、高量柱的涨幅大于7%;2、高量柱收盘价是前期最高价(前期为15天);3、选股时最低价高于等于高量柱的最低价。4、高量柱到选股时之间的K线价柱的收盘价不低于高量柱的最低价。5、高量柱的阳线的高量柱,不是假阴真阳的高量柱。如图:
高量柱指标源码:


DRAWKLINE(H,O,L,C);
TJ:=VOL>=REF(V,1)*1.91 AND C>REF(C,1)*1.01;
DRAWTEXT(TJ,LOW*0.99,'↖高量柱'),COLORYELLOW;
STICKLINE(TJ,OPEN,CLOSE,1.5,0),COLORYELLOW;
K1:=SUMBARS(TJ,1);
STICKLINE(K1,REF(H,K1-1),REF(H,K1-1),10,0),COLORYELLOW;

附件

11.png

举报

点亮(0) 扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-5-19 18:22 复制 查看全部楼层
本帖最后由 注册111 于 2020-5-19 18:24 编辑
刘写乐乐 发表于 2020-5-19 17:30
这回好了,谢谢。麻烦老师在帮下面的选股公式加个条件吧,选股时的收盘价是近期最高价,近期定义为10天吧 ...


有未来。
X_1:=MAX(CLOSE,OPEN);
X_2:=MIN(CLOSE,OPEN);
X_3:=MA(CLOSE,20);
X_4:=BARSLASTCOUNT(CLOSE<X_3);
X_5:=BACKSET((X_4>=4)*X_4,X_4);
X_6:=BARSLASTCOUNT(CLOSE>X_3);
X_7:=BACKSET((X_6>=4)*X_6,X_6);
X_8:=BARSLASTCOUNT(NOT(X_5 OR X_7));
X_9:=BARSLASTCOUNT(REF(X_5>0,X_8));
X_10:=BARSLASTCOUNT(REF(X_7>0,X_8));
X_11:=FILTERX(LLV(X_2,X_9)=X_2,X_9);
X_12:=FILTERX(HHV(X_1,X_10)=X_1,X_10);
X_13:=REF(X_1,BARSLAST(X_12));
X_14:=REF(X_2,BARSLAST(X_11));
X_15:=BARSLAST(X_9=1);
X_16:=REF(X_13,BARSLAST(X_9));
X_17:=REF(X_14,X_15);
X_18:=X_16+(X_16-X_17)*0.191;
X_19:=REFDATE(X_18,DATE);
黄金突破:CROSS(CLOSE,X_19)&&H=HHV(H,10);

举报

点亮(2) 扔鸡蛋(0) 回复

刘写乐乐
Lv.3
发表于 2020-5-19 17:30 复制 查看全部楼层
注册111 发表于 2020-5-19 15:30
你的问题,要求没说对。我的问题,是没测试。
X_1:=VOL;
X_2:=SMA((CLOSE-REF(CLOSE,1))*X_1,3,1)/1000 ...

这回好了,谢谢。麻烦老师在帮下面的选股公式加个条件吧,选股时的收盘价是近期最高价,近期定义为10天吧。就是说选出的票是10日内的最高价

X_1:=MAX(CLOSE,OPEN);
X_2:=MIN(CLOSE,OPEN);
X_3:=MA(CLOSE,20);
X_4:=BARSLASTCOUNT(CLOSE<X_3);
X_5:=BACKSET((X_4>=4)*X_4,X_4);
X_6:=BARSLASTCOUNT(CLOSE>X_3);
X_7:=BACKSET((X_6>=4)*X_6,X_6);
X_8:=BARSLASTCOUNT(NOT(X_5 OR X_7));
X_9:=BARSLASTCOUNT(REF(X_5>0,X_8));
X_10:=BARSLASTCOUNT(REF(X_7>0,X_8));
X_11:=FILTERX(LLV(X_2,X_9)=X_2,X_9);
X_12:=FILTERX(HHV(X_1,X_10)=X_1,X_10);
X_13:=REF(X_1,BARSLAST(X_12));
X_14:=REF(X_2,BARSLAST(X_11));
X_15:=BARSLAST(X_9=1);
X_16:=REF(X_13,BARSLAST(X_9));
X_17:=REF(X_14,X_15);
X_18:=X_16+(X_16-X_17)*0.191;
X_19:=REFDATE(X_18,DATE);
黄金突破:CROSS(CLOSE,X_19);

举报

点亮(1) 扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-5-19 15:30 复制 查看全部楼层
刘写乐乐 发表于 2020-5-19 15:19
选不出来,可能是我没有说明白,是  流入=1  的选股公式。

你的问题,要求没说对。我的问题,是没测试。
X_1:=VOL;
X_2:=SMA((CLOSE-REF(CLOSE,1))*X_1,3,1)/10000;
X_3:=EMA(X_2,12)-EMA(X_2,26);
X_4:=EMA(X_3,9);
X_5:=(X_3-X_4)*2;
ref(X_5<0,1)&&X_5>0;

举报

点亮(2) 扔鸡蛋(0) 回复

刘写乐乐
Lv.3
发表于 2020-5-19 15:19 复制 查看全部楼层
注册111 发表于 2020-5-19 11:52
X_1:=VOL;
X_2:=SMA((CLOSE-REF(CLOSE,1))*X_1,3,1)/10000;
X_3:=EMA(X_2,12)-EMA(X_2,26);

选不出来,可能是我没有说明白,是  流入=1  的选股公式。

举报

点亮(1) 扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-5-19 11:52 复制 查看全部楼层
X_1:=VOL;
X_2:=SMA((CLOSE-REF(CLOSE,1))*X_1,3,1)/10000;
X_3:=EMA(X_2,12)-EMA(X_2,26);
X_4:=EMA(X_3,9);
X_5:=(X_3-X_4)*2;
X_5=1;

举报

点亮(2) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表