手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙做一个出现突袭信号的选股器,在添加一个条件股价大于expma60

[通达信]
设置
1465 6 纪钦尚 Lv.2 发表于 · 2020-5-19 18:52 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
F:=100*(C-REF(C,1))/REF(C,1); 今小昨:=IF(C<REF(O,1) AND F<0,1,0);  S1:=今小昨; 今小前:=IF(C<REF(O,2) AND F<0,1,0),LINETHICK0;  S2:=今小前; A1:=S1=0 AND REF(S1,1)=1 AND S2=0 AND REF(S2,1)=1 AND CROSS(ZIG(3,3) ,REF(ZIG(3 ,3),1)); A2:=S1=0 AND REF(S1,1)=1 AND S2=0 AND REF(S2,1)=1 AND CROSS(ZIG(3,5) ,REF(ZIG(3 ,5),1)); A3:=S1=0 AND REF(S1,1)=1 AND S2=0 AND REF(S2,1)=1 AND CROSS(ZIG(3,10) ,REF(ZIG(3 ,10),1)); STICKLINE(A1 AND A2 ,0,3,3,0)COLORGREEN; STICKLINE(A1 AND A2 ,0,1,3,0)COLORBLUE; STICKLINE(A1 AND A2 AND A3,0,5,3,0)COLORYELLOW; STICKLINE(A1 AND A2 AND A3,0,3,3,0)COLORFF00FF; STICKLINE(A1 AND A2 AND A3,0,1,3,0)COLORBLUE; DRAWTEXT(A3=1,3.8,'☆全仓杀入'),COLORRED;智勇出击: ZIG(3,6)>REF(ZIG(3,6),1)AND REF(ZIG(3,6),1)<REF(ZIG (3,6),2),COLORWHITE,LINETHICK2; DRAWTEXT(智勇出击=1,0.8,'突袭!'),COLORWHITE;小获且退: ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>REF(ZIG (3,10),2),COLORYELLOW,LINETHICK2; DRAWTEXT(小获且退=1,1.3,'撤退!'),COLORYELLOW; VAR3:=PEAKBARS(3,15,1)<10; VAR5:=IF(VAR3=1,2,0);顶:= IF(VAR5=2,2,0);大胜且归:IF(顶>REF(顶,1),2,0),COLORRED,LINETHICK2; DRAWTEXT(大胜且归=2,2,'将大跌逢高清跌完再买!'),COLORGREEN; VAR200:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100; VAR300:=SMA(SMA(VAR200,3,1),3,1)/28.57; VAR400:=EMA(VAR300,5);操盘:=3*VAR300-2*VAR400; A4:=CROSS(操盘,VAR300) AND VAR300<2.1 AND C>O; DRAWTEXT(A4,0.2.1,'关注'),COLORYELLOW;选底:TROUGHBARS(3,15,1)<4,NODRAW; DRAWTEXT(FILTER(选底=1,3),0.2,'准备抄底'),COLOR00FF00;出★逢低买:CROSS(ZIG(3,10) ,REF(ZIG(3 ,10),1)) ; DRAWTEXT(出★逢低买>0,2,'☆逢低买');

附件

Screenshot_20200519_183742.jpg

举报

扔鸡蛋(0) 回复

踏雪无痕517
Lv.2
发表于 2020-5-19 21:05 复制 查看全部楼层
好好,谢谢

举报

扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-5-19 21:03 复制 查看全部楼层
踏雪无痕517 发表于 2020-5-19 21:00
按K线 ,在K线的下面

L*0.98{根据需要自己调整}

举报

扔鸡蛋(0) 回复

踏雪无痕517
Lv.2
发表于 2020-5-19 21:00 复制 查看全部楼层
休闲者68 发表于 2020-5-19 20:58
没有指标源码,不知道字的位置是按K线还是按均线或者是按什么比例设置的。

按K线 ,在K线的下面

举报

扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-5-19 20:58 复制 查看全部楼层
踏雪无痕517 发表于 2020-5-19 20:35
老师好,请问怎么 将 K线下面的字 离K线下影线 远一点呢 ,  太近看起来太乱了

没有指标源码,不知道字的位置是按K线还是按均线或者是按什么比例设置的。

举报

点亮(0) 扔鸡蛋(0) 回复

踏雪无痕517
Lv.2
发表于 2020-5-19 20:35 复制 查看全部楼层
休闲者68 发表于 2020-5-19 20:01
{指标含有未来函数ZIG!慎用!}
EXP2:=EMA(CLOSE,50);
突袭!: ZIG(3,6)>REF(ZIG(3,6),1)AND REF(ZIG(3,6), ...

老师好,请问怎么 将 K线下面的字 离K线下影线 远一点呢 ,  太近看起来太乱了

附件

微信图片_20200519202930.png

举报

点亮(1) 扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-5-19 20:01 复制 查看全部楼层
{指标含有未来函数ZIG!慎用!}
EXP2:=EMA(CLOSE,50);
突袭!: ZIG(3,6)>REF(ZIG(3,6),1)AND REF(ZIG(3,6),1)<REF(ZIG (3,6),2) AND C>EXP2;

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表