手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙把主图第一个龙字出现做个选股提示(之后出现龙字提示就不要了)

[通达信]
设置
1624 1 风含笑204 Lv.2 发表于 · 2020-5-19 20:21 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
VAR3:=LLV(HIGH,240);
VAR4:=100*(CLOSE-VAR3)/VAR3;
VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;
VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;
VAR7:=0;
VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;
VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;
VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);
买1:=VAR10;
买2:=(VAR11+VAR13+VAR15+VAR17);
卖1:=(VAR12+VAR14+VAR16+VAR18);
B:IF(买1>0 OR 买2>0,LOW*0.99,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW;
DRAWTEXT(买1>0 OR 买2>0,LOW*0.99,'小仓位买入'),COLORRED;
S:IF(卖1>0,HIGH*1.01,DRAWNULL),CROSSDOT,LINETHICK3,COLORGREEN;
DRAWTEXT(卖1>0,HIGH*1.02,'庄家出货'),COLORGREEN;


{涨跌停显示}
涨停:=IF((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(O,1)),1,0);
STICKLINE(涨停,O,C,1,0),COLORYELLOW;
ZDF:=(C-REF(C,1))/REF(C,1)*100;
STICKLINE(ZDF<-9.9,O,C,1,0),COLORBLUE;

AQ1:=REF(V,1);AQ2:=DVOL;AQ3:=AQ2/AQ1;
LNX:=AQ3-REF(AQ3,1);
E1:=REF(C,1);E2:=DCLOSE;E3:=(E2-E1)/E1*100;
QMX:=E3-REF(E3,1);
XG:=CROSS(LNX,500) AND CROSS(QMX,10);
DRAWTEXT(XG=1,L*0.995,'--钻石买入'),COLORFFCC88;
DRAWICON(XG=1,L*0.993,25);


A0:=((L+H+C*2)/4);
上:EMA(A0,14)*1.1382,COLORYELLOW,LINETHICK2;
{上B:REFDATE(上,DATE),COLORYELLOW,DOTLINE;}
DRAWNUMBER(ISLASTBAR,上,上),COLORWHITE;
中:EMA(A0,14)*1.0618,COLORWHITE,LINETHICK2;
DRAWNUMBER(ISLASTBAR,中,中),COLORWHITE;
下:EMA(A0,14),COLORRED,LINETHICK2;
DRAWNUMBER(ISLASTBAR,下,下),COLORWHITE;
{A2:=EMA(A0,25)COLORLIBLUE,LINETHICK3;
A1X:=(下-REF(下,1))/REF(下,1)*100,NODRAW;
A2X:=(A2-REF(A2,1))/REF(A2,1)*100,NODRAW;
买:IF(A1X>=0,下,DRAWNULL),COLORRED,LINETHICK3;
卖:IF(A1X<0 AND A2X<0,下,DRAWNULL)COLORGREEN3;}
多空:EMA((EMA(CLOSE,29)+EMA(CLOSE,31)+EMA(CLOSE,33))/3,3),COLORYELLOW,LINETHICK3;
做空:=REF(多空,1),COLORGREEN,NODRAW;
A2:=EMA(多空,25)COLORLIBLUE,LINETHICK3;
A1X:=(多空-REF(多空,1))/REF(多空,1)*100,NODRAW;
A2X:=(A2-REF(A2,1))/REF(A2,1)*100,NODRAW;
买:IF(A1X>=0,多空,DRAWNULL),COLORMAGENTA,LINETHICK3;
卖:IF(A1X<0 AND A2X<0,多空,DRAWNULL),COLORGREEN,LINETHICK3;
{STICKLINE(做多>做空,做多,做空,3,0),COLORRED;
STICKLINE(做多<=做空,做多,做空,3,1),COLORGREEN;};
{高低连线支撑压力}
A1:=REF(H,8)=HHV(H,2*8+1);
B1:=FILTER(A1,8);
C1:=BACKSET(B1,8+1);
D1:=FILTER(C1,8);
R11:=BACKSET(ISLASTBAR,BARSLAST(D1)+1); S11:=R11>REF(R11,1);
A2B:=REF(L,8)=LLV(L,2*8+1);
B2:=FILTER(A2B,8);
C2:=BACKSET(B2,8+1);
D2:=FILTER(C2,8);
T11:=BACKSET(ISLASTBAR,BARSLAST(D2)+1); U11:=T11>REF(T11,1);
M:=INTPART(3*8/5);
A12:=REF(H,M)=HHV(H,2*M+1);
B12:=FILTER(A12,M);
C12:=BACKSET(B12,M+1);
D12:=FILTER(C12,M);
R112:=BACKSET(ISLASTBAR,BARSLAST(D12)+1); S112:=R112>REF(R112,1);
A22:=REF(L,M)=LLV(L,2*M+1);
B22:=FILTER(A22,M);
C22:=BACKSET(B22,M+1);
D22:=FILTER(C22,M);{低点}
T112:=BACKSET(ISLASTBAR,BARSLAST(D22)+1); U112:=T112>REF(T112,1);
压1:DRAWLINE(D1,H,S11,H,1),COLORGREEN;
压2:DRAWLINE(D12,H,S112,H,1),COLORLIBLUE;
支1:=DRAWLINE(D2,L,U11,L,1),COLORRED;
支2:=DRAWLINE(D22,L,U112,L,1),COLORLIRED;
{变动支撑压力}
PH:=TROUGHBARS(2,5,1);
LL:=HHV(H,PH);
TJ1:=LL=HIGH AND LL<REF(LL,1);
TS:=SUMBARS(TJ1,2);
TJ:=PEAKBARS(2,5,1)=1 AND TS>=PH;
PL:=BARSLAST(TJ);
支C:=IF(BARSLAST(TJ1),REF(LOW,BARSLAST(TJ1)),DRAWNULL),COLOREA91B5;
压C:=IF(BARSLAST(TJ),REF(HIGH,PL),DRAWNULL),COLORYELLOW;

{涨停表示}
LA:=BARSLAST(C>REF(C,1)*1.098);
LC:=REF(CLOSE,LA);
LO:=REF(OPEN,LA);
LAL:=REF(L,LA);
LAH:=REF(H,LA);

一涨停:=EVERY(C/REF(C,1)>=1.097 AND C=H,1);
双涨停:=EVERY(C/REF(C,1)>=1.097 AND C=H,2);
三涨停:=EVERY(C/REF(C,1)>=1.097 AND C=H,3) AND H>L;
策略1A:=EXIST((C/REF(C,2)-1)*100>20,2) AND COUNT(LC>LO,3)>=1 AND O<REF(C,1)  AND C<REF(C,1) AND C>O AND C>REF(O,1) AND REF(C,1)>REF(C,2) ;
策略1B:=EXIST(双涨停,3) AND COUNT(LC>LO,4)>=1 AND O<REF(C,1)  AND C<REF(C,1) AND C>O AND C>REF(O,1) AND REF(C,1)>REF(C,2) ;
DRAWTEXT(策略1A,LOW,'↖①'),COLORYELLOW;
DRAWTEXT(策略1B,LOW,'↖①'),COLORYELLOW;
{策略2:=EXIST(三涨停,5)  AND C>中  AND L<中*1.01618 AND C/REF(C,1)<1.05 AND HHV(H,5)/C>1.14;
DRAWTEXT(策略2,LOW,'↖②'),COLORYELLOW;}
角度:=ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*57.3;
持有:=EXIST(一涨停,5) AND 角度>75 AND C>上 AND C>REF(C,1) AND C>上 ;
突破:=角度>75 AND C>上 AND C>REF(C,1) AND C>上 {AND (H/C)<1.038};
DRAWTEXT(持有,LOW,'↖龙'),COLORYELLOW;
STICKLINE(突破,O,C,1,0),COLORMAGENTA;

附件

只要这第一个龙字提示

只要这第一个龙字提示

举报

扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-5-19 20:38 复制 查看全部楼层
本帖最后由 休闲者68 于 2020-5-19 20:43 编辑

A0:=((L+H+C*2)/4);
上:=EMA(A0,14)*1.1382;
一涨停:=EVERY(C/REF(C,1)>=1.097 AND C=H,1);
角度:=ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*57.3;
持有:=EXIST(一涨停,5) AND 角度>75 AND C>上 AND C>REF(C,1) AND C>上;

CROSS(持有,0.5);
查看全部打赏
  • 风含笑204+10理想币 +2共享币 : 点赞,知识的价值在于分享,谢谢!

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表