手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助编写个出现黄色柱体的K线时的选股公式

[通达信]
设置
1425 3 中国饭店 Lv.4 发表于 · 2020-5-19 21:32 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
TC3:=REF(C,1);
涨停1:=IF((C-TC3)*100/TC3>=(10-0.03*100/TC3),1,0);
STICKLINE(涨停1,OPEN,CLOSE,0.5,0),COLORYELLOW;
跌停1:=IF((TC3-C)*100/TC3>=(10-0.03*100/TC3),1,0);
STICKLINE(跌停1,OPEN,CLOSE,0.5,0),COLORBLUE;

MA5:=MA(C,5);
操作:=MA((L+H+C)/3,5);
筹码线:IF(CURRBARSCOUNT<INTPART(PPART(4)*100/2),CONST(COSTEX(REF(C,3),REF(C,4)))*1.03,DRAWNULL),COLORWHITE,LINETHICK1;
DRAWTEXT(CURRBARSCOUNT<4 AND CROSS(C,筹码线) AND C/REF(C,1)>1.05,L,'---突破!'),COLORMAGENTA;




AA05:=MA(C,5);
五日乖离率:=(C-AA05)/AA05*100;
BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);
加速度5:=EMA((速度5-REF(速度5,1)),3);
AA10:=MA(C,10);AA20:=MA(C,20);
BB10:=ATAN((AA10/REF(AA10,1)-1)*100)*180/3.1416;
AA30:=MA(C,30);
三拾日乖离率:=(C-AA30)/AA30*100;
VAR1:=(AA20-AA30)>REF((AA20-AA30),1) AND AA20>REF(AA20,1) AND AA30>REF(AA30,1);
PVAR2:=(AA30-AA20)<REF((AA30-AA20),1) AND AA20<REF(AA20,1) AND AA30<REF(AA30,1);
BB30:=ATAN((AA30/REF(AA30,1)-1)*100)*180/3.1416;
强势狙击:=FILTER(BB30>30 AND BB10>45 AND CROSS(BB05,60),10);
加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND AA05>REF(AA05,1)  AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA10>REF(AA10,1)
AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1)  ,10) ;
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<AA30;
布林上轨:=MA(CLOSE,24)+2*STD(CLOSE,24);
WMA5:=MA(C,5);
XJJ:=MA(C,5)>REF(MA(C,5),1) AND 布林上轨>REF(布林上轨,1) AND 布林上轨/MA(C,5)<1.07
AND O<布林上轨 AND C>布林上轨 AND C/REF(C,1)>1.031;
极速线:=MA(C,25)+MA(C,25)*20/100;
WXG1:=XJJ AND C>极速线;
WXG2:=O<MA(C,5) AND XJJ  AND C<极速线;
XGLL:=WXG1 OR WXG2;
XGPP:=XGLL AND NOT(REF(XGLL,1));
DRAWTEXT(XGPP,L*0.97,'加速'),COLORRED;
M:=88;N1:=6;VAR0A:=EMA(EMA(EMA(CLOSE,2),2),2);
MA13:=(MA(VAR0A,13)*0.99);
TLAMSENR:=MAX(MAX((HIGH-LOW),ABS((REF(CLOSE,1)-HIGH))),ABS((REF(CLOSE,1)-LOW)));
ATR:=MA(TLAMSENR,13);
VAR1AL:=(REF(CLOSE,1)-REF(ATR,1));
强弱线:(HHV(VAR1AL,12)),LINETHICK2,COLOR0080FF;
DRAWTEXT(ISLASTBAR,强弱线,'强弱线')COLOR0080FF;




上轨:=(1+11/100)*MA(CLOSE,10),COLORWHITE,DOTLINE;
下轨:=(1-9/100)*MA(CLOSE,10),COLORRED,DOTLINE;
中轨线:(上轨+下轨)/2,COLORGREEN,DOTLINE;


V1:="CCI";
V2:="KDJ.K";
V3:="MACD.DIF";
V4:="MTM";
V5:="RSI";
V6:="BIAS.BIAS2";
V7:="ACCER";
V8:="CYF";
V9:=3*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1)-2*SMA(SMA((C-LLV(L,27))/
(HHV(H,27)-LLV(L,27))*100,5,1),3,1);
V10:="WR";
线:=IF(V1>SMA(V1,5,3),1,0)+IF(V2>SMA(V2,5,3),1,0)+IF(V3>SMA(V3,5,3),1,0)+IF(V4>SMA(V4,5,3),1,0)
+IF(V5>SMA(V5,5,3),1,0)+IF(V6>SMA(V6,5,3),1,0)+IF(V7>SMA(V7,5,3),1,0)+IF(V8>SMA(V8,5,3),1,0)+
IF(V9>SMA(V9,5,3),1,0)+IF(V10<SMA(V10,5,3),1,0);
红:=线-(10-线);
TTV:=(2*C+O+H+L);
动能:=TTV/EMA(TTV,4)-1;
FF:=动能*100;
能增:=(FF-REF(FF,1))*10;
红升:=红-REF(红,1);
W:=CROSS(V9,SMA(V9,5,4)) OR V9>REF(V9,1);
停:=DYNAINFO(17)>0;
超短:=能增>=18 AND 红升>=8 AND 红>=0 AND 停;
EE:=红>=8 AND 红>REF(红+2,1);
低吸:=能增>=25 AND (红升>=8 OR EE) AND (CROSS(红,0) OR EE) AND C<45 AND REF(V9,1)<=80
AND DYNAINFO(4)<DYNAINFO(3)*1.098 AND 停;
黄线:=EMA(线,60)*10-50;
短进:=((红升>=12 AND 能增>=30) OR (红升>=16 AND 能增>=20)) AND CROSS(黄线,SMA(黄线,5,4)) AND
(XLPL.NOTEXT吸 OR XLPL.NOTEXT拉) AND C<38 AND 停;
DRAWTEXT(短进,L*0.985,'←短进'),COLORWHITE;

举报

扔鸡蛋(0) 回复

南洁
Lv.3
发表于 2020-5-20 15:49 复制 查看全部楼层
谢谢老师受累了

举报

扔鸡蛋(0) 回复

中国饭店
Lv.4
发表于 2020-5-19 21:48 复制 查看全部楼层
谢谢老师受累了

举报

扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-5-19 21:46 复制 查看全部楼层
TC3:=REF(C,1);
涨停1:(C-TC3)*100/TC3>=(10-0.03*100/TC3);

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表