手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙做个选股公式

[通达信]
设置
1596 7 阿明选股 Lv.4 发表于 · 2020-5-20 10:13 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
这个指标拜托老师帮忙做个(新庄建仓低于50)的选股公式,谢谢!

这个是源码

VAR2:=1/WINNER(CLOSE);
VAR3:=MA(CLOSE,13);
VAR4:=100-ABS((CLOSE-VAR3)/VAR3*100);
VAR5:=LLV(LOW,75);
VAR6:=HHV(HIGH,75);
VAR7:=(VAR6-VAR5)/100;
VAR8:=SMA((CLOSE-VAR5)/VAR7,20,1);
VAR9:=SMA((OPEN-VAR5)/VAR7,20,1);
VARA:=3*VAR8-2*SMA(VAR8,15,1);
VARB:=3*VAR9-2*SMA(VAR9,15,1);
VARC:=100-VARB;

拉升资金: MA(WINNER(CLOSE*0.95)*100,3),COLORYELLOW, ;
新庄建仓: (100-IF(VAR2>5,IF(VAR2<100,VAR2,VAR4-10),0)),COLORGREEN , ;
VARD:=拉升资金>VAR4;
VARE:=REF(LOW,1)*0.9;
VARF:=LOW*0.9;
VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;
VAR11:=EMA(VAR10,30);
VAR12:=CLOSE-REF(CLOSE,1);
VAR13:=MAX(VAR12,0);
VAR14:=ABS(VAR12);
VAR15:=SMA(VAR13,7,1)/SMA(VAR14,7,1)*100;
VAR16:=SMA(VAR13,13,1)/SMA(VAR14,13,1)*100;
VAR17:=BARSCOUNT(CLOSE);
VAR18:=SMA(MAX(VAR12,0),6,1)/SMA(ABS(VAR12),6,1)*100;
VAR19:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
VAR1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR1B:=SMA((SMA(VAR1A,4,1)-50)*2,3,1);
VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAR1D:=SMA(VAR1C,4,1);
VAR1E:=SMA(VAR1D,3,1);
VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
VAR20:=VAR18<=25 AND VAR19<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR11-CLOSE>=-0.25 AND VAR15<22 AND VAR16<28 AND VAR17>50;
VAR21:=(HIGH+LOW+CLOSE)/3;
VAR22:=(VAR21-MA(VAR21,14))/(0.015*AVEDEV(VAR21,14));
VAR23:=(VAR21-MA(VAR21,70))/(0.015*AVEDEV(VAR21,70));
VAR24:=IF(VAR22>=150 AND VAR22<200 AND VAR23>=150 AND VAR23<200,10,0);
VAR25:=IF(VAR22<=-150 AND VAR22>-200 AND VAR23<=-150 AND VAR23>-200,-10,VAR24);


过中轴线注意:(IF(VAR23>=200 AND VAR22>=150,15,IF(VAR23<=-200 AND VAR22<=-150,-15,VAR25))+50),COLORCC9900 ,LINETHICK3 ,CROSSDOT;
STICKLINE(VARD,VAR4,拉升资金,5,0), ;
STICKLINE(1,拉升资金,0,1,0),COLORYELLOW ,COLOR00AAFF ;
STICKLINE(1,新庄建仓,100,1,0),COLORGREEN, ;
STICKLINE(VAR20,0,80,5,0),COLORRED,LINETHICK3 ;
DRAWTEXT(CROSS(VAR20,0.5) AND COUNT(VAR20=1,10)=1,60,'有钱不赚是傻蛋!'),COLORYELLOW,LINETHICK2;
DRAWTEXT(CROSS(VARD,0.5) AND COUNT(VARD=1,10)=1,70,'赚钱我走啦!'),,COLORGREEN ;

附件

微信图片_20200520101053.png

举报

扔鸡蛋(0) 回复

起爆K线
Lv.1
发表于 2020-6-4 06:54 复制 查看全部楼层
注册111 发表于 2020-5-21 09:04
有未来。
LY:=11;
BL:=32;

谢谢老师                                

举报

点亮(0) 扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-5-21 09:16 复制 查看全部楼层
起爆K线 发表于 2020-5-20 12:36
诚心恳请老师帮忙写个ENE选股公式,(ENE参数 10  11   9)K线最高点曾经突破上轨或者站住上轨,不论绿线红 ...

参数在eneh上调。
(CROSS(C,ENE.UPPER)&&V>REF(V,1)*2.5)||(CROSS(H,ENE.UPPER)&&V>REF(V,1));

举报

点亮(0) 扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-5-21 09:04 复制 查看全部楼层
北方a 发表于 2020-5-20 10:41
抢主图
LY:=11;
BL:=32;

有未来。
LY:=11;
BL:=32;
CJQS:=XMA(CLOSE,LY);
JBQS:=XMA(CLOSE,BL);
N:=REF(JBQS,BL/2+1-CURRBARSCOUNT)/REF(JBQS,BL/2+2-CURRBARSCOUNT);
M:=REF(CJQS,LY/2+1-CURRBARSCOUNT)/REF(CJQS,LY/2+2-CURRBARSCOUNT);
下轨:=IF(CURRBARSCOUNT>BL/2,JBQS*0.9,REF(JBQS,BL/2+1-CURRBARSCOUNT)*POW(N,BL/2+1-CURRBARSCOUNT)*0.9);
短下轨:=IF(CURRBARSCOUNT>LY/2,CJQS*0.95,REF(CJQS,LY/2+1-CURRBARSCOUNT)*POW(M,LY/2+1-CURRBARSCOUNT)*0.95);
O<=短下轨&&CROSS(短下轨,下轨);

举报

点亮(0) 扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-5-21 08:57 复制 查看全部楼层
VAR2:=1/WINNER(CLOSE);
VAR3:=MA(CLOSE,13);
VAR4:=100-ABS((CLOSE-VAR3)/VAR3*100);
VAR5:=LLV(LOW,75);
VAR6:=HHV(HIGH,75);
VAR7:=(VAR6-VAR5)/100;
VAR8:=SMA((CLOSE-VAR5)/VAR7,20,1);
VAR9:=SMA((OPEN-VAR5)/VAR7,20,1);
VARA:=3*VAR8-2*SMA(VAR8,15,1);
VARB:=3*VAR9-2*SMA(VAR9,15,1);
VARC:=100-VARB;
新庄建仓:=(100-IF(VAR2>5,IF(VAR2<100,VAR2,VAR4-10),0)) ;
CROSS(50,新庄建仓);

举报

点亮(0) 扔鸡蛋(0) 回复

起爆K线
Lv.1
发表于 2020-5-20 12:36 复制 查看全部楼层
诚心恳请老师帮忙写个ENE选股公式,(ENE参数 10  11   9)K线最高点曾经突破上轨或者站住上轨,不论绿线红线,没有其他条件,案例一比如世运电路2020年4月15号,放量站上去,或者金桥信息2020年4月1号上影线曾经突破过,以上两个条件全部写进去组成一个选股公式,有酬!

举报

扔鸡蛋(0) 回复

北方a
Lv.1
发表于 2020-5-20 10:41 复制 查看全部楼层
抢主图
LY:=11;
BL:=32;
CJQS:=XMA(CLOSE,LY);
JBQS:=XMA(CLOSE,BL);
N:=REF(JBQS,BL/2+1-CURRBARSCOUNT)/REF(JBQS,BL/2+2-CURRBARSCOUNT);
M:=REF(CJQS,LY/2+1-CURRBARSCOUNT)/REF(CJQS,LY/2+2-CURRBARSCOUNT);
上轨:IF(CURRBARSCOUNT>BL/2,JBQS*1.1,REF(JBQS,BL/2+1-CURRBARSCOUNT)*POW(N,BL/2+1-CURRBARSCOUNT)*1.1),LINETHICK2;
下轨:IF(CURRBARSCOUNT>BL/2,JBQS*0.9,REF(JBQS,BL/2+1-CURRBARSCOUNT)*POW(N,BL/2+1-CURRBARSCOUNT)*0.9),LINETHICK2;
短上轨:IF(CURRBARSCOUNT>LY/2,CJQS*1.05,REF(CJQS,LY/2+1-CURRBARSCOUNT)*POW(M,LY/2+1-CURRBARSCOUNT)*1.05);
短下轨:IF(CURRBARSCOUNT>LY/2,CJQS*0.95,REF(CJQS,LY/2+1-CURRBARSCOUNT)*POW(M,LY/2+1-CURRBARSCOUNT)*0.95);
DRAWTEXT(O<=短下轨,(L * 0.98),'抢'),COLORYELLOW;
DRAWTEXT(CROSS(H,短上轨),(H * 1.01),'逃'),COLORYELLOW;
{立桩量}
TJ:=VOL>=REF(V,1)*1.91 AND C>REF(C,1)*1.01;
STICKLINE(TJ,C,O+(C-O)/2,1,0),COLOR00FFFF;
{一穿三:5、10、20}
MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
MA3:=MA(CLOSE,20);
一穿三:=MA1>O AND MA2>O AND MA3>O AND MA1>C AND MA2>C AND MA3>C AND CLOSE>OPEN ;
STICKLINE(一穿三,O,O+(C-O)/2,1,0),COLORFF00FF;
AAA2:=SUM(IF( CLOSE>REF(CLOSE,1),VOL*C,0),0);
AAA3:=SUM(IF( CLOSE<REF(CLOSE,1),VOL*C,0),0);
AAA4:=SUM(IF( CLOSE=REF(CLOSE,1),VOL*C,0),0);
BB1:=0;
B1万元:=DVOL*DCLOSE/100;
B1差:=B1万元-REF(B1万元,1);
B2万元:=DVOL*DCLOSE/100;
B2比:=B2万元/REF(B2万元,1);
净流入万元:=(AAA2-AAA3-0.5*AAA4);
PM:=MA(净流入万元,1);
PMA:=PM/REF(PM,1)>1;
PMB:=REF(PMA,1)<1 AND PMA;
密码:(EMA(MA(B1万元,2),2))/100000,COLORYELLOW,NODRAW;
二日比:=密码/REF(密码,1);
选股:=PMB AND 密码>REF(密码,1) AND 二日比>1;
DRAWICON(选股,L,1);
Y:=CLOSE/REF(CLOSE,1)>1.07;
X:=VOL>MA(VOL,5);
A1:=Y AND X;
DRAWTEXT(A1,MA(CLOSE,5),'攻涨停'),COLORMAGENTA;
DRAWTEXT_FIX(1,0.00,0.10,0,''),COLORYELLOW;
DRAWTEXT_FIX(1,0.00,0.15,0,''),COLORYELLOW;

举报

点亮(1) 扔鸡蛋(0) 回复

北方a
Lv.1
发表于 2020-5-20 10:40 复制 查看全部楼层
请老师编写个选股公式,多谢。 [通达信]

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表